summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-04-27 10:06:52 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-04-27 10:06:52 +0000
commitbd1442e02b47e49b1d2e83ae2991a0140279dbd6 (patch)
tree523be8056f7ff94399663a7f876fd2cbcadbe694 /sci-libs/libdap
parentkeyword ~sparc-fbsd, bug #301705 (diff)
downloadgentoo-2-bd1442e02b47e49b1d2e83ae2991a0140279dbd6.tar.gz
gentoo-2-bd1442e02b47e49b1d2e83ae2991a0140279dbd6.tar.bz2
gentoo-2-bd1442e02b47e49b1d2e83ae2991a0140279dbd6.zip
Version bump. Drop old.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libdap')
-rw-r--r--sci-libs/libdap/ChangeLog12
-rw-r--r--sci-libs/libdap/files/3.10.0-fix_tests.patch11
-rw-r--r--sci-libs/libdap/files/libdap-3.9.2-gcc-4.4.patch26
-rw-r--r--sci-libs/libdap/libdap-3.10.0.ebuild50
-rw-r--r--sci-libs/libdap/libdap-3.8.2.ebuild44
-rw-r--r--sci-libs/libdap/libdap-3.9.2.ebuild53
-rw-r--r--sci-libs/libdap/libdap-3.9.3.ebuild46
7 files changed, 71 insertions, 171 deletions
diff --git a/sci-libs/libdap/ChangeLog b/sci-libs/libdap/ChangeLog
index 8562f8b692ff..6e4c378f35de 100644
--- a/sci-libs/libdap/ChangeLog
+++ b/sci-libs/libdap/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/libdap
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/ChangeLog,v 1.6 2009/12/07 06:27:24 bicatali Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/ChangeLog,v 1.7 2010/04/27 10:06:52 scarabeus Exp $
+
+*libdap-3.10.0 (27 Apr 2010)
+
+ 27 Apr 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/3.10.0-fix_tests.patch, -libdap-3.8.2.ebuild, -libdap-3.9.2.ebuild,
+ -files/libdap-3.9.2-gcc-4.4.patch, -libdap-3.9.3.ebuild,
+ +libdap-3.10.0.ebuild:
+ Version bump. Drop old.
*libdap-3.9.3 (07 Dec 2009)
diff --git a/sci-libs/libdap/files/3.10.0-fix_tests.patch b/sci-libs/libdap/files/3.10.0-fix_tests.patch
new file mode 100644
index 000000000000..a9025853338b
--- /dev/null
+++ b/sci-libs/libdap/files/3.10.0-fix_tests.patch
@@ -0,0 +1,11 @@
+diff -urN libdap-3.10.0.old//unit-tests/RCReaderTest.cc libdap-3.10.0//unit-tests/RCReaderTest.cc
+--- libdap-3.10.0.old//unit-tests/RCReaderTest.cc 2010-02-02 18:45:05.000000000 +0100
++++ libdap-3.10.0//unit-tests/RCReaderTest.cc 2010-04-27 12:00:16.000000000 +0200
+@@ -31,6 +31,7 @@
+ #include <unistd.h>
+ #endif
+
++#include <cstdlib>
+ #include <cstring>
+ #include <string>
+ #include <iostream>
diff --git a/sci-libs/libdap/files/libdap-3.9.2-gcc-4.4.patch b/sci-libs/libdap/files/libdap-3.9.2-gcc-4.4.patch
deleted file mode 100644
index ac7e856c41c0..000000000000
--- a/sci-libs/libdap/files/libdap-3.9.2-gcc-4.4.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- util_mit.cc.orig 2009-07-18 11:29:06.529751581 -0700
-+++ util_mit.cc 2009-07-18 11:30:08.898000932 -0700
-@@ -34,6 +34,7 @@
- };
-
- #include <cstring>
-+#include <cstdio>
- #include <cstdlib>
- #include <string>
- #include <ctype.h>
-@@ -59,13 +60,13 @@
-
- namespace libdap {
-
--static char * months[12] =
-+static const char * months[12] =
- {
- "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov", "Dec"
- };
-
- #ifndef HAVE_STRFTIME
--static char * wkdays[7] =
-+static const char * wkdays[7] =
- {
- "Sun", "Mon", "Tue", "Wed", "Thu", "Fri", "Sat"
- };
diff --git a/sci-libs/libdap/libdap-3.10.0.ebuild b/sci-libs/libdap/libdap-3.10.0.ebuild
new file mode 100644
index 000000000000..aebd761f1126
--- /dev/null
+++ b/sci-libs/libdap/libdap-3.10.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/libdap-3.10.0.ebuild,v 1.1 2010/04/27 10:06:52 scarabeus Exp $
+
+EAPI="3"
+
+inherit base
+
+DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
+HOMEPAGE="http://opendap.org/"
+SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 URI )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-util/cppunit
+ dev-libs/libxml2
+ net-misc/curl
+ sys-libs/zlib
+"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}/${PV}-fix_tests.patch" )
+
+RESTRICT="test"
+# needs http connection
+# FAIL: MIMEUtilTest
+
+src_compile() {
+ base_src_compile
+ if use doc; then
+ emake docs || die "make docs failed"
+ fi
+}
+
+src_test() {
+ cd "${S}"/unit-tests
+ emake check || die
+}
+
+src_install() {
+ base_src_install
+ dodoc README NEWS README.dodsrc || die
+ use doc && { dohtml docs/html/* || die ; }
+}
diff --git a/sci-libs/libdap/libdap-3.8.2.ebuild b/sci-libs/libdap/libdap-3.8.2.ebuild
deleted file mode 100644
index f9bac6170d63..000000000000
--- a/sci-libs/libdap/libdap-3.8.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/libdap-3.8.2.ebuild,v 1.3 2009/05/03 03:30:29 nerdboy Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="A C++ SDK which contains an implementation of DAP 2.0 and 3.2, both Client- and Server-side support."
-HOMEPAGE="http://opendap.org/index.html"
-SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 URI )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-util/cppunit
- dev-util/dejagnu"
-
-DEPEND="${RDEPEND}
- >=sys-libs/zlib-1.1.4
- >=dev-libs/libxml2-2.5.7
- >=net-misc/curl-7.12.0
- doc? ( app-doc/doxygen )"
-
-src_compile() {
- local myconf="--disable-dependency-tracking"
- econf ${myconf} || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use doc; then
- make docs || die "make docs failed"
- fi
-}
-
-src_test() {
- cd "${S}"/unit-tests && make check
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc README NEWS README.dodsrc README.AIS
- use doc && dohtml docs/html/*
-}
diff --git a/sci-libs/libdap/libdap-3.9.2.ebuild b/sci-libs/libdap/libdap-3.9.2.ebuild
deleted file mode 100644
index ceac7e6cdaa4..000000000000
--- a/sci-libs/libdap/libdap-3.9.2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/libdap-3.9.2.ebuild,v 1.5 2009/07/18 18:53:12 nerdboy Exp $
-
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="A C++ SDK which contains an implementation of DAP 2.0 and 3.2, both Client- and Server-side support."
-HOMEPAGE="http://opendap.org/index.html"
-SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 URI )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-util/cppunit
- dev-util/dejagnu"
-
-DEPEND="${RDEPEND}
- >=sys-libs/zlib-1.1.4
- >=dev-libs/libxml2-2.5.7
- >=net-misc/curl-7.12.0
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- eaclocal
- eautoreconf
-
- epatch "${FILESDIR}"/${P}-gcc-4.4.patch
-}
-
-src_compile() {
- local myconf="--disable-dependency-tracking"
- econf ${myconf} || die "econf failed"
- emake -j1 || die "emake failed"
-
- if use doc; then
- make docs || die "make docs failed"
- fi
-}
-
-src_test() {
- cd "${S}"/unit-tests && make check
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc README NEWS README.dodsrc README.AIS
- use doc && dohtml docs/html/*
-}
diff --git a/sci-libs/libdap/libdap-3.9.3.ebuild b/sci-libs/libdap/libdap-3.9.3.ebuild
deleted file mode 100644
index 7b72d717f9a2..000000000000
--- a/sci-libs/libdap/libdap-3.9.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libdap/libdap-3.9.3.ebuild,v 1.1 2009/12/07 06:27:24 bicatali Exp $
-
-EAPI=2
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
-HOMEPAGE="http://opendap.org/"
-SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 URI )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="doc"
-
-RDEPEND="dev-util/cppunit
- dev-util/dejagnu"
-
-DEPEND="${RDEPEND}
- >=sys-libs/zlib-1.1.4
- >=dev-libs/libxml2-2.5.7
- >=net-misc/curl-7.12.0
- doc? ( app-doc/doxygen )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.9.2-gcc-4.4.patch
-}
-
-src_compile() {
- emake || die "emake failed"
- if use doc; then
- emake docs || die "make docs failed"
- fi
-}
-
-src_test() {
- cd "${S}"/unit-tests
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README NEWS README.dodsrc README.AIS
- use doc && dohtml docs/html/*
-}