summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-03 09:30:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-03 09:30:24 +0000
commit1de1cfe7abf0966431d7e98d4844cbb1b0e56eb8 (patch)
tree9c11ee69f7b4d2ca1cde3e47c9b9ed6210dae6d7 /sci-libs/libcmatrix
parentSecurity version bump, bug #343389 (diff)
downloadgentoo-2-1de1cfe7abf0966431d7e98d4844cbb1b0e56eb8.tar.gz
gentoo-2-1de1cfe7abf0966431d7e98d4844cbb1b0e56eb8.tar.bz2
gentoo-2-1de1cfe7abf0966431d7e98d4844cbb1b0e56eb8.zip
New Addition, imported from sci overlay
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libcmatrix')
-rw-r--r--sci-libs/libcmatrix/ChangeLog11
-rw-r--r--sci-libs/libcmatrix/files/3.2.1-gcc4.4.patch12
-rw-r--r--sci-libs/libcmatrix/files/3.2.1-minuit2.patch14
-rw-r--r--sci-libs/libcmatrix/files/3.2.1-shared.patch80
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild50
-rw-r--r--sci-libs/libcmatrix/metadata.xml11
6 files changed, 178 insertions, 0 deletions
diff --git a/sci-libs/libcmatrix/ChangeLog b/sci-libs/libcmatrix/ChangeLog
new file mode 100644
index 000000000000..e5534ae43d4a
--- /dev/null
+++ b/sci-libs/libcmatrix/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/libcmatrix
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/ChangeLog,v 1.1 2010/11/03 09:30:24 jlec Exp $
+
+*libcmatrix-3.2.1 (03 Nov 2010)
+
+ 03 Nov 2010; Justin Lecher <jlec@gentoo.org> +files/3.2.1-gcc4.4.patch,
+ +libcmatrix-3.2.1.ebuild, +files/3.2.1-minuit2.patch,
+ +files/3.2.1-shared.patch, +metadata.xml:
+ New Addition, imported from sci overlay
+
diff --git a/sci-libs/libcmatrix/files/3.2.1-gcc4.4.patch b/sci-libs/libcmatrix/files/3.2.1-gcc4.4.patch
new file mode 100644
index 000000000000..24c1a89b48d0
--- /dev/null
+++ b/sci-libs/libcmatrix/files/3.2.1-gcc4.4.patch
@@ -0,0 +1,12 @@
+diff --git a/include/DynamicList.h b/include/DynamicList.h
+index f8c1346..05a7b10 100755
+--- a/include/DynamicList.h
++++ b/include/DynamicList.h
+@@ -4,6 +4,7 @@
+ #include "BaseList.h"
+ #include "lcm_basethreads.h"
+ #include "Warnings.h"
++#include <cstdio>
+
+ namespace libcmatrix {
+
diff --git a/sci-libs/libcmatrix/files/3.2.1-minuit2.patch b/sci-libs/libcmatrix/files/3.2.1-minuit2.patch
new file mode 100644
index 000000000000..24dc5628b8f0
--- /dev/null
+++ b/sci-libs/libcmatrix/files/3.2.1-minuit2.patch
@@ -0,0 +1,14 @@
+--- configure-libraries.ac 2008-03-04 00:48:46.000000000 +0100
++++ configure-libraries.ac.new 2009-03-19 18:22:21.000000000 +0100
+@@ -14,8 +14,8 @@
+ fi
+ if test x$FOUNDMINUIT = xyes; then
+ AC_CHECK_LIB(lcg_Minuit,main,,
+- AC_CHECK_LIB(Minuit,main,,FOUNDMINUIT=no
+- AC_MSG_WARN([Minuit library (liblcg_Minuit or libMinuit) not found
++ AC_CHECK_LIB(Minuit2,main,,FOUNDMINUIT=no
++ AC_MSG_WARN([Minuit library (liblcg_Minuit or libMinuit2) not found
+ Is LDFLAGS is defined to include relevant directory?])))
+ if test x$FOUNDMINUIT = xyes; then
+ AC_DEFINE(HAVE_LIBMINUIT)
+
diff --git a/sci-libs/libcmatrix/files/3.2.1-shared.patch b/sci-libs/libcmatrix/files/3.2.1-shared.patch
new file mode 100644
index 000000000000..9ab453d98b17
--- /dev/null
+++ b/sci-libs/libcmatrix/files/3.2.1-shared.patch
@@ -0,0 +1,80 @@
+diff --git a/Makefile.in b/Makefile.in
+index 1361371..1448e76 100755
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -13,8 +13,8 @@ AR=@AR@
+
+ # You shouldn't need to alter anything below here
+
+-COMPILE=$(CXX) $(CPPFLAGS) $(CXXFLAGS) -c
+-ALLOPTFLAGS=$(OPTFLAGS) -DNDEBUG
++COMPILE=$(CXX) $(CPPFLAGS) $(CXXFLAGS) -fPIC -c
++#ALLOPTFLAGS=$(OPTFLAGS) -DNDEBUG
+
+ LOCALOBJS= local/CrystalSystem.o local/CrystalGeneric.o local/MoleculeStructure.o
+ COREOBJS= coredefs/complex.o coredefs/common.o coredefs/diagonal.o coredefs/diagonalise.o coredefs/power.o coredefs/invert.o coredefs/transforms.o coredefs/blocking.o coredefs/mixed.o coredefs/realtransforms.o coredefs/Chebyshev.o
+@@ -36,7 +36,7 @@ ALLTHROBJS=$(UNSAFEOBJS:.o=_r.o) $(ALLSAFEOBJS)
+
+ ROOT=..
+
+-first: lib/libcmatrix.a
++first: lib/libcmatrix.so.3.2.1
+
+ #%.o: %.f
+ # @F77@ @FFLAGS@ -c -o $@ $<
+@@ -68,25 +68,25 @@ tempclean:
+ # -cd optim; @CLEAN@
+ # -cd local; @CLEAN@
+
+-lib/libcmatrix.a: $(ALLNORMOBJS)
+- $(AR) $@ $(ALLNORMOBJS)
+- chmod a+rx $@
+- $(RANLIB) $@
+-
+-lib/libcmatrix_p.a: $(ALLPROFOBJS)
+- $(AR) $@ $(ALLPROFOBJS)
+- chmod a+rx $@
+- $(RANLIB) $@
+-
+-lib/libcmatrix-g.a: $(ALLGOBJS)
+- $(AR) $@ $(ALLGOBJS)
+- chmod a+rx $@
+- $(RANLIB) $@
+-
+-lib/libcmatrix_r.a: $(ALLTHROBJS)
+- $(AR) @MTFLAGS@ $@ $(ALLTHROBJS)
+- chmod a+rx $@
+- $(RANLIB) $@
++lib/libcmatrix.so.3.2.1: $(ALLNORMOBJS)
++ $(CXX) $(LDFLAGS) -fPIC -shared -Wl,--soname,libcmatrix.so.3 -o $@ $(ALLNORMOBJS)
++ ln -sf libcmatrix.so.3.2.1 lib/libcmatrix.so.3
++ ln -sf libcmatrix.so.3.2.1 lib/libcmatrix.so
++
++lib/libcmatrix_p.so.3.2.1: $(ALLPROFOBJS)
++ $(CXX) $(LDFLAGS) -fPIC -shared -Wl,--soname,libcmatrix.so.3 -o $@ $(ALLPROFOBJS)
++ ln -sf libcmatrix_p.so.3.2.1 lib/libcmatrix_p.so.3
++ ln -sf libcmatrix_p.so.3.2.1 lib/libcmatrix_p.so
++
++lib/libcmatrix-g.so.3.2.1: $(ALLGOBJS)
++ $(CXX) $(LDFLAGS) -fPIC -shared -Wl,--soname,libcmatrix.so.3 -o $@ $(ALLGOBJS)
++ ln -sf libcmatrix-g.so.3.2.1 lib/libcmatrix-g.so.3
++ ln -sf libcmatrix-g.so.3.2.1 lib/libcmatrix-g.so
++
++lib/libcmatrix.so_r.3.2.1: $(ALLTHROBJS)
++ $(CXX) $(LDFLAGS) -fPIC -shared -Wl,--soname,libcmatrix.so.3 -o $@ $(ALLTHROBJS)
++ ln -sf libcmatrix_r.so.3.2.1 lib/libcmatrix_r.so.3
++ ln -sf libcmatrix_r.so.3.2.1 lib/libcmatrix_r.so
+
+ @CONFIGLEAF@.tar.gz:
+ cd $(ROOT) ; tar --exclude lib/* --exclude *.o --exclude=*~ --exclude=Makefile --exclude=include/config.h --exclude=config.status -cvf @CONFIGLEAF@.tar @CONFIGLEAF@
+diff --git a/configure.ac b/configure.ac
+index c0ae0e1..50dcd5a 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,5 +1,6 @@
+ AC_INIT(configure.ac)
+ AC_CONFIG_HEADER(include/config.h)
++LT_INIT
+
+ DEFAR="ar ru"
+ MAKEEXTRA=
diff --git a/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild b/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild
new file mode 100644
index 000000000000..01522394aec2
--- /dev/null
+++ b/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild,v 1.1 2010/11/03 09:30:24 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+MY_P="${PN}${PV}_lite"
+
+DESCRIPTION="lite version of pNMRsim"
+HOMEPAGE="http://www.dur.ac.uk/paul.hodgkinson/pNMRsim/"
+#SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
+SRC_URI="http://dev.gentooexperimental.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atlas threads"
+
+RDEPEND="
+ sci-libs/minuit
+ atlas? ( sci-libs/blas-atlas )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}R3
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-shared.patch \
+ "${FILESDIR}"/${PV}-minuit2.patch \
+ "${FILESDIR}"/${PV}-gcc4.4.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-minuit \
+ $(use_with atlas) \
+ $(use_with threads)
+}
+
+src_install() {
+ dolib.so lib/*.so* || die "install failed"
+
+ insinto /usr/include/${PN}R3
+ doins include/* || die "no includes"
+
+ dodoc CHANGES docs/* || die "no docs"
+}
diff --git a/sci-libs/libcmatrix/metadata.xml b/sci-libs/libcmatrix/metadata.xml
new file mode 100644
index 000000000000..ae22c398e6ee
--- /dev/null
+++ b/sci-libs/libcmatrix/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name='atlas'>Use of atlas blas implementation</flag>
+</use>
+</pkgmetadata>