summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-10-31 14:29:55 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-10-31 14:29:55 +0000
commit8b35e2955f1cee0177a40226630924360669f341 (patch)
tree025dab8780d0fe8aa26982d2169dfc076bff38e9 /sci-libs/lapack-atlas
parentpkg_postinst was being overridden without calling gnome2_pkg_postinst so sche... (diff)
downloadgentoo-2-8b35e2955f1cee0177a40226630924360669f341.tar.gz
gentoo-2-8b35e2955f1cee0177a40226630924360669f341.tar.bz2
gentoo-2-8b35e2955f1cee0177a40226630924360669f341.zip
Version bump to latest development snapshot. Ebuild now uses atlas' build system to select compiler and flags (see bug #144314).
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'sci-libs/lapack-atlas')
-rw-r--r--sci-libs/lapack-atlas/ChangeLog9
-rw-r--r--sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.1912
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.7.19.ebuild166
3 files changed, 186 insertions, 1 deletions
diff --git a/sci-libs/lapack-atlas/ChangeLog b/sci-libs/lapack-atlas/ChangeLog
index 2fb8aa88dada..0327b98693ee 100644
--- a/sci-libs/lapack-atlas/ChangeLog
+++ b/sci-libs/lapack-atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/lapack-atlas
# Copyright 2004-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.30 2006/10/03 19:52:50 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.31 2006/10/31 14:29:55 markusle Exp $
+
+*lapack-atlas-3.7.19 (31 Oct 2006)
+
+ 31 Oct 2006; Markus Dittrich <markusle@gentoo.org>
+ -lapack-atlas-3.7.17.ebuild, +lapack-atlas-3.7.19.ebuild:
+ Version bump to latest development snapshot. Ebuild now uses
+ atlas' build system to select compiler and flags (see bug #144314).
03 Oct 2006; Markus Dittrich <markusle@gentoo.org>
+files/atlas-asm-gentoo.patch, lapack-atlas-3.7.17.ebuild:
diff --git a/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.19 b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.19
new file mode 100644
index 000000000000..417d70b5f179
--- /dev/null
+++ b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.19
@@ -0,0 +1,12 @@
+MD5 0620639af548077cfbceab27bd7f667f atlas-3.7.19-shared-libs.patch.bz2 6295
+RMD160 d9bf35bd529decd7245c929356b383d5ac4972e4 atlas-3.7.19-shared-libs.patch.bz2 6295
+SHA256 874aa6b2be5ec5dbe576a5a6c8d0a11755a2043b8b437aa52c4b077adb2fed26 atlas-3.7.19-shared-libs.patch.bz2 6295
+MD5 2d7d468a8facf9675c400dcbb8a759c0 atlas3.7.19.tar.bz2 1748440
+RMD160 958508bc1dcf03a0a347931817371de5dcb569f7 atlas3.7.19.tar.bz2 1748440
+SHA256 a4cbd3bf05dfe53883d698e3f7b64dd0c244b14814d5ea4cbeb541348a1f4256 atlas3.7.19.tar.bz2 1748440
+MD5 c35802e688f28f8f65632fb93aad69d8 lapack-20020531-20021004.patch.bz2 59736
+RMD160 126a579d242664dce53d23cdd7bef935e81b5031 lapack-20020531-20021004.patch.bz2 59736
+SHA256 19bcae60fcec3742563d8b27e21da52677b18520c54cf0cb7a51537ec3dbd29c lapack-20020531-20021004.patch.bz2 59736
+MD5 a24f59304f87b78cdc7da2ae59c98664 lapack.tgz 4991992
+RMD160 630f9d7b4b37b0d39bccd4816198271b7e9e0cce lapack.tgz 4991992
+SHA256 393613641f80745e7e8445fd0f3e4f5f66a5e340c8115cd4d780b0f53e2b31a6 lapack.tgz 4991992
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.7.19.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.7.19.ebuild
new file mode 100644
index 000000000000..d1c1cc5d472e
--- /dev/null
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.7.19.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.19.ebuild,v 1.1 2006/10/31 14:29:55 markusle Exp $
+
+inherit eutils flag-o-matic toolchain-funcs fortran
+
+DESCRIPTION="Full LAPACK implementation using available ATLAS routines"
+LICENSE="BSD"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN="${PN/lapack-/}"
+SRC_URI1="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2"
+SRC_URI2="http://www.netlib.org/lapack/lapack.tgz"
+SRC_URI="${SRC_URI1} ${SRC_URI2}
+ mirror://gentoo/lapack-20020531-20021004.patch.bz2
+ mirror://gentoo/${MY_PN}-${PV}-shared-libs.patch.bz2"
+
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/blas
+ app-admin/eselect-lapack"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5
+ ~sci-libs/blas-atlas-3.7.19"
+
+PROVIDE="virtual/lapack"
+
+FORTRAN="g77 gfortran"
+
+S="${WORKDIR}/ATLAS"
+S_LAPACK="${WORKDIR}/LAPACK"
+BLD_DIR="${S}/gentoo-build"
+RPATH="${DESTTREE}/$(get_libdir)/lapack/atlas"
+
+pkg_setup() {
+ fortran_pkg_setup
+ echo
+ ewarn "Please make sure to disable CPU throttling completely"
+ ewarn "during the compile of lapack-atlas. Otherwise, all atlas"
+ ewarn "generated timings will be completely random and the"
+ ewarn "performance of the resulting libraries will be degraded"
+ ewarn "considerably."
+ echo
+ epause 8
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+
+ epatch "${DISTDIR}"/${MY_PN}-${PV}-shared-libs.patch.bz2
+ epatch "${FILESDIR}"/${MY_PN}-asm-gentoo.patch
+ epatch "${DISTDIR}"/lapack-20020531-20021004.patch.bz2
+ epatch "${FILESDIR}"/lapack-reference-3.0-autotool.patch
+
+ cd "${S}"
+ mkdir ${BLD_DIR} || die "failed to generate build directory"
+ cp "${FILESDIR}"/war "${BLD_DIR}" && chmod a+x "${BLD_DIR}"/war \
+ || die "failed to install war"
+
+ # make sure the compile picks up the proper includes
+ sed -e 's|INCLUDES =|INCLUDES = -I/usr/include/atlas/|' \
+ -i CONFIG/src/SpewMakeInc.c || \
+ die "failed to append proper includes"
+
+ # force proper 32/64bit libs
+ local archselect
+ if [[ "${ARCH}" == "amd64" || "${ARCH}" == "ppc64" ]]; then
+ archselect="-b 64"
+ else
+ archselect="-b 32"
+ fi
+
+ # set up compiler/flags using atlas' native configure
+ local compdefs
+ compdefs="${compdefs} -C xc '$(tc-getCC)' -F xc '${CFLAGS}'"
+ compdefs="${compdefs} -C ic '$(tc-getCC)' -F ic '${CFLAGS}'"
+ compdefs="${compdefs} -C sk '$(tc-getCC)' -F sk '${CFLAGS}'"
+ compdefs="${compdefs} -C dk '$(tc-getCC)' -F dk '${CFLAGS}'"
+ compdefs="${compdefs} -C sm '$(tc-getCC)' -F sm '${CFLAGS}'"
+ compdefs="${compdefs} -C dm '$(tc-getCC)' -F dm '${CFLAGS}'"
+ compdefs="${compdefs} -C if '${FORTRANC}' -F if '${FFLAGS}'"
+ compdefs="${compdefs} -Si cputhrchk 0 ${archselect}"
+
+
+ cd ${BLD_DIR} && ../configure ${compdefs} \
+ || die "configure failed"
+
+ cd "${S_LAPACK}"
+ eautoreconf
+}
+
+src_compile() {
+ # build atlas' part of lapack
+ cd "${BLD_DIR}"/src/lapack
+ make lib || die "Failed to make lib in ${BLD_DIR}/src/lapack"
+
+ cd "${BLD_DIR}"/interfaces/lapack/C/src
+ make lib || die "Failed to make lib in ${BLD_DIR}/interfaces/lapack/C/src"
+
+ cd "${BLD_DIR}"/interfaces/lapack/F77/src
+ make lib || die "Failed to make lib in ${BLD_DIR}/interfaces/lapack/F77/src"
+
+ # build rest of lapack
+ cd "${S_LAPACK}"
+ econf || die "Failed to configure reference lapack lib"
+ emake || die "Failed to make reference lapack lib"
+
+ cd "${S_LAPACK}"/SRC
+ einfo "Copying liblapack.a/*.o to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/*.o .
+ einfo "Copying liblapack.a/*.lo to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/*.lo .
+ einfo "Copying liblapack.a/.libs/*.o to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/.libs/*.o .libs/
+
+ # make sure shared libs link against proper libraries
+ if [[ ${FORTRANC} == "gfortran" ]]; then
+ libs="${LDFLAGS} -lpthread -lgfortran"
+ else
+ libs="${LDFLAGS} -lpthread -lg2c"
+ fi
+
+ ../libtool --mode=link --tag=F77 ${FORTRANC} -lblas -lcblas \
+ -latlas ${libs} -o liblapack.la *.lo -rpath "${RPATH}" \
+ || die "Failed to create liblapack.la"
+}
+
+src_install () {
+ dodir "${RPATH}"
+
+ cd "${S_LAPACK}"/SRC
+ ../libtool --mode=install install -s liblapack.la \
+ "${D}/${RPATH}" \
+ || die "Failed to install lapack-atlas library"
+
+ eselect lapack add $(get_libdir) ${FILESDIR}/eselect.lapack atlas
+
+ insinto /usr/include/atlas
+ cd "${S}"/include
+ doins clapack.h || die "Failed to install clapack.h"
+
+ cd "${S}"
+ dodoc README doc/AtlasCredits.txt doc/ChangeLog || \
+ die "Failed to install docs"
+ if use doc; then
+ dodoc doc/lapackqref.ps || die "Failed to install docs"
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z "$(eselect lapack show)" ]]; then
+ eselect lapack set atlas
+ fi
+
+ elog
+ elog "To link with ATLAS LAPACK from C or Fortran, simply use:"
+ elog
+ elog "-llapack"
+ elog
+ elog "C users: your header is /usr/include/atlas/clapack.h"
+ elog
+ elog "Configuration now uses eselect rather than lapack-config."
+}