summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-03-23 13:41:31 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-03-23 13:41:31 +0000
commitce77ff7d4ac6619443c2c1ba697af3477412e497 (patch)
treeca52494d21d3cd2625cdb928f3497e9decc6bab2 /sci-libs/itpp
parentStable -n sparc --- Bug #171907 --- builds and works on my ruby/mysql (diff)
downloadgentoo-2-ce77ff7d4ac6619443c2c1ba697af3477412e497.tar.gz
gentoo-2-ce77ff7d4ac6619443c2c1ba697af3477412e497.tar.bz2
gentoo-2-ce77ff7d4ac6619443c2c1ba697af3477412e497.zip
Version bump (fixes bug #171859).
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog7
-rw-r--r--sci-libs/itpp/files/digest-itpp-3.99.13
-rw-r--r--sci-libs/itpp/itpp-3.99.1.ebuild62
3 files changed, 71 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index f42039fa11a6..d5c47000cecc 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.30 2007/03/17 16:38:03 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.31 2007/03/23 13:41:31 markusle Exp $
+
+*itpp-3.99.1 (23 Mar 2007)
+
+ 23 Mar 2007; Markus Dittrich <markusle@gentoo.org> +itpp-3.99.1.ebuild:
+ Version bump (fixes bug #171859).
17 Mar 2007; nixnut <nixnut@gentoo.org> itpp-3.10.9.ebuild:
Stable on ppc wrt bug 170759
diff --git a/sci-libs/itpp/files/digest-itpp-3.99.1 b/sci-libs/itpp/files/digest-itpp-3.99.1
new file mode 100644
index 000000000000..6eb29e71afdd
--- /dev/null
+++ b/sci-libs/itpp/files/digest-itpp-3.99.1
@@ -0,0 +1,3 @@
+MD5 39d05b1a4fa6f0f0fd4f7f90c2cab52c itpp-3.99.1.tar.bz2 868613
+RMD160 05d42d88240136cd62451426a524aac5775ac5dd itpp-3.99.1.tar.bz2 868613
+SHA256 844d2b3060d44243297dff846a859dd8a0fd65158a5045c10484696591b56c26 itpp-3.99.1.tar.bz2 868613
diff --git a/sci-libs/itpp/itpp-3.99.1.ebuild b/sci-libs/itpp/itpp-3.99.1.ebuild
new file mode 100644
index 000000000000..c13d81d644b5
--- /dev/null
+++ b/sci-libs/itpp/itpp-3.99.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.99.1.ebuild,v 1.1 2007/03/23 13:41:31 markusle Exp $
+
+inherit fortran
+
+DESCRIPTION="IT++ is a C++ library of mathematical, signal processing, speech processing, and communications classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blas cblas debug doc fftw lapack minimal"
+
+DEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
+ blas? ( virtual/blas
+ cblas? ( || ( >=sci-libs/gsl-1.4
+ >=sci-libs/acml-2.5.3
+ >=sci-libs/blas-atlas-3.6.0
+ sci-libs/cblas-reference ) )
+ lapack? ( virtual/lapack ) )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+pkg_setup() {
+ # lapack/cblas can only be used in conjunction with blas
+ if use cblas && ! use blas; then
+ die "USE=cblas requires USE=blas to be set"
+ fi
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ local myconf
+ if use blas; then
+ myconf="--with-blas=-lblas"
+ else
+ myconf="--without-blas"
+ fi
+
+ if use minimal; then
+ myconf="${myconf} --disable-comm --disable-fixed --disable-optim --disable-protocol --disable-signal --disable-srccode"
+ fi
+
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_with cblas) \
+ $(use_with lapack) \
+ $(use_with fftw fft) \
+ "${myconf}" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog ChangeLog-2006 ChangeLog-2005 INSTALL \
+ NEWS NEWS-3.10 README TODO || die "failed to install docs"
+}