summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2010-01-09 12:29:09 +0000
committerMarkus Dittrich <markusle@gentoo.org>2010-01-09 12:29:09 +0000
commit38c461f4d859fd1625d5ec69eab344bb7ea5bfe5 (patch)
tree1326580a2e56b04f7dc2ae9f6720f29be4e1fdf4 /sci-libs/itpp
parentkeyword ~ppc64, working fine on a PowerMac 970 (diff)
downloadgentoo-2-38c461f4d859fd1625d5ec69eab344bb7ea5bfe5.tar.gz
gentoo-2-38c461f4d859fd1625d5ec69eab344bb7ea5bfe5.tar.bz2
gentoo-2-38c461f4d859fd1625d5ec69eab344bb7ea5bfe5.zip
Version bump and removed old versions.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog11
-rw-r--r--sci-libs/itpp/files/itpp-4.0.1-zdotu-debian.patch54
-rw-r--r--sci-libs/itpp/files/itpp-4.0.4-vec.patch12
-rw-r--r--sci-libs/itpp/itpp-4.0.3.ebuild71
-rw-r--r--sci-libs/itpp/itpp-4.0.7.ebuild (renamed from sci-libs/itpp/itpp-4.0.4.ebuild)12
5 files changed, 12 insertions, 148 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 7268b7d22a1d..ab9e894fd89c 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/itpp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.88 2009/07/30 07:38:42 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.89 2010/01/09 12:29:09 markusle Exp $
+
+*itpp-4.0.7 (09 Jan 2010)
+
+ 09 Jan 2010; Markus Dittrich <markusle@gentoo.org>
+ -files/itpp-4.0.1-zdotu-debian.patch, -itpp-4.0.3.ebuild,
+ -itpp-4.0.4.ebuild, -files/itpp-4.0.4-vec.patch, +itpp-4.0.7.ebuild:
+ Version bump and removed old versions.
30 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> itpp-4.0.6.ebuild,
+files/itpp-4.0.6-gcc44.patch:
diff --git a/sci-libs/itpp/files/itpp-4.0.1-zdotu-debian.patch b/sci-libs/itpp/files/itpp-4.0.1-zdotu-debian.patch
deleted file mode 100644
index 50dc6936ee14..000000000000
--- a/sci-libs/itpp/files/itpp-4.0.1-zdotu-debian.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff --git a/itpp/base/blas.h b/itpp/base/blas.h
-index 91e415b..e23ca68 100644
---- a/itpp/base/blas.h
-+++ b/itpp/base/blas.h
-@@ -88,21 +88,21 @@ extern "C" {
- const double *x, const int *incx,
- const double *y, const int *incy);
-
--#if defined(HAVE_ZDOTU_RETURN)
-- std::complex<double> zdotu_(const int *n,
-- const std::complex<double> *x, const int *incx,
-- const std::complex<double> *y, const int *incy);
--#elif defined(HAVE_ZDOTU_VOID)
-+#if defined(HAVE_ZDOTU_VOID)
- void zdotu_(std::complex<double> *dot,
- const int *n,
- const std::complex<double> *x, const int *incx,
- const std::complex<double> *y, const int *incy);
-+#elif defined(HAVE_ZDOTU_RETURN)
-+ std::complex<double> zdotu_(const int *n,
-+ const std::complex<double> *x, const int *incx,
-+ const std::complex<double> *y, const int *incy);
- #else
- void zdotusub_(std::complex<double> *dot,
- const int *n,
- const std::complex<double> *x, const int *incx,
- const std::complex<double> *y, const int *incy);
--#endif
-+#endif // HAVE_ZDOTU_VOID
-
- // ----------------------------------------------------------------------
- // BLAS 2 functions
-diff --git a/itpp/base/vec.h b/itpp/base/vec.h
-index 6da1126..8708766 100644
---- a/itpp/base/vec.h
-+++ b/itpp/base/vec.h
-@@ -925,13 +925,13 @@ namespace itpp {
- it_assert_debug(v1.datasize == v2.datasize, "cvec::dot: wrong sizes");
- int incr = 1;
- std::complex<double> output;
--#if defined(HAVE_ZDOTU_RETURN)
-- output = blas::zdotu_(&v1.datasize, v1.data, &incr, v2.data, &incr);
--#elif defined(HAVE_ZDOTU_VOID)
-+#if defined(HAVE_ZDOTU_VOID)
- blas::zdotu_(&output, &v1.datasize, v1.data, &incr, v2.data, &incr);
-+#elif defined(HAVE_ZDOTU_RETURN)
-+ output = blas::zdotu_(&v1.datasize, v1.data, &incr, v2.data, &incr);
- #else
- blas::zdotusub_(&output, &v1.datasize, v1.data, &incr, v2.data, &incr);
--#endif // HAVE_ZDOTU_RETURN
-+#endif // HAVE_ZDOTU_VOID
- return output;
- }
- #endif // HAVE_BLAS
diff --git a/sci-libs/itpp/files/itpp-4.0.4-vec.patch b/sci-libs/itpp/files/itpp-4.0.4-vec.patch
deleted file mode 100644
index 1a39260f42e9..000000000000
--- a/sci-libs/itpp/files/itpp-4.0.4-vec.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur itpp-4.0.4/itpp/base/vec.h itpp-4.0.4.new/itpp/base/vec.h
---- itpp-4.0.4/itpp/base/vec.h 2008-03-31 04:44:14.000000000 -0400
-+++ itpp-4.0.4.new/itpp/base/vec.h 2008-04-14 21:20:06.000000000 -0400
-@@ -1041,7 +1041,7 @@
- }
- #else
- //! Outer product of two vectors v1 and v2
-- template<>
-+ template<> inline
- cmat outer_product(const cvec &v1, const cvec &v2, bool hermitian)
- {
- it_assert_debug((v1.datasize > 0) && (v2.datasize > 0),
diff --git a/sci-libs/itpp/itpp-4.0.3.ebuild b/sci-libs/itpp/itpp-4.0.3.ebuild
deleted file mode 100644
index c0eddcef7989..000000000000
--- a/sci-libs/itpp/itpp-4.0.3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.3.ebuild,v 1.10 2008/05/18 11:19:40 markusle Exp $
-
-inherit fortran flag-o-matic
-
-DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
-LICENSE="GPL-2"
-HOMEPAGE="http://itpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="blas debug doc fftw lapack minimal"
-
-RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
- blas? ( virtual/blas
- lapack? ( virtual/lapack ) )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen
- virtual/latex-base )"
-
-pkg_setup() {
- # lapack can only be used in conjunction with blas
- if use lapack && ! use blas; then
- die "USE=lapack requires USE=blas to be set"
- fi
-}
-
-src_compile() {
- # turn off performance critical debug code
- append-flags -DNDEBUG
-
- local blas_conf="--without-blas"
- local lapack_conf="--without-lapack"
- if use blas; then
- if use lapack; then
- blas_conf="--with-blas=$(pkg-config lapack --libs)"
- lapack_conf="--with-lapack"
- else
- blas_conf="--with-blas=$(pkg-config blas --libs)"
- fi
- fi
-
- local fftw_conf="--without-fft";
- if use fftw;
- then
- fftw_conf="--with-fft=-lfftw3"
- fi
-
- local myconf="--docdir=/usr/share/doc/${P}"
- if use minimal; then
- myconf="${myconf} --disable-comm --disable-fixed --disable-optim --disable-protocol --disable-signal --disable-srccode"
- fi
-
- econf $(use_enable doc html-doc) \
- $(use_enable debug) \
- "${blas_conf}" \
- "${lapack_conf}" \
- "${fftw_conf}" \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog ChangeLog-2007 ChangeLog-2006 \
- ChangeLog-2005 INSTALL NEWS NEWS-3.10 NEWS-3.99 README TODO \
- || die "failed to install docs"
-}
diff --git a/sci-libs/itpp/itpp-4.0.4.ebuild b/sci-libs/itpp/itpp-4.0.7.ebuild
index 67f176525579..a01b581f5083 100644
--- a/sci-libs/itpp/itpp-4.0.4.ebuild
+++ b/sci-libs/itpp/itpp-4.0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.4.ebuild,v 1.13 2008/05/25 06:58:46 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.7.ebuild,v 1.1 2010/01/09 12:29:09 markusle Exp $
inherit fortran flag-o-matic
@@ -14,7 +14,7 @@ HOMEPAGE="http://itpp.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="blas debug doc fftw lapack minimal"
RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
@@ -31,12 +31,6 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-vec.patch
-}
-
src_compile() {
# turn off performance critical debug code
append-flags -DNDEBUG