summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-01-16 02:46:01 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-01-16 02:46:01 +0000
commit2bbefe1ad735d6b391a39b0c360daa70f1b89f55 (patch)
treeabb7660ef942e7182a14fa80320981cb2153d47a /sci-libs/itpp
parentVersion bump. (diff)
downloadgentoo-2-2bbefe1ad735d6b391a39b0c360daa70f1b89f55.tar.gz
gentoo-2-2bbefe1ad735d6b391a39b0c360daa70f1b89f55.tar.bz2
gentoo-2-2bbefe1ad735d6b391a39b0c360daa70f1b89f55.zip
Version bump (fixes bug #162074).
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/files/digest-itpp-3.10.83
-rw-r--r--sci-libs/itpp/itpp-3.10.8.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 5ad6871358c8..c92eb51ac4aa 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.17 2007/01/07 17:26:48 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.18 2007/01/16 02:46:01 markusle Exp $
+
+*itpp-3.10.8 (16 Jan 2007)
+
+ 16 Jan 2007; Markus Dittrich <markusle@gentoo.org> +itpp-3.10.8.ebuild:
+ Version bump (fixes bug #162074). Thanks to Adam Piatyszek
+ <ediap@et.put.poznan.pl> for keeping us up to date :)
07 Jan 2007; Torsten Veller <tove@gentoo.org> itpp-3.10.7.ebuild:
Stable on x86 (#160469)
diff --git a/sci-libs/itpp/files/digest-itpp-3.10.8 b/sci-libs/itpp/files/digest-itpp-3.10.8
new file mode 100644
index 000000000000..6df28eb06cd9
--- /dev/null
+++ b/sci-libs/itpp/files/digest-itpp-3.10.8
@@ -0,0 +1,3 @@
+MD5 f38bd39dbdae4836a493dd8c625b840d itpp-3.10.8.tar.bz2 793789
+RMD160 f8b2d8ae00adb557f16d48dea5c00290388bb11b itpp-3.10.8.tar.bz2 793789
+SHA256 711ab3377fbc0a94db6322413c60caeca7399037498fc3cf159b835fe266faae itpp-3.10.8.tar.bz2 793789
diff --git a/sci-libs/itpp/itpp-3.10.8.ebuild b/sci-libs/itpp/itpp-3.10.8.ebuild
new file mode 100644
index 000000000000..b8aad3ddf4ee
--- /dev/null
+++ b/sci-libs/itpp/itpp-3.10.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.10.8.ebuild,v 1.1 2007/01/16 02:46:01 markusle Exp $
+
+inherit fortran
+
+DESCRIPTION="IT++ is a C++ library of mathematical, signal processing, speech processing, and communications classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="blas cblas debug doc fftw lapack"
+
+DEPEND="fftw? ( >=sci-libs/fftw-3.0.0 )
+ blas? ( virtual/blas
+ cblas? ( || ( >=sci-libs/gsl-1.4
+ >=sci-libs/acml-2.5.3
+ >=sci-libs/blas-atlas-3.6.0
+ sci-libs/cblas-reference ) )
+ lapack? ( virtual/lapack ) )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+pkg_setup() {
+ # lapack/cblas can only be used in conjunction with blas
+ if use cblas && ! use blas; then
+ die "USE=cblas requires USE=blas to be set"
+ fi
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ local myconf
+
+ if use blas; then
+ myconf="--with-blas=-lblas"
+ else
+ myconf="--without-blas"
+ fi
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_with cblas) \
+ $(use_with lapack) \
+ $(use_with fftw fft) \
+ "$myconf" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || \
+ die "failed to install docs"
+}