summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-05-21 16:47:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-05-21 16:47:10 +0000
commit623e67683e3489d3d10343001389aaa7415327a9 (patch)
treec1133dfec4625177062a2a045cc5e2d944a0a88d /sci-libs/ipopt
parentVersion bump (diff)
downloadgentoo-2-623e67683e3489d3d10343001389aaa7415327a9.tar.gz
gentoo-2-623e67683e3489d3d10343001389aaa7415327a9.tar.bz2
gentoo-2-623e67683e3489d3d10343001389aaa7415327a9.zip
Version bump
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/ipopt')
-rw-r--r--sci-libs/ipopt/ChangeLog8
-rw-r--r--sci-libs/ipopt/ipopt-3.11.8.ebuild98
-rw-r--r--sci-libs/ipopt/metadata.xml18
3 files changed, 114 insertions, 10 deletions
diff --git a/sci-libs/ipopt/ChangeLog b/sci-libs/ipopt/ChangeLog
index cbfbada0d48a..c8850996111a 100644
--- a/sci-libs/ipopt/ChangeLog
+++ b/sci-libs/ipopt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/ipopt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipopt/ChangeLog,v 1.2 2014/02/04 08:33:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipopt/ChangeLog,v 1.3 2014/05/21 16:47:10 bicatali Exp $
+
+*ipopt-3.11.8 (21 May 2014)
+
+ 21 May 2014; Sébastien Fabbro <bicatali@gentoo.org> +ipopt-3.11.8.ebuild,
+ metadata.xml:
+ Version bump
04 Feb 2014; Justin Lecher <jlec@gentoo.org> ipopt-3.11.7.ebuild:
Fix the common coinor pkg-config installation problem
diff --git a/sci-libs/ipopt/ipopt-3.11.8.ebuild b/sci-libs/ipopt/ipopt-3.11.8.ebuild
new file mode 100644
index 000000000000..b5bbe9f7d289
--- /dev/null
+++ b/sci-libs/ipopt/ipopt-3.11.8.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ipopt/ipopt-3.11.8.ebuild,v 1.1 2014/05/21 16:47:10 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+FORTRAN_NEEDED="mumps"
+
+inherit eutils autotools-utils multilib toolchain-funcs fortran-2
+
+MYPN=Ipopt
+MYP=${MYPN}-${PV}
+
+DESCRIPTION="Interior-Point Optimizer for large-scale nonlinear optimization"
+HOMEPAGE="https://projects.coin-or.org/Ipopt/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYP}.tgz"
+
+LICENSE="EPL-1.0 hsl? ( HSL )"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hsl lapack mpi mumps static-libs test"
+
+RDEPEND="
+ virtual/blas
+ hsl? ( sci-libs/coinhsl:0= )
+ lapack? ( virtual/lapack )
+ mumps? ( sci-libs/mumps:0=[mpi=] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample sci-libs/mumps )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ if use mumps && ! use mpi; then
+ ln -s "${EPREFIX}"/usr/include/mpiseq/mpi.h \
+ src/Algorithm/LinearSolvers/
+ elif use mpi; then
+ export CXX=mpicxx FC=mpif77 F77=mpif77 CC=mpicc
+ fi
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-blas-lib="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+
+ if use lapack; then
+ myeconfargs+=( --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)" )
+ else
+ myeconfargs+=( --without-lapack )
+ fi
+ if use mumps; then
+ myeconfargs+=(
+ --with-mumps-incdir="${EPREFIX}"/usr/include
+ --with-mumps-lib="-lmumps_common -ldmumps -lzmumps -lsmumps -lcmumps" )
+ else
+ myeconfargs+=( --without-mumps )
+ fi
+ if use hsl; then
+ myeconfargs+=(
+ --with-hsl-incdir="${EPREFIX}"/usr/include
+ --with-hsl-lib="$($(tc-getPKG_CONFIG) --libs coinhsl)" )
+ else
+ myeconfargs+=( --without-hsl )
+ fi
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo doxydoc)
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ use doc && HTML_DOC=("${AUTOTOOLS_BUILD_DIR}/doxydocs/html/")
+ autotools-utils_src_install
+ # already installed
+ rm "${ED}"/usr/share/coin/doc/${MYPN}/{README,AUTHORS,LICENSE} || die
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/ipopt/metadata.xml b/sci-libs/ipopt/metadata.xml
index 6d6ec6956d2b..9b75b46f459c 100644
--- a/sci-libs/ipopt/metadata.xml
+++ b/sci-libs/ipopt/metadata.xml
@@ -1,18 +1,18 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription lang="en">
+<herd>sci</herd>
+<longdescription lang="en">
Ipopt is a solver for large-scale nonlinear continuous
optimization. It can be used from modeling environments, such as
AMPL, GAMS, or Matlab, and it is also available as a callable library with
interfaces to C++, C, and Fortran. Ipopt uses an interior point
- method, together with a filter linear search procedure. Ipopt is part of the
- larger COIN-OR initiative (Computational Infrastructure for Operations
- Research).
+ method, together with a filter linear search procedure. Ipopt is
+ part of the larger COIN-OR initiative (Computational Infrastructure
+ for Operations Research).
</longdescription>
- <use>
- <flag name="hsl">hsl</flag>
- <flag name="mumps">Enable <pkg>sci-libs/mumps</pkg> support</flag>
- </use>
+<use>
+ <flag name="hsl">hsl</flag>
+ <flag name="mumps">Enable <pkg>sci-libs/mumps</pkg> support</flag>
+</use>
</pkgmetadata>