summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-05-21 21:44:41 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-05-21 21:44:41 +0000
commitb2068611e3425d70a61a541452d1a61560e78cfe (patch)
tree1573df4e41a18cd773413a3faa1232b54f5da59c /sci-libs/hdf5
parentkeyworded and tested on ppc (diff)
downloadgentoo-2-b2068611e3425d70a61a541452d1a61560e78cfe.tar.gz
gentoo-2-b2068611e3425d70a61a541452d1a61560e78cfe.tar.bz2
gentoo-2-b2068611e3425d70a61a541452d1a61560e78cfe.zip
updated to fix a few minor odds and ends; verified working with mpich2
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/ChangeLog10
-rw-r--r--sci-libs/hdf5/files/digest-hdf5-1.6.22
-rw-r--r--sci-libs/hdf5/files/digest-hdf5-1.6.42
-rw-r--r--sci-libs/hdf5/hdf5-1.6.2.ebuild27
-rw-r--r--sci-libs/hdf5/hdf5-1.6.4.ebuild24
5 files changed, 46 insertions, 19 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index 323eca2dd73f..8b3e4c125a99 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/hdf5
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.10 2006/03/17 14:11:22 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.11 2006/05/21 21:44:41 nerdboy Exp $
+
+ 21 May 2006; Steve Arnold <nerdboy@gentoo.org> hdf5-1.6.2.ebuild,
+ hdf5-1.6.4.ebuild:
+ Updated to fix a few minor odds and ends (extra configure options,
+ get_libdir, etc). Verified working with mpich2-1.0.3 (bug #107161).
+ Need to stablize for gdal; also needs some work on other arches
+ (eg, the sparc bug #118777). Go back to virtual/mpi when deps are
+ fixed (mpich is dorked).
17 Mar 2006; Markus Rothe <corsair@gentoo.org> hdf5-1.6.4.ebuild:
Added ~ppc64; bug #126527
diff --git a/sci-libs/hdf5/files/digest-hdf5-1.6.2 b/sci-libs/hdf5/files/digest-hdf5-1.6.2
index 388a1ae246cf..1adf644d5206 100644
--- a/sci-libs/hdf5/files/digest-hdf5-1.6.2
+++ b/sci-libs/hdf5/files/digest-hdf5-1.6.2
@@ -1 +1,3 @@
MD5 9a39a0d8b002b12787436e186133455c hdf5-1.6.2.tar.gz 3879147
+RMD160 75678e8859e783dbb274cdabee3d916724c46780 hdf5-1.6.2.tar.gz 3879147
+SHA256 aabc23cb2c744c25b71416e25bdca3b9ca8dadb9248f22314330a33d91c599ba hdf5-1.6.2.tar.gz 3879147
diff --git a/sci-libs/hdf5/files/digest-hdf5-1.6.4 b/sci-libs/hdf5/files/digest-hdf5-1.6.4
index 1fc0a2f53d0d..fb913f72c24c 100644
--- a/sci-libs/hdf5/files/digest-hdf5-1.6.4
+++ b/sci-libs/hdf5/files/digest-hdf5-1.6.4
@@ -1 +1,3 @@
MD5 a837391b633fc4c6681905d89047c032 hdf5-1.6.4.tar.gz 4862437
+RMD160 8175af3153bb0a5a1278c01af2d3940f4fd5084f hdf5-1.6.4.tar.gz 4862437
+SHA256 11ab0d81575f333067ae091d39c28fbf446c8ecafdfe70cf92b3c35ceffbfc97 hdf5-1.6.4.tar.gz 4862437
diff --git a/sci-libs/hdf5/hdf5-1.6.2.ebuild b/sci-libs/hdf5/hdf5-1.6.2.ebuild
index 0b79e1def387..62a3ceffbc5f 100644
--- a/sci-libs/hdf5/hdf5-1.6.2.ebuild
+++ b/sci-libs/hdf5/hdf5-1.6.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.6.2.ebuild,v 1.4 2005/09/11 05:38:16 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.6.2.ebuild,v 1.5 2006/05/21 21:44:41 nerdboy Exp $
+
+inherit eutils
DESCRIPTION="general purpose library and file format for storing scientific data"
HOMEPAGE="http://hdf.ncsa.uiuc.edu/HDF5/"
@@ -9,17 +11,20 @@ SRC_URI="ftp://ftp.ncsa.uiuc.edu/HDF/HDF5/current/src/${P}.tar.gz"
LICENSE="NCSA-HDF"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-IUSE="static zlib ssl"
+IUSE="static zlib ssl threads debug"
DEPEND="zlib? ( sys-libs/zlib )"
src_compile() {
- local myconf
+ local myconf="--with-pic"
#--disable-static conflicts with --enable-cxx, so we have to do either or
- use static && myconf="--enable-cxx" || myconf="--disable-static"
- use zlib || myconf="${myconf} --disable-zlib"
- use ssl && myconf="${myconf} --with-ssl"
+ use static && myconf="${myconf} --enable-cxx" || \
+ myconf="${myconf} --disable-static"
+ # fortran needs f90 support
+ #use fortran && myconf="${myconf} --enable-fortran"
+ use threads && myconf="${myconf} --with-pthread"
+ use debug && myconf="${myconf} --enable-debug=all"
# NOTE: the hdf5 configure script has its own interpretation of
# the ARCH environment variable which conflicts with that of
@@ -28,8 +33,11 @@ src_compile() {
EBUILD_ARCH=${ARCH}
unset ARCH
- ./configure ${myconf} --enable-linux-lfs --with-gnu-ld \
- --prefix=/usr \
+ ./configure --prefix=/usr ${myconf} \
+ $(use_enable zlib) \
+ $(use_with ssl) \
+ --enable-linux-lfs \
+ --libdir=/usr/$(get_libdir) \
--sysconfdir=/etc \
--infodir=/usr/share/info \
--mandir=/usr/share/man || die "configure failed"
@@ -43,6 +51,7 @@ src_compile() {
src_install() {
make \
prefix=${D}/usr \
+ libdir=${D}/usr/$(get_libdir) \
mandir=${D}/usr/share/man \
docdir=${D}/usr/share/doc/${PF} \
infodir=${D}/usr/share/info \
diff --git a/sci-libs/hdf5/hdf5-1.6.4.ebuild b/sci-libs/hdf5/hdf5-1.6.4.ebuild
index 93a7598174eb..472c2a794580 100644
--- a/sci-libs/hdf5/hdf5-1.6.4.ebuild
+++ b/sci-libs/hdf5/hdf5-1.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.6.4.ebuild,v 1.4 2006/03/17 14:11:22 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.6.4.ebuild,v 1.5 2006/05/21 21:44:41 nerdboy Exp $
inherit eutils
@@ -11,19 +11,23 @@ SRC_URI="ftp://ftp.ncsa.uiuc.edu/HDF/HDF5/current/src/${P}.tar.gz"
LICENSE="NCSA-HDF"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="static zlib ssl mpi hlapi szip"
+# should try to get alpha ia64 and sparc back in here
+IUSE="static zlib ssl mpi hlapi szip threads debug"
DEPEND="zlib? ( sys-libs/zlib )
szip? ( sci-libs/szip )
- mpi? ( virtual/mpi )"
+ mpi? ( sys-cluster/mpich2 )"
src_compile() {
- local myconf
+ local myconf="--with-pic"
#--disable-static conflicts with --enable-cxx, so we have to do either or
- use static && myconf="--enable-cxx" || myconf="--disable-static"
- use zlib || myconf="${myconf} --disable-zlib"
- use ssl && myconf="${myconf} --with-ssl"
+ use static && myconf="${myconf} --enable-cxx" || \
+ myconf="${myconf} --disable-static"
+ # fortran needs f90 support
+ #myconf="${myconf} $(use_enable fortran)"
+ use threads && myconf="${myconf} --with-pthread"
+ use debug && myconf="${myconf} --enable-debug=all"
use mpi && myconf="${myconf} --enable-parallel"
use hlapi || myconf="${myconf} --disable-hl"
@@ -36,8 +40,10 @@ src_compile() {
use mpi && \
export CC="/usr/bin/mpicc"
- ./configure ${myconf} --enable-linux-lfs \
- --prefix=/usr \
+ ./configure --prefix=/usr ${myconf} \
+ $(use_enable zlib) \
+ $(use_with ssl) \
+ --enable-linux-lfs \
--sysconfdir=/etc \
--infodir=/usr/share/info \
--mandir=/usr/share/man || die "configure failed"