summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-04-04 15:33:32 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-04-04 15:33:32 +0000
commit4ca72ccc3fa58522c939844057e47c442453192e (patch)
tree4c1404ffbed782de59a03e593f603eea9701ef60 /sci-libs/gts/gts-0.7.6.ebuild
parentUpdate common-lisp-controller dependency to >=dev-lisp/common-lisp-controller... (diff)
downloadgentoo-2-4ca72ccc3fa58522c939844057e47c442453192e.tar.gz
gentoo-2-4ca72ccc3fa58522c939844057e47c442453192e.tar.bz2
gentoo-2-4ca72ccc3fa58522c939844057e47c442453192e.zip
Version bump.
(Portage version: 2.1_pre7-r3)
Diffstat (limited to 'sci-libs/gts/gts-0.7.6.ebuild')
-rw-r--r--sci-libs/gts/gts-0.7.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-libs/gts/gts-0.7.6.ebuild b/sci-libs/gts/gts-0.7.6.ebuild
new file mode 100644
index 000000000000..85a96c0f0f19
--- /dev/null
+++ b/sci-libs/gts/gts-0.7.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/gts-0.7.6.ebuild,v 1.1 2006/04/04 15:33:32 markusle Exp $
+
+DESCRIPTION="GNU Triangulated Surface Library"
+LICENSE="LGPL-2"
+HOMEPAGE="http://gts.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-libs/glib-2.4.0
+ sys-apps/gawk
+ sys-devel/libtool
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ # fix up examples
+ sed -e "s:/var/tmp/portage/gts-0.7.6/work/gts-0.7.6/:/usr/share/gts/:g" \
+ -e "s:../src/.libs/libgts.so:/usr/lib/libgts.so:g" \
+ -i examples/* || \
+ die "Failed to fix-up example scripts"
+
+ # install examples
+ insinto /usr/share/${PN}/examples
+ doins examples/* || die "Failed to install examples"
+
+ # install additional docs
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}
+