summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-08-02 21:30:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-08-02 21:30:17 +0000
commit16b287297b7a7a91dd27d2ecdfc6ebdc7ca3fb57 (patch)
tree764ae4e92cef75a74bd17e77637e8074851fe2bf /sci-libs/gerris
parentBumped to EAPI 4 and added xml(+) (diff)
downloadgentoo-2-16b287297b7a7a91dd27d2ecdfc6ebdc7ca3fb57.tar.gz
gentoo-2-16b287297b7a7a91dd27d2ecdfc6ebdc7ca3fb57.tar.bz2
gentoo-2-16b287297b7a7a91dd27d2ecdfc6ebdc7ca3fb57.zip
Version bump. Keyword amd64-linux x86-linux
(Portage version: 2.2.01.20796-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gerris')
-rw-r--r--sci-libs/gerris/ChangeLog8
-rw-r--r--sci-libs/gerris/gerris-20120731.ebuild55
2 files changed, 61 insertions, 2 deletions
diff --git a/sci-libs/gerris/ChangeLog b/sci-libs/gerris/ChangeLog
index f75a20fcde1a..f309725de1de 100644
--- a/sci-libs/gerris/ChangeLog
+++ b/sci-libs/gerris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gerris
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/ChangeLog,v 1.15 2012/05/04 08:22:51 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/ChangeLog,v 1.16 2012/08/02 21:30:17 bicatali Exp $
+
+*gerris-20120731 (02 Aug 2012)
+
+ 02 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> +gerris-20120731.ebuild:
+ Version bump. Keyword amd64-linux x86-linux
04 May 2012; Jeff Horelick <jdhore@gentoo.org> gerris-20100519.ebuild,
gerris-20111123.ebuild:
@@ -77,4 +82,3 @@
+gerris-0.8.0.ebuild:
Initial import (fixes bug #102323). Many thanks to Tim Cera
<timcera@earthlink.net> for his ebuild.
-
diff --git a/sci-libs/gerris/gerris-20120731.ebuild b/sci-libs/gerris/gerris-20120731.ebuild
new file mode 100644
index 000000000000..7732277a4ccc
--- /dev/null
+++ b/sci-libs/gerris/gerris-20120731.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20120731.ebuild,v 1.1 2012/08/02 21:30:17 bicatali Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic
+
+MYP=${P/-20/-snapshot-}
+
+DESCRIPTION="Gerris Flow Solver"
+HOMEPAGE="http://gfs.sourceforge.net/"
+SRC_URI="http://gerris.dalembert.upmc.fr/gerris/tarballs/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples mpi static-libs"
+
+# all these deps could be optional
+# but the configure.in would have to be modified
+# heavily for the automagic
+RDEPEND="dev-libs/glib:2
+ dev-games/ode
+ sci-libs/netcdf
+ sci-libs/gsl
+ sci-libs/gts
+ sci-libs/hypre
+ sci-libs/lis
+ sci-libs/proj
+ >=sci-libs/fftw-3
+ virtual/lapack
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ append-cppflags "-I${EPREFIX}/usr/include/hypre"
+ econf \
+ $(use_enable mpi) \
+ $(use_enable static-libs static) \
+ LAPACK_LIBS="$(pkg-config --libs lapack)"
+}
+
+src_install() {
+ default
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ rm -f doc/examples/*.pyc || die "Failed to remove python object"
+ doins -r doc/examples/*
+ fi
+}