summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-21 22:03:35 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-21 22:03:35 +0000
commitd3f6799e458950a5b5e45816bd4ac14e90fe893e (patch)
tree93ff54c438c5068fedd99b07d815935a622f7c4e /sci-libs/gerris/gerris-20120731.ebuild
parentsci-chemistry/molrep: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instea... (diff)
downloadgentoo-2-d3f6799e458950a5b5e45816bd4ac14e90fe893e.tar.gz
gentoo-2-d3f6799e458950a5b5e45816bd4ac14e90fe893e.tar.bz2
gentoo-2-d3f6799e458950a5b5e45816bd4ac14e90fe893e.zip
sci-libs/gerris: Use tc-getPKG_CONFIG from toolchain-funcs.eclass instead of plain pkg-config; drop old
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'sci-libs/gerris/gerris-20120731.ebuild')
-rw-r--r--sci-libs/gerris/gerris-20120731.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sci-libs/gerris/gerris-20120731.ebuild b/sci-libs/gerris/gerris-20120731.ebuild
index 82b465505371..6834f60f850e 100644
--- a/sci-libs/gerris/gerris-20120731.ebuild
+++ b/sci-libs/gerris/gerris-20120731.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20120731.ebuild,v 1.2 2012/08/08 17:11:25 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gerris/gerris-20120731.ebuild,v 1.3 2013/02/21 22:03:35 jlec Exp $
EAPI=4
-inherit eutils flag-o-matic autotools
+inherit autotools eutils flag-o-matic toolchain-funcs
MYP=${P/-20/-snapshot-}
@@ -21,7 +21,8 @@ IUSE="examples mpi static-libs"
# all these deps could be optional
# but the configure.in would have to be modified
# heavily for the automagic
-RDEPEND="dev-libs/glib:2
+RDEPEND="
+ dev-libs/glib:2
dev-games/ode
sci-libs/netcdf
sci-libs/gsl
@@ -50,7 +51,7 @@ src_configure() {
econf \
$(use_enable mpi) \
$(use_enable static-libs static) \
- LAPACK_LIBS="$(pkg-config --libs lapack)"
+ LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
}
src_install() {