summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-05-25 19:18:46 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-05-25 19:18:46 +0000
commitadfd8c5f8d6ec643e24e78d2a3bc0d5166ea9101 (patch)
tree4d0fc14761898ad564465b61fcd3f1c924253e2b /sci-libs/geos/geos-2.2.2.ebuild
parentoops. drop arch back to ~arch (diff)
downloadgentoo-2-adfd8c5f8d6ec643e24e78d2a3bc0d5166ea9101.tar.gz
gentoo-2-adfd8c5f8d6ec643e24e78d2a3bc0d5166ea9101.tar.bz2
gentoo-2-adfd8c5f8d6ec643e24e78d2a3bc0d5166ea9101.zip
overdue stable bumps, added newest version, removed oldest
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'sci-libs/geos/geos-2.2.2.ebuild')
-rw-r--r--sci-libs/geos/geos-2.2.2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sci-libs/geos/geos-2.2.2.ebuild b/sci-libs/geos/geos-2.2.2.ebuild
new file mode 100644
index 000000000000..6681406d89ce
--- /dev/null
+++ b/sci-libs/geos/geos-2.2.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-2.2.2.ebuild,v 1.1 2006/05/25 19:18:46 nerdboy Exp $
+
+inherit eutils
+
+DESCRIPTION="Geometry Engine - Open Source"
+HOMEPAGE="http://geos.refractions.net"
+SRC_URI="http://geos.refractions.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static doc python"
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )\
+ python? ( dev-lang/python dev-lang/swig )"
+
+src_compile() {
+ cd ${S}
+ libtoolize --force
+
+ local myconf
+ myconf=""
+ use static && myconf="$(use_enable static)"
+
+ econf ${myconf} || die "Error: econf failed"
+
+ # intermittent build failures with emake
+ make || die "Error: make failed"
+ if use python; then
+ einfo "Compilling PyGEOS"
+ cd ${S}/swig/python
+ swig -c++ -python -modern -o geos_wrap.cxx ../geos.i
+ python setup.py build
+ fi
+}
+
+src_test() {
+ cd ${S}
+ make check || die "Tring make check without success."
+# I think this test must be made after the PyGEOS installation
+# if use python; then
+# cd ${S}/swig/python
+# python tests/runtests.py -v
+# fi
+}
+
+src_install(){
+ into /usr
+ einstall
+ dodoc AUTHORS COPYING INSTALL NEWS README TODO
+ if use doc; then
+ cd ${S}/doc
+ make doxygen-html
+ dohtml -r doxygen_docs/html/*
+ fi
+ if use python; then
+ einfo "Intalling PyGEOS"
+ cd ${S}/swig/python
+ python setup.py install --prefix="${D}/usr/"
+ insinto /usr/share/doc/${PF}/python
+ doins README.txt tests/*.py
+ insinto /usr/share/doc/${PF}/python/cases
+ doins tests/cases/*
+ fi
+}