summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-10-06 07:11:16 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-10-06 07:11:16 +0000
commitf958113129c27768b184fc3ce0d9422dd7c53ef0 (patch)
tree9a9ab8dc80239cb0177069ea8a74b6a29c474299 /sci-libs/gdal
parentXfce builds for new eclass and modular Xorg. (diff)
downloadgentoo-2-f958113129c27768b184fc3ce0d9422dd7c53ef0.tar.gz
gentoo-2-f958113129c27768b184fc3ce0d9422dd7c53ef0.tar.bz2
gentoo-2-f958113129c27768b184fc3ce0d9422dd7c53ef0.zip
Added fix for bug #105760
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog8
-rw-r--r--sci-libs/gdal/files/gdal-1.2.6-installpathfix.patch210
-rw-r--r--sci-libs/gdal/files/gdal-1.3.0-installpathfix.patch210
-rw-r--r--sci-libs/gdal/gdal-1.2.6-r3.ebuild30
-rw-r--r--sci-libs/gdal/gdal-1.3.0.ebuild32
5 files changed, 442 insertions, 48 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index f5d7d07f9721..6c422f73ea2e 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.12 2005/09/21 06:19:14 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.13 2005/10/06 07:11:16 nerdboy Exp $
+
+ 06 Oct 2005; Steve Arnold <nerdboy@gentoo.org>
+ +files/gdal-1.2.6-installpathfix.patch,
+ +files/gdal-1.3.0-installpathfix.patch, gdal-1.2.6-r3.ebuild,
+ gdal-1.3.0.ebuild:
+ Added fix for bug #105760
21 Sep 2005; Steve Arnold <nerdboy@gentoo.org> gdal-1.2.6-r3.ebuild,
gdal-1.3.0.ebuild:
diff --git a/sci-libs/gdal/files/gdal-1.2.6-installpathfix.patch b/sci-libs/gdal/files/gdal-1.2.6-installpathfix.patch
new file mode 100644
index 000000000000..85c847b2e51e
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.2.6-installpathfix.patch
@@ -0,0 +1,210 @@
+diff -ru gdal-1.2.6/GNUmakefile gdal-1.2.6.fixed/GNUmakefile
+--- gdal-1.2.6/GNUmakefile 2005-03-02 04:55:40.000000000 +1100
++++ gdal-1.2.6.fixed/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -126,7 +126,7 @@
+
+ install-docs:
+ (cd ogr; $(MAKE) install-docs)
+- $(INSTALL_DIR) $(INST_DOCS)/gdal
++ $(INSTALL_DIR) $(DESTDIR)$(INST_DOCS)/gdal
+ cp html/*.* $(INST_DOCS)/gdal
+
+ web-update: docs
+@@ -135,9 +135,9 @@
+ install: default install-actions
+
+ install-actions: install-lib
+- $(INSTALL_DIR) $(INST_BIN)
+- $(INSTALL_DIR) $(INST_DATA)
+- $(INSTALL_DIR) $(INST_INCLUDE)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_BIN)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_DATA)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_INCLUDE)
+ (cd port; $(MAKE) install)
+ (cd gcore; $(MAKE) install)
+ (cd frmts; $(MAKE) install)
+@@ -148,14 +148,14 @@
+ ifneq ($(PYTHON),no)
+ (cd pymod; $(MAKE) install)
+ endif
+- for f in data/*.* ; do $(INSTALL_DATA) $$f $(INST_DATA) ; done
++ for f in data/*.* ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_DATA) ; done
+ $(LIBTOOL_FINISH) $(INST_LIB)
+
+ ifeq ($(HAVE_LIBTOOL),yes)
+
+ install-lib:
+- $(INSTALL_DIR) $(INST_LIB)
+- for f in $(LIBGDAL-yes) ; do $(INSTALL_LIB) $$f $(INST_LIB) ; done
++ $(INSTALL_DIR) $(DESTDIR)$(INST_LIB)
++ for f in $(LIBGDAL-yes) ; do $(INSTALL_LIB) $$f $(DESTDIR)$(INST_LIB) ; done
+
+ else
+
+@@ -165,11 +165,11 @@
+ GDAL_SLIB_B = $(notdir $(GDAL_SLIB))
+
+ install-lib:
+- $(INSTALL_DIR) $(INST_LIB)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_LIB)
+ rm -f $(INST_LIB)/$(GDAL_SLIB_B)
+ rm -f $(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER_MAJOR)
+ rm -f $(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER)
+- $(INSTALL_LIB) $(GDAL_SLIB) $(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER)
++ $(INSTALL_LIB) $(GDAL_SLIB) $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER)
+ (cd $(INST_LIB) ; \
+ ln -s $(GDAL_SLIB_B).$(GDAL_VER_MAJOR) $(GDAL_SLIB_B))
+ (cd $(INST_LIB) ; \
+@@ -178,8 +178,8 @@
+ else
+
+ install-lib:
+- $(INSTALL_DIR) $(INST_LIB)
+- $(INSTALL_LIB) $(GDAL_LIB) $(INST_LIB)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_LIB)
++ $(INSTALL_LIB) $(GDAL_LIB) $(DESTDIR)$(INST_LIB)
+
+ endif # HAVE_LD_SHARED=no
+
+diff -ru gdal-1.2.6/alg/GNUmakefile gdal-1.2.6.fixed/alg/GNUmakefile
+--- gdal-1.2.6/alg/GNUmakefile 2004-12-27 08:26:15.000000000 +1100
++++ gdal-1.2.6.fixed/alg/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -23,7 +23,7 @@
+ (cd ..; $(MAKE) docs)
+
+ install:
+- for f in *.h ; do $(INSTALL_DATA) $$f $(INST_INCLUDE) ; done
++ for f in *.h ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_INCLUDE) ; done
+
+ lib: $(OBJ)
+ (cd .. ; $(MAKE) force-lib)
+diff -ru gdal-1.2.6/apps/GNUmakefile gdal-1.2.6.fixed/apps/GNUmakefile
+--- gdal-1.2.6/apps/GNUmakefile 2004-08-12 05:07:21.000000000 +1000
++++ gdal-1.2.6.fixed/apps/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -85,6 +85,6 @@
+
+
+ install: default
+- for f in $(BIN_LIST) ; do $(INSTALL) $$f $(INST_BIN) ; done
+- $(INSTALL) gdal-config-inst $(INST_BIN)/gdal-config
++ for f in $(BIN_LIST) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done
++ $(INSTALL) gdal-config-inst $(DESTDIR)$(INST_BIN)/gdal-config
+
+diff -ru gdal-1.2.6/frmts/mem/GNUmakefile gdal-1.2.6.fixed/frmts/mem/GNUmakefile
+--- gdal-1.2.6/frmts/mem/GNUmakefile 2005-01-25 05:09:57.000000000 +1100
++++ gdal-1.2.6.fixed/frmts/mem/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -15,4 +15,4 @@
+ install-obj: $(O_OBJ)
+
+ install:
+- $(INSTALL_DATA) memdataset.h $(INST_INCLUDE)
++ $(INSTALL_DATA) memdataset.h $(DESTDIR)$(INST_INCLUDE)
+diff -ru gdal-1.2.6/frmts/raw/GNUmakefile gdal-1.2.6.fixed/frmts/raw/GNUmakefile
+--- gdal-1.2.6/frmts/raw/GNUmakefile 2005-01-25 05:09:57.000000000 +1100
++++ gdal-1.2.6.fixed/frmts/raw/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -21,4 +21,4 @@
+ $(OBJ) $(O_OBJ): rawdataset.h
+
+ install:
+- $(INSTALL_DATA) rawdataset.h $(INST_INCLUDE)
++ $(INSTALL_DATA) rawdataset.h $(DESTDIR)$(INST_INCLUDE)
+diff -ru gdal-1.2.6/frmts/vrt/GNUmakefile gdal-1.2.6.fixed/frmts/vrt/GNUmakefile
+--- gdal-1.2.6/frmts/vrt/GNUmakefile 2005-01-25 05:09:57.000000000 +1100
++++ gdal-1.2.6.fixed/frmts/vrt/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -19,4 +19,4 @@
+ $(OBJ) $(O_OBJ): vrtdataset.h
+
+ install:
+- $(INSTALL_DATA) vrtdataset.h $(INST_INCLUDE)
++ $(INSTALL_DATA) vrtdataset.h $(DESTDIR)$(INST_INCLUDE)
+diff -ru gdal-1.2.6/gcore/GNUmakefile gdal-1.2.6.fixed/gcore/GNUmakefile
+--- gdal-1.2.6/gcore/GNUmakefile 2004-04-29 23:43:34.000000000 +1000
++++ gdal-1.2.6.fixed/gcore/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -31,4 +31,4 @@
+ $*.cpp -o $*.o
+
+ install:
+- for f in *.h ; do $(INSTALL_DATA) $$f $(INST_INCLUDE) ; done
++ for f in *.h ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_INCLUDE) ; done
+diff -ru gdal-1.2.6/man/GNUmakefile gdal-1.2.6.fixed/man/GNUmakefile
+--- gdal-1.2.6/man/GNUmakefile 2004-02-21 04:26:13.000000000 +1100
++++ gdal-1.2.6.fixed/man/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -5,5 +5,5 @@
+ include ../GDALmake.opt
+
+ install:
+- $(INSTALL_DIR) $(INST_MAN)/man1
+- for f in $(MAN1_FILES) ; do $(INSTALL_DATA) $$f $(INST_MAN)/man1 ; done
++ $(INSTALL_DIR) $(DESTDIR)$(INST_MAN)/man1
++ for f in $(MAN1_FILES) ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_MAN)/man1 ; done
+diff -ru gdal-1.2.6/ogr/GNUmakefile gdal-1.2.6.fixed/ogr/GNUmakefile
+--- gdal-1.2.6/ogr/GNUmakefile 2005-03-12 01:28:05.000000000 +1100
++++ gdal-1.2.6.fixed/ogr/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -79,7 +79,7 @@
+ cp ogr_feature_style.html html
+
+ install-docs:
+- $(INSTALL_DIR) $(INST_DOCS)/ogr
++ $(INSTALL_DIR) $(DESTDIR)$(INST_DOCS)/ogr
+ cp html/* $(INST_DOCS)/ogr
+
+ gdalso: $(GDAL_SLIB)
+@@ -120,14 +120,14 @@
+
+ ifeq ($(OGR_ENABLED),yes)
+ install-full: apps
+- $(INSTALL) ogr2ogr $(INST_BIN)
+- $(INSTALL) ogrinfo $(INST_BIN)
+- $(INSTALL) ogrtindex $(INST_BIN)
++ $(INSTALL) ogr2ogr $(DESTDIR)$(INST_BIN)
++ $(INSTALL) ogrinfo $(DESTDIR)$(INST_BIN)
++ $(INSTALL) ogrtindex $(DESTDIR)$(INST_BIN)
+ else
+ install-full:
+ endif
+
+ install: install-full
+ for f in $(INST_H_FILES) ; \
+- do $(INSTALL_DATA) $$f $(INST_INCLUDE) ; \
++ do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_INCLUDE) ; \
+ done
+diff -ru gdal-1.2.6/port/GNUmakefile gdal-1.2.6.fixed/port/GNUmakefile
+--- gdal-1.2.6/port/GNUmakefile 2003-12-29 04:25:00.000000000 +1100
++++ gdal-1.2.6.fixed/port/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -25,7 +25,7 @@
+ $(RM) *.o $(LIB)
+
+ install:
+- for f in *.h ; do $(INSTALL_DATA) $$f $(INST_INCLUDE) ; done
++ for f in *.h ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_INCLUDE) ; done
+
+ xmlreformat: xmlreformat.o
+ $(CXX) $(CXXFLAGS) xmlreformat.o $(CONFIG_LIBS) -o xmlreformat
+diff -ru gdal-1.2.6/pymod/GNUmakefile gdal-1.2.6.fixed/pymod/GNUmakefile
+--- gdal-1.2.6/pymod/GNUmakefile 2005-02-01 09:07:02.000000000 +1100
++++ gdal-1.2.6.fixed/pymod/GNUmakefile 2005-10-02 18:22:05.000000000 +1000
+@@ -45,9 +45,9 @@
+
+ # special care is taken so that python scripts are installed as executables
+ install: $(GDALMODULE_SO)
+- $(INSTALL_DIR) $(INST_PYMOD)
+- $(INSTALL_LIB) $(GDALMODULE_SO) $(INST_PYMOD)
+- for f in $(PY_COMMANDS) ; do $(INSTALL) $$f $(INST_BIN) ; done
+- for f in $(PY_MODULES) ; do $(INSTALL_DATA) $$f $(INST_PYMOD) ; done
++ $(INSTALL_DIR) $(DESTDIR)$(INST_PYMOD)
++ $(INSTALL_LIB) $(GDALMODULE_SO) $(DESTDIR)$(INST_PYMOD)
++ for f in $(PY_COMMANDS) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done
++ for f in $(PY_MODULES) ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_PYMOD) ; done
+ # ugh! spurius relinking leaves a file owned by root into .libs/.
+ rm -f .libs/*.soT
+--- gdal-1.2.6/GDALmake.opt.in.orig 2005-10-02 21:07:42.000000000 +1000
++++ gdal-1.2.6/GDALmake.opt.in 2005-10-02 21:08:23.000000000 +1000
+@@ -50,7 +50,7 @@
+ exec_prefix = @exec_prefix@
+ INST_PREFIX = @exec_prefix@
+ INST_INCLUDE = @includedir@
+-INST_DATA = @datadir@
++INST_DATA = @datadir@/gdal
+ INST_LIB = @libdir@
+ INST_BIN = @bindir@
+ INST_PYMOD = @pymoddir@
diff --git a/sci-libs/gdal/files/gdal-1.3.0-installpathfix.patch b/sci-libs/gdal/files/gdal-1.3.0-installpathfix.patch
new file mode 100644
index 000000000000..931962d4c3a2
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.3.0-installpathfix.patch
@@ -0,0 +1,210 @@
+diff -ru gdal-1.3.0.orig/GNUmakefile gdal-1.3.0/GNUmakefile
+--- gdal-1.3.0.orig/GNUmakefile 2005-03-02 04:55:40.000000000 +1100
++++ gdal-1.3.0/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -126,7 +126,7 @@
+
+ install-docs:
+ (cd ogr; $(MAKE) install-docs)
+- $(INSTALL_DIR) $(INST_DOCS)/gdal
++ $(INSTALL_DIR) $(DESTDIR)$(INST_DOCS)/gdal
+ cp html/*.* $(INST_DOCS)/gdal
+
+ web-update: docs
+@@ -135,9 +135,9 @@
+ install: default install-actions
+
+ install-actions: install-lib
+- $(INSTALL_DIR) $(INST_BIN)
+- $(INSTALL_DIR) $(INST_DATA)
+- $(INSTALL_DIR) $(INST_INCLUDE)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_BIN)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_DATA)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_INCLUDE)
+ (cd port; $(MAKE) install)
+ (cd gcore; $(MAKE) install)
+ (cd frmts; $(MAKE) install)
+@@ -148,14 +148,14 @@
+ ifneq ($(PYTHON),no)
+ (cd pymod; $(MAKE) install)
+ endif
+- for f in data/*.* ; do $(INSTALL_DATA) $$f $(INST_DATA) ; done
++ for f in data/*.* ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_DATA) ; done
+ $(LIBTOOL_FINISH) $(INST_LIB)
+
+ ifeq ($(HAVE_LIBTOOL),yes)
+
+ install-lib:
+- $(INSTALL_DIR) $(INST_LIB)
+- for f in $(LIBGDAL-yes) ; do $(INSTALL_LIB) $$f $(INST_LIB) ; done
++ $(INSTALL_DIR) $(DESTDIR)$(INST_LIB)
++ for f in $(LIBGDAL-yes) ; do $(INSTALL_LIB) $$f $(DESTDIR)$(INST_LIB) ; done
+
+ else
+
+@@ -165,11 +165,11 @@
+ GDAL_SLIB_B = $(notdir $(GDAL_SLIB))
+
+ install-lib:
+- $(INSTALL_DIR) $(INST_LIB)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_LIB)
+ rm -f $(INST_LIB)/$(GDAL_SLIB_B)
+ rm -f $(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER_MAJOR)
+ rm -f $(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER)
+- $(INSTALL_LIB) $(GDAL_SLIB) $(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER)
++ $(INSTALL_LIB) $(GDAL_SLIB) $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER)
+ (cd $(INST_LIB) ; \
+ ln -s $(GDAL_SLIB_B).$(GDAL_VER_MAJOR) $(GDAL_SLIB_B))
+ (cd $(INST_LIB) ; \
+@@ -178,8 +178,8 @@
+ else
+
+ install-lib:
+- $(INSTALL_DIR) $(INST_LIB)
+- $(INSTALL_LIB) $(GDAL_LIB) $(INST_LIB)
++ $(INSTALL_DIR) $(DESTDIR)$(INST_LIB)
++ $(INSTALL_LIB) $(GDAL_LIB) $(DESTDIR)$(INST_LIB)
+
+ endif # HAVE_LD_SHARED=no
+
+diff -ru gdal-1.3.0.orig/alg/GNUmakefile gdal-1.3.0/alg/GNUmakefile
+--- gdal-1.3.0.orig/alg/GNUmakefile 2004-12-27 08:26:15.000000000 +1100
++++ gdal-1.3.0/alg/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -23,7 +23,7 @@
+ (cd ..; $(MAKE) docs)
+
+ install:
+- for f in *.h ; do $(INSTALL_DATA) $$f $(INST_INCLUDE) ; done
++ for f in *.h ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_INCLUDE) ; done
+
+ lib: $(OBJ)
+ (cd .. ; $(MAKE) force-lib)
+diff -ru gdal-1.3.0.orig/apps/GNUmakefile gdal-1.3.0/apps/GNUmakefile
+--- gdal-1.3.0.orig/apps/GNUmakefile 2005-05-12 17:10:00.000000000 +1000
++++ gdal-1.3.0/apps/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -89,6 +89,6 @@
+
+
+ install: default
+- for f in $(BIN_LIST) ; do $(INSTALL) $$f $(INST_BIN) ; done
+- $(INSTALL) gdal-config-inst $(INST_BIN)/gdal-config
++ for f in $(BIN_LIST) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done
++ $(INSTALL) gdal-config-inst $(DESTDIR)$(INST_BIN)/gdal-config
+
+diff -ru gdal-1.3.0.orig/frmts/mem/GNUmakefile gdal-1.3.0/frmts/mem/GNUmakefile
+--- gdal-1.3.0.orig/frmts/mem/GNUmakefile 2005-01-25 05:09:57.000000000 +1100
++++ gdal-1.3.0/frmts/mem/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -15,4 +15,4 @@
+ install-obj: $(O_OBJ)
+
+ install:
+- $(INSTALL_DATA) memdataset.h $(INST_INCLUDE)
++ $(INSTALL_DATA) memdataset.h $(DESTDIR)$(INST_INCLUDE)
+diff -ru gdal-1.3.0.orig/frmts/raw/GNUmakefile gdal-1.3.0/frmts/raw/GNUmakefile
+--- gdal-1.3.0.orig/frmts/raw/GNUmakefile 2005-01-25 05:09:57.000000000 +1100
++++ gdal-1.3.0/frmts/raw/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -21,4 +21,4 @@
+ $(OBJ) $(O_OBJ): rawdataset.h
+
+ install:
+- $(INSTALL_DATA) rawdataset.h $(INST_INCLUDE)
++ $(INSTALL_DATA) rawdataset.h $(DESTDIR)$(INST_INCLUDE)
+diff -ru gdal-1.3.0.orig/frmts/vrt/GNUmakefile gdal-1.3.0/frmts/vrt/GNUmakefile
+--- gdal-1.3.0.orig/frmts/vrt/GNUmakefile 2005-01-25 05:09:57.000000000 +1100
++++ gdal-1.3.0/frmts/vrt/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -19,4 +19,4 @@
+ $(OBJ) $(O_OBJ): vrtdataset.h
+
+ install:
+- $(INSTALL_DATA) vrtdataset.h $(INST_INCLUDE)
++ $(INSTALL_DATA) vrtdataset.h $(DESTDIR)$(INST_INCLUDE)
+diff -ru gdal-1.3.0.orig/gcore/GNUmakefile gdal-1.3.0/gcore/GNUmakefile
+--- gdal-1.3.0.orig/gcore/GNUmakefile 2005-07-12 03:11:00.000000000 +1000
++++ gdal-1.3.0/gcore/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -32,4 +32,4 @@
+ $*.cpp -o $*.o
+
+ install:
+- for f in *.h ; do $(INSTALL_DATA) $$f $(INST_INCLUDE) ; done
++ for f in *.h ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_INCLUDE) ; done
+diff -ru gdal-1.3.0.orig/man/GNUmakefile gdal-1.3.0/man/GNUmakefile
+--- gdal-1.3.0.orig/man/GNUmakefile 2004-02-21 04:26:13.000000000 +1100
++++ gdal-1.3.0/man/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -5,5 +5,5 @@
+ include ../GDALmake.opt
+
+ install:
+- $(INSTALL_DIR) $(INST_MAN)/man1
+- for f in $(MAN1_FILES) ; do $(INSTALL_DATA) $$f $(INST_MAN)/man1 ; done
++ $(INSTALL_DIR) $(DESTDIR)$(INST_MAN)/man1
++ for f in $(MAN1_FILES) ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_MAN)/man1 ; done
+diff -ru gdal-1.3.0.orig/ogr/GNUmakefile gdal-1.3.0/ogr/GNUmakefile
+--- gdal-1.3.0.orig/ogr/GNUmakefile 2005-03-12 01:28:05.000000000 +1100
++++ gdal-1.3.0/ogr/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -79,7 +79,7 @@
+ cp ogr_feature_style.html html
+
+ install-docs:
+- $(INSTALL_DIR) $(INST_DOCS)/ogr
++ $(INSTALL_DIR) $(DESTDIR)$(INST_DOCS)/ogr
+ cp html/* $(INST_DOCS)/ogr
+
+ gdalso: $(GDAL_SLIB)
+@@ -120,14 +120,14 @@
+
+ ifeq ($(OGR_ENABLED),yes)
+ install-full: apps
+- $(INSTALL) ogr2ogr $(INST_BIN)
+- $(INSTALL) ogrinfo $(INST_BIN)
+- $(INSTALL) ogrtindex $(INST_BIN)
++ $(INSTALL) ogr2ogr $(DESTDIR)$(INST_BIN)
++ $(INSTALL) ogrinfo $(DESTDIR)$(INST_BIN)
++ $(INSTALL) ogrtindex $(DESTDIR)$(INST_BIN)
+ else
+ install-full:
+ endif
+
+ install: install-full
+ for f in $(INST_H_FILES) ; \
+- do $(INSTALL_DATA) $$f $(INST_INCLUDE) ; \
++ do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_INCLUDE) ; \
+ done
+diff -ru gdal-1.3.0.orig/port/GNUmakefile gdal-1.3.0/port/GNUmakefile
+--- gdal-1.3.0.orig/port/GNUmakefile 2005-06-11 01:00:00.000000000 +1000
++++ gdal-1.3.0/port/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -25,7 +25,7 @@
+ $(RM) *.o $(LIB)
+
+ install:
+- for f in *.h ; do $(INSTALL_DATA) $$f $(INST_INCLUDE) ; done
++ for f in *.h ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_INCLUDE) ; done
+
+ xmlreformat: xmlreformat.o
+ $(CXX) $(CXXFLAGS) xmlreformat.o $(CONFIG_LIBS) -o xmlreformat
+diff -ru gdal-1.3.0.orig/pymod/GNUmakefile gdal-1.3.0/pymod/GNUmakefile
+--- gdal-1.3.0.orig/pymod/GNUmakefile 2005-02-01 09:07:02.000000000 +1100
++++ gdal-1.3.0/pymod/GNUmakefile 2005-10-02 18:28:59.000000000 +1000
+@@ -45,9 +45,9 @@
+
+ # special care is taken so that python scripts are installed as executables
+ install: $(GDALMODULE_SO)
+- $(INSTALL_DIR) $(INST_PYMOD)
+- $(INSTALL_LIB) $(GDALMODULE_SO) $(INST_PYMOD)
+- for f in $(PY_COMMANDS) ; do $(INSTALL) $$f $(INST_BIN) ; done
+- for f in $(PY_MODULES) ; do $(INSTALL_DATA) $$f $(INST_PYMOD) ; done
++ $(INSTALL_DIR) $(DESTDIR)$(INST_PYMOD)
++ $(INSTALL_LIB) $(GDALMODULE_SO) $(DESTDIR)$(INST_PYMOD)
++ for f in $(PY_COMMANDS) ; do $(INSTALL) $$f $(DESTDIR)$(INST_BIN) ; done
++ for f in $(PY_MODULES) ; do $(INSTALL_DATA) $$f $(DESTDIR)$(INST_PYMOD) ; done
+ # ugh! spurius relinking leaves a file owned by root into .libs/.
+ rm -f .libs/*.soT
+--- gdal-1.3.0/GDALmake.opt.in.orig 2005-10-02 21:04:30.000000000 +1000
++++ gdal-1.3.0/GDALmake.opt.in 2005-10-02 21:04:59.000000000 +1000
+@@ -50,7 +50,7 @@
+ exec_prefix = @exec_prefix@
+ INST_PREFIX = @exec_prefix@
+ INST_INCLUDE = @includedir@
+-INST_DATA = @datadir@
++INST_DATA = @datadir@/gdal
+ INST_LIB = @libdir@
+ INST_BIN = @bindir@
+ INST_PYMOD = @pymoddir@
diff --git a/sci-libs/gdal/gdal-1.2.6-r3.ebuild b/sci-libs/gdal/gdal-1.2.6-r3.ebuild
index 59d0d272cfb9..085120ff9901 100644
--- a/sci-libs/gdal/gdal-1.2.6-r3.ebuild
+++ b/sci-libs/gdal/gdal-1.2.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r3.ebuild,v 1.5 2005/09/21 06:19:14 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r3.ebuild,v 1.6 2005/10/06 07:11:16 nerdboy Exp $
inherit eutils libtool gnuconfig distutils
@@ -45,6 +45,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${P}-installpathfix.patch || die "epatch failed"
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then
@@ -52,8 +53,8 @@ src_unpack() {
if built_with_use sci-libs/hdf szip ; then
einfo "Found HDF4 compiled with szip. Nice."
else
- ewarn "HDF4 must be compiled with szip USE flag!"
- einfo "Emerge HDF with szip USE flag and then emerge GDAL."
+ ewarn "HDF4 (sci-libs/hdf) must be compiled with szip USE flag!"
+ einfo "Emerge HDF with szip USE flag and then emerge GDAL."
die "HDF4 not merged with szip use flag"
fi
fi
@@ -61,16 +62,8 @@ src_unpack() {
src_compile() {
distutils_python_version
- # This package uses old borked automake/autoconf and libtool, so
- # it doesn't work without ${D} (or with econf and einstall).
- pkg_conf="--prefix=${D}usr --exec-prefix=${D}usr --bindir=${D}usr/bin \
- --datadir=${D}usr/share/gdal --includedir=${D}usr/include/gdal \
- --libdir=${D}usr/$(get_libdir) --mandir=${D}usr/share/man \
- --with-pymoddir=${D}usr/lib/python${PYVER}/site-packages \
- --enable-static=no --enable-shared=yes --with-gnu-ld"
-
- # the above should make libtool behave for the most part
+ pkg_conf="--enable-static=no --enable-shared=yes --with-gnu-ld"
use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
$(use_with postgres pg) $(use_with fits cfitsio) \
@@ -100,7 +93,7 @@ src_compile() {
fi
if useq python ; then
- use_conf="--with-pymoddir=${D}usr/lib/python${PYVER}/site-packages \
+ use_conf="--with-pymoddir=/usr/${get_libdir}/python${PYVER}/site-packages \
${use_conf}"
else
use_conf="--with-python=no ${use_conf}"
@@ -109,13 +102,7 @@ src_compile() {
# Fix doc path just in case
sed -i -e "s:@exec_prefix@/doc:${D}usr/share/doc/${PF}/html:g" GDALmake.opt.in
- ./configure --with-pymoddir=${D}usr/lib/python${PYVER}/site-packages \
- ${pkg_conf} ${use_conf}
-
- # Patch libtool here since it's not created until after configure runs
- sed -i -e "s:hardcode_into_libs=yes:hardcode_into_libs=no:g" libtool
- echo '#undef GDAL_PREFIX' >> port/cpl_config.h
- echo '#define GDAL_PREFIX "/usr"' >> port/cpl_config.h
+ econf ${pkg_conf} ${use_conf} || die "econf failed"
emake || die "emake failed"
if useq doc ; then
emake docs || die "emake docs failed"
@@ -125,9 +112,6 @@ src_compile() {
src_install() {
# einstall causes sandbox violations on /usr/lib/libgdal.so
make DESTDIR=${D} install || die "make install failed"
- dosed "s:${D}usr:/usr:g" /usr/bin/gdal-config
- dosed "s:/usr/local/bin/perl:/usr/bin/perl:g" ${S}/Doxyfile.man
- dosed "s:$(INST_DOCS)/gdal:$(INST_DOCS)/html:g" GNUmakefile
dodoc Doxyfile.man Doxyfile HOWTO-RELEASE NEWS
if useq doc ; then
dohtml html/* || die "install html failed"
diff --git a/sci-libs/gdal/gdal-1.3.0.ebuild b/sci-libs/gdal/gdal-1.3.0.ebuild
index 9e4ffcfef569..920582185080 100644
--- a/sci-libs/gdal/gdal-1.3.0.ebuild
+++ b/sci-libs/gdal/gdal-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0.ebuild,v 1.2 2005/09/21 06:19:14 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0.ebuild,v 1.3 2005/10/06 07:11:16 nerdboy Exp $
inherit eutils libtool gnuconfig distutils
@@ -46,6 +46,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${P}-installpathfix.patch || die "epatch failed"
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then
@@ -53,7 +54,7 @@ src_unpack() {
if built_with_use sci-libs/hdf szip ; then
einfo "Found HDF4 compiled with szip. Nice."
else
- ewarn "HDF4 must be compiled with szip USE flag!"
+ ewarn "HDF4 (sci-libs/hdf) must be compiled with szip USE flag!"
einfo "Emerge HDF with szip USE flag and then emerge GDAL."
die "HDF4 not merged with szip use flag"
fi
@@ -62,16 +63,8 @@ src_unpack() {
src_compile() {
distutils_python_version
- # This package uses old borked automake/autoconf and libtool, so
- # it doesn't work without ${D} (or with econf and einstall).
- pkg_conf="--prefix=${D}usr --exec-prefix=${D}usr --bindir=${D}usr/bin \
- --datadir=${D}usr/share/gdal --includedir=${D}usr/include/gdal \
- --libdir=${D}usr/$(get_libdir) --mandir=${D}usr/share/man \
- --with-pymoddir=${D}usr/lib/python${PYVER}/site-packages \
- --enable-static=no --enable-shared=yes --with-gnu-ld"
-
- # the above should make libtool behave for the most part
+ pkg_conf="--enable-static=no --enable-shared=yes --with-gnu-ld"
use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
$(use_with postgres pg) $(use_with fits cfitsio) \
@@ -101,22 +94,16 @@ src_compile() {
fi
if useq python ; then
- use_conf="--with-pymoddir=${D}usr/lib/python${PYVER}/site-packages \
+ use_conf="--with-pymoddir=/usr/${get_libdir}/python${PYVER}/site-packages \
${use_conf}"
else
use_conf="--with-python=no ${use_conf}"
fi
# Fix doc path just in case
- sed -i -e "s:@exec_prefix@/doc:${D}usr/share/doc/${PF}/html:g" GDALmake.opt.in
-
- ./configure --with-pymoddir=${D}usr/lib/python${PYVER}/site-packages \
- ${pkg_conf} ${use_conf}
+ sed -i -e "s:@exec_prefix@/doc:/usr/share/doc/${PF}/html:g" GDALmake.opt.in
- # Patch libtool here since it's not created until after configure runs
- sed -i -e "s:hardcode_into_libs=yes:hardcode_into_libs=no:g" libtool
- echo '#undef GDAL_PREFIX' >> port/cpl_config.h
- echo '#define GDAL_PREFIX "/usr"' >> port/cpl_config.h
+ econf ${pkg_conf} ${use_conf} || die "econf failed"
emake || die "emake failed"
if useq doc ; then
emake docs || die "emake docs failed"
@@ -126,12 +113,9 @@ src_compile() {
src_install() {
# einstall causes sandbox violations on /usr/lib/libgdal.so
make DESTDIR=${D} install || die "make install failed"
- dosed "s:${D}usr:/usr:g" /usr/bin/gdal-config
- dosed "s:/usr/local/bin/perl:/usr/bin/perl:g" ${S}/Doxyfile.man
- dosed "s:$(INST_DOCS)/gdal:$(INST_DOCS)/html:g" GNUmakefile
dodoc Doxyfile.man Doxyfile HOWTO-RELEASE NEWS
if useq doc ; then
- dohtml html/*.* || die "install html failed"
+ dohtml html/* || die "install html failed"
docinto ogr
dohtml ogr/html/* || die "install ogr html failed"
fi