summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-09 13:24:23 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-09 13:24:23 +0000
commitecc1e139c73e9063dcbeb952acc19b145bd469bf (patch)
tree4e7ade642cac05a767eaceee91b88223a8713de7 /sci-libs/gdal
parentQA: When not using an absolute path, you MUST NOT use a file extension (.png,... (diff)
downloadgentoo-2-ecc1e139c73e9063dcbeb952acc19b145bd469bf.tar.gz
gentoo-2-ecc1e139c73e9063dcbeb952acc19b145bd469bf.tar.bz2
gentoo-2-ecc1e139c73e9063dcbeb952acc19b145bd469bf.zip
Unbreak compilation on Darwin
(Portage version: 2.2.00.15800-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog6
-rw-r--r--sci-libs/gdal/files/gdal-1.5.0-install_name.patch45
-rw-r--r--sci-libs/gdal/gdal-1.6.3-r1.ebuild7
3 files changed, 55 insertions, 3 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 9d8e097c4b66..601b99d199dd 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.74 2010/03/07 19:32:30 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.75 2010/03/09 13:24:22 grobian Exp $
+
+ 09 Mar 2010; Fabian Groffen <grobian@gentoo.org>
+ +files/gdal-1.5.0-install_name.patch, gdal-1.6.3-r1.ebuild:
+ Unbreak compilation on Darwin
*gdal-1.6.3-r1 (07 Mar 2010)
diff --git a/sci-libs/gdal/files/gdal-1.5.0-install_name.patch b/sci-libs/gdal/files/gdal-1.5.0-install_name.patch
new file mode 100644
index 000000000000..e17575267d6e
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.5.0-install_name.patch
@@ -0,0 +1,45 @@
+--- GDALmake.opt.in.orig 2008-02-02 18:25:48.000000000 -0800
++++ GDALmake.opt.in 2008-02-02 18:54:53.000000000 -0800
+@@ -97,6 +97,10 @@
+ GDAL_SLIB = $(GDAL_ROOT)/libgdal.$(SO_EXT)
+ GDAL_SLIB_LINK = -L$(GDAL_ROOT) -lgdal
+
++# for building without libtool
++GDAL_SLIB_SO_VER = $(GDAL_VERSION_MAJOR).$(LIBGDAL_CURRENT).$(LIBGDAL_REVISION)
++GDAL_SLIB_SONAME = -install_name $(INST_LIB)/libgdal.$(GDAL_VERSION_MAJOR).$(SO_EXT)
++
+ # Mac OS X Framework definition
+ MACOSX_FRAMEWORK = @MACOSX_FRAMEWORK@
+
+--- GNUmakefile.orig 2010-03-09 14:03:08 +0100
++++ GNUmakefile 2010-03-09 14:05:29 +0100
+@@ -218,7 +218,7 @@
+
+ ifeq ($(HAVE_LD_SHARED),yes)
+
+-GDAL_SLIB_B = $(notdir $(GDAL_SLIB))
++GDAL_SLIB_B = libgdal
+
+ install-lib:
+
+@@ -226,14 +226,14 @@
+ ifeq ($(MACOSX_FRAMEWORK),yes)
+ $(INSTALL_LIB) $(GDAL_SLIB) $(DESTDIR)$(INST_LIB)/GDAL
+ else
+- rm -f $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B)
+- rm -f $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VERSION_MAJOR)
+- rm -f $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER)
+- $(INSTALL_LIB) $(GDAL_SLIB) $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER)
++ rm -f $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).dylib
++ rm -f $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VERSION_MAJOR).dylib
++ rm -f $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER).dylib
++ $(INSTALL_LIB) $(GDAL_SLIB) $(DESTDIR)$(INST_LIB)/$(GDAL_SLIB_B).$(GDAL_VER).dylib
+ (cd $(DESTDIR)$(INST_LIB) ; \
+- ln -s $(GDAL_SLIB_B).$(GDAL_VER) $(GDAL_SLIB_B).$(GDAL_VERSION_MAJOR))
++ ln -s $(GDAL_SLIB_B).$(GDAL_VER).dylib $(GDAL_SLIB_B).$(GDAL_VERSION_MAJOR).dylib)
+ (cd $(DESTDIR)$(INST_LIB) ; \
+- ln -s $(GDAL_SLIB_B).$(GDAL_VERSION_MAJOR) $(GDAL_SLIB_B))
++ ln -s $(GDAL_SLIB_B).$(GDAL_VERSION_MAJOR).dylib $(GDAL_SLIB_B).dylib)
+ endif
+
+ else
diff --git a/sci-libs/gdal/gdal-1.6.3-r1.ebuild b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
index 76bfe4d8ee8f..b7a222f67897 100644
--- a/sci-libs/gdal/gdal-1.6.3-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.2 2010/03/07 22:56:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.6.3-r1.ebuild,v 1.3 2010/03/09 13:24:22 grobian Exp $
EAPI="3"
WANT_AUTOCONF="2.5"
@@ -76,11 +76,14 @@ src_prepare() {
eautoconf
epatch "${FILESDIR}"/${PN}-1.4.2-datadir.patch \
- "${FILESDIR}"/${PN}-1.5.0-soname.patch \
"${FILESDIR}"/${PN}-1.5.1-python-install.patch \
"${FILESDIR}"/${PN}-1.6.0-swig-fix.patch \
"${FILESDIR}"/${PN}-1.6.1-ruby-make.patch
+ [[ ${CHOST} == *-darwin* ]] \
+ && epatch "${FILESDIR}"/${PN}-1.5.0-install_name.patch \
+ || epatch "${FILESDIR}"/${PN}-1.5.0-soname.patch
+
if useq hdf && useq netcdf; then
ewarn "Netcdf and HDF4 are incompatible due to certain tools in"
ewarn "common; HDF5 is now the preferred choice for HDF data."