summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-06-17 04:45:59 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-06-17 04:45:59 +0000
commit99e96cf08e18edcae6b69aae1a9a04c0bece6d11 (patch)
tree3305f42f174499987c784c1ab132bc59fb9b7215 /sci-libs/gdal
parentstable amd64, bug 274083 (diff)
downloadgentoo-2-99e96cf08e18edcae6b69aae1a9a04c0bece6d11.tar.gz
gentoo-2-99e96cf08e18edcae6b69aae1a9a04c0bece6d11.tar.bz2
gentoo-2-99e96cf08e18edcae6b69aae1a9a04c0bece6d11.zip
Removed older versions (see bug #271137) and marked 1.5.2 stable for ppc
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog8
-rw-r--r--sci-libs/gdal/gdal-1.3.1.ebuild140
-rw-r--r--sci-libs/gdal/gdal-1.3.2.ebuild149
-rw-r--r--sci-libs/gdal/gdal-1.4.2.ebuild149
-rw-r--r--sci-libs/gdal/gdal-1.5.0-r1.ebuild204
-rw-r--r--sci-libs/gdal/gdal-1.5.1.ebuild206
-rw-r--r--sci-libs/gdal/gdal-1.5.2.ebuild4
7 files changed, 9 insertions, 851 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index f9af7c6417a5..2abce285d157 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.58 2009/04/28 05:33:37 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.59 2009/06/17 04:45:59 nerdboy Exp $
+
+ 17 Jun 2009; Steve Arnold <nerdboy@gentoo.org> -gdal-1.3.1.ebuild,
+ -gdal-1.3.2.ebuild, -gdal-1.4.2.ebuild, -gdal-1.5.0-r1.ebuild,
+ -gdal-1.5.1.ebuild, gdal-1.5.2.ebuild:
+ Removed older versions (see bug #271137) and marked 1.5.2 stable for ppc
+ (which it should have been already, but I tested it on efika anyway).
28 Apr 2009; Steve Arnold <nerdboy@gentoo.org>
+files/gdal-1.6.0-ruby-make.patch:
diff --git a/sci-libs/gdal/gdal-1.3.1.ebuild b/sci-libs/gdal/gdal-1.3.1.ebuild
deleted file mode 100644
index af06c1e9f582..000000000000
--- a/sci-libs/gdal/gdal-1.3.1.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.18 2008/10/18 19:08:36 nerdboy Exp $
-
-inherit eutils libtool distutils toolchain-funcs
-
-IUSE="jpeg png geos gif jpeg2k netcdf hdf hdf5 python postgres \
- odbc sqlite ogdi fits gml doc debug"
-
-DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
-HOMEPAGE="http://www.remotesensing.org/gdal/index.html"
-SRC_URI="http://dl.maptools.org/dl/gdal/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-# need to get these arches updated on several libs first
-#KEYWORDS="~alpha ~hppa"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=media-libs/tiff-3.7.0
- sci-libs/libgeotiff
- jpeg? ( media-libs/jpeg )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- python? ( dev-lang/python )
- fits? ( sci-libs/cfitsio )
- ogdi? ( sci-libs/ogdi )
- gml? ( <dev-libs/xerces-c-2.8.0 )
- hdf5? ( >=sci-libs/hdf5-1.6.4 )
- postgres? ( virtual/postgresql-server )
- || (
- netcdf? ( sci-libs/netcdf )
- hdf? ( sci-libs/hdf )
- )
- jpeg2k? ( media-libs/jasper )
- odbc? ( dev-db/unixODBC )
- geos? ( >=sci-libs/geos-2.2.1 )
- sqlite? ( >=dev-db/sqlite-3 )"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-installpathfix.patch" || die "installpath patch failed"
- if [ $(gcc-major-version) -eq 4 ] ; then
- epatch "${FILESDIR}/${PN}-gcc4.patch" || die "gcc4 patch failed"
- fi
- elibtoolize --patch-only
- if useq netcdf && useq hdf; then
- einfo "Checking is HDF4 compiled with szip..."
- if built_with_use sci-libs/hdf szip ; then
- einfo "Found HDF4 compiled with szip. Nice."
- else
- ewarn "HDF4 (sci-libs/hdf) must be compiled with szip USE flag!"
- einfo "Emerge HDF with szip USE flag and then emerge GDAL."
- die "HDF4 not merged with szip use flag"
- fi
- fi
-}
-
-src_compile() {
- distutils_python_version
-
- pkg_conf="--enable-static=no --enable-shared=yes \
- --with-libgrass=no"
-
- use_conf="$(use_with jpeg) $(use_with png) \
- $(use_with postgres pg) $(use_with fits cfitsio) \
- $(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
- $(use_with sqlite) $(use_with jpeg2k jasper) $(use_with odbc) \
- $(use_with gml xerces) $(use_with hdf5)"
- # mysql support temporarily disabled $(use_with mysql)
-
- # It can't find this
- if useq ogdi ; then
- use_conf="--with-ogdi=/usr/$(get_libdir) ${use_conf}"
- fi
-
-# if useq mysql ; then
-# use_conf="--with-mysql=/usr/bin/mysql_config ${use_conf}"
-# fi
-
- if useq gif ; then
- use_conf="--with-gif=internal ${use_conf}"
- else
- use_conf="--with-gif=no ${use_conf}"
- fi
-
- if useq debug ; then
- export CFG=debug
- fi
-
- if useq python ; then
- use_conf="--with-pymoddir=/usr/$(get_libdir)/python${PYVER}/site-packages \
- ${use_conf}"
- else
- use_conf="--with-python=no ${use_conf}"
- fi
-
- # Fix doc path just in case
- sed -i -e "s:@exec_prefix@/doc:/usr/share/doc/${PF}/html:g" \
- GDALmake.opt.in || die "sed gdalmake.opt failed"
-
- econf ${pkg_conf} ${use_conf} || die "econf failed"
- # parallel makes fail on the ogr stuff (C++, what can I say?)
- emake || die "emake failed"
- if useq doc ; then
- emake docs || die "emake docs failed"
- fi
-}
-
-src_install() {
- # einstall causes sandbox violations on /usr/lib/libgdal.so
- make DESTDIR="${D}" install || die "make install failed"
- dodoc Doxyfile.man Doxyfile HOWTO-RELEASE NEWS
- if useq doc ; then
- dohtml html/* || die "install html failed"
- docinto ogr
- dohtml ogr/html/* || die "install ogr html failed"
- fi
-}
-
-pkg_postinst() {
- einfo "GDAL is most useful with full graphics support enabled via various"
- einfo "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
- einfo "geos, and support for either netcdf or HDF4 is available, as well as"
- einfo "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
- einfo "and the new gdal-grass ebuild). HDF5 support is now included."
- ewarn
- einfo "Note: tiff and geotiff are now hard depends, so no USE flags."
- einfo "Also, this package will check for netcdf before hdf, so if you"
- einfo "prefer hdf, please emerge hdf with USE=szip prior to emerging"
- einfo "gdal. Detailed API docs require doxygen (man pages are free)."
- einfo ""
- einfo "Check available image and data formats after building with"
- einfo "gdalinfo and ogrinfo (using the --formats switch)."
-}
diff --git a/sci-libs/gdal/gdal-1.3.2.ebuild b/sci-libs/gdal/gdal-1.3.2.ebuild
deleted file mode 100644
index 4218ac4c7a25..000000000000
--- a/sci-libs/gdal/gdal-1.3.2.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.2.ebuild,v 1.8 2008/10/18 19:08:36 nerdboy Exp $
-
-inherit eutils libtool distutils toolchain-funcs
-
-IUSE="jpeg png geos gif jpeg2k netcdf hdf hdf5 python ruby postgres \
- odbc sqlite ogdi fits gml doc debug"
-
-DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
-HOMEPAGE="http://www.remotesensing.org/gdal/index.html"
-SRC_URI="http://dl.maptools.org/dl/gdal/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-# need to get these arches updated on several libs first
-#KEYWORDS="~alpha ~hppa"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=media-libs/tiff-3.7.0
- sci-libs/libgeotiff
- jpeg? ( media-libs/jpeg )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- python? ( dev-lang/python )
- ruby? ( >=dev-lang/ruby-1.8.4.20060226 )
- fits? ( sci-libs/cfitsio )
- ogdi? ( sci-libs/ogdi )
- gml? ( <dev-libs/xerces-c-2.8.0 )
- hdf5? ( >=sci-libs/hdf5-1.6.4 )
- postgres? ( virtual/postgresql-server )
- || (
- netcdf? ( sci-libs/netcdf )
- hdf? ( sci-libs/hdf )
- )
- jpeg2k? ( media-libs/jasper )
- odbc? ( dev-db/unixODBC )
- geos? ( >=sci-libs/geos-2.2.1 )
- sqlite? ( >=dev-db/sqlite-3 )"
-
-DEPEND="${RDEPEND}
- ruby? ( >=dev-lang/swig-1.3.28 )
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-destdir.patch" || die "epatch failed"
- epatch "${FILESDIR}/${P}-ruby-install.patch" || die "epatch failed"
- if [ $(gcc-major-version) -eq 4 ]; then
- epatch "${FILESDIR}/${P}-gcc4-stl.patch" || die "epatch failed"
- fi
- elibtoolize --patch-only
- if useq netcdf && useq hdf; then
- einfo "Checking is HDF4 compiled with szip..."
- if built_with_use sci-libs/hdf szip ; then
- einfo "Found HDF4 compiled with szip. Nice."
- else
- ewarn "HDF4 (sci-libs/hdf) must be compiled with szip USE flag!"
- einfo "Emerge HDF with szip USE flag and then emerge GDAL."
- die "HDF4 not merged with szip use flag"
- fi
- fi
-}
-
-src_compile() {
- distutils_python_version
-
- pkg_conf="--enable-static=no --enable-shared=yes --with-pic \
- --with-libgrass=no"
-
- use_conf="$(use_with jpeg) $(use_with png) $(use_with ruby) \
- $(use_with postgres pg) $(use_with fits cfitsio) \
- $(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
- $(use_with sqlite) $(use_with jpeg2k jasper) $(use_with odbc) \
- $(use_with gml xerces) $(use_with hdf5)"
- # mysql support temporarily disabled $(use_with mysql)
-
- # It can't find this
- if useq ogdi ; then
- use_conf="--with-ogdi=/usr/$(get_libdir) ${use_conf}"
- fi
-
- #if useq mysql ; then
- # use_conf="--with-mysql=/usr/bin/mysql_config ${use_conf}"
- #fi
-
- if useq gif ; then
- use_conf="--with-gif=internal ${use_conf}"
- else
- use_conf="--with-gif=no ${use_conf}"
- fi
-
- if useq debug ; then
- export CFG=debug
- fi
-
- if useq python ; then
- use_conf="--with-pymoddir=/usr/$(get_libdir)/python${PYVER}/site-packages \
- ${use_conf}"
- else
- use_conf="--with-python=no ${use_conf}"
- fi
-
- # Fix doc path just in case
- sed -i -e "s:@exec_prefix@/doc:/usr/share/doc/${PF}/html:g" \
- GDALmake.opt.in || die "sed gdalmake.opt failed"
-
- econf ${pkg_conf} ${use_conf} || die "econf failed"
- # parallel makes fail on the ogr stuff (C++, what can I say?)
- # also failing with gcc4 in libcsf
- make || die "make failed"
- if useq ruby ; then
- cd "${S}"/swig
- make build || die "make ruby failed"
- cd "${S}"
- fi
- if useq doc ; then
- make docs || die "make docs failed"
- fi
-}
-
-src_install() {
- # einstall causes sandbox violations on /usr/lib/libgdal.so
- make DESTDIR="${D}" install || die "make install failed"
- dodoc Doxyfile.man Doxyfile HOWTO-RELEASE NEWS
- if useq doc ; then
- dohtml html/* || die "install html failed"
- docinto ogr
- dohtml ogr/html/* || die "install ogr html failed"
- fi
-}
-
-pkg_postinst() {
- einfo "GDAL is most useful with full graphics support enabled via various"
- einfo "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
- einfo "geos, and support for either netcdf or HDF4 is available, as well as"
- einfo "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
- einfo "and the new gdal-grass ebuild). HDF5 support is now included."
- ewarn
- einfo "Note: tiff and geotiff are now hard depends, so no USE flags."
- einfo "Also, this package will check for netcdf before hdf, so if you"
- einfo "prefer hdf, please emerge hdf with USE=szip prior to emerging"
- einfo "gdal. Detailed API docs require doxygen (man pages are free)."
- einfo ""
- einfo "Check available image and data formats after building with"
- einfo "gdalinfo and ogrinfo (using the --formats switch)."
-}
diff --git a/sci-libs/gdal/gdal-1.4.2.ebuild b/sci-libs/gdal/gdal-1.4.2.ebuild
deleted file mode 100644
index ded2d03f92d4..000000000000
--- a/sci-libs/gdal/gdal-1.4.2.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.4.2.ebuild,v 1.6 2008/10/18 19:08:36 nerdboy Exp $
-
-inherit eutils libtool distutils toolchain-funcs
-
-IUSE="debug doc fits geos gif gml hdf hdf5 jpeg jpeg2k mysql netcdf \
- odbc png ogdi postgres python ruby sqlite"
-
-DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
-HOMEPAGE="http://www.gdal.org/"
-SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-# need to get these arches updated on several libs first
-#KEYWORDS="~alpha ~hppa"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=media-libs/tiff-3.7.0
- sci-libs/libgeotiff
- jpeg? ( media-libs/jpeg )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- python? ( dev-lang/python )
- ruby? ( >=dev-lang/ruby-1.8.4.20060226 )
- fits? ( sci-libs/cfitsio )
- ogdi? ( sci-libs/ogdi )
- gml? ( <dev-libs/xerces-c-2.8.0 )
- hdf5? ( >=sci-libs/hdf5-1.6.4 )
- postgres? ( virtual/postgresql-server )
- || (
- netcdf? ( sci-libs/netcdf )
- hdf? ( sci-libs/hdf )
- )
- jpeg2k? ( media-libs/jasper )
- mysql? ( virtual/mysql )
- odbc? ( dev-db/unixODBC )
- geos? ( >=sci-libs/geos-2.2.1 )
- sqlite? ( >=dev-db/sqlite-3 )"
-
-DEPEND="${RDEPEND}
- ruby? ( >=dev-lang/swig-1.3.28 )
- doc? ( app-doc/doxygen )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-datadir.patch" || die "epatch failed"
- epatch "${FILESDIR}/${P}-ruby-install.patch" || die "epatch failed"
-
- elibtoolize --patch-only
-
- if useq netcdf && useq hdf; then
- einfo "Checking if HDF4 is compiled with szip..."
- if built_with_use sci-libs/hdf szip ; then
- einfo "Found HDF4 compiled with szip. Nice."
- else
- ewarn "HDF4 (sci-libs/hdf) must be compiled with the szip USE flag!"
- einfo "Please emerge hdf with szip USE flag and then emerge GDAL."
- die "HDF4 not merged with szip use flag"
- fi
- fi
-}
-
-src_compile() {
- distutils_python_version
-
- pkg_conf="--enable-static=no --enable-shared=yes --with-pic \
- --with-libgrass=no"
-
- use_conf="$(use_with jpeg) $(use_with png) $(use_with ruby) \
- $(use_with postgres pg) $(use_with fits cfitsio) \
- $(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
- $(use_with sqlite) $(use_with jpeg2k jasper) $(use_with odbc) \
- $(use_with gml xerces) $(use_with hdf5) $(use_with mysql)"
-
- # It can't find this
- if useq ogdi ; then
- use_conf="--with-ogdi=/usr/$(get_libdir) ${use_conf}"
- fi
-
- if useq mysql ; then
- use_conf="--with-mysql=/usr/bin/mysql_config ${use_conf}"
- fi
-
- if useq gif ; then
- use_conf="--with-gif=internal ${use_conf}"
- else
- use_conf="--with-gif=no ${use_conf}"
- fi
-
- if useq debug ; then
- export CFG=debug
- fi
-
- if useq python ; then
- use_conf="--with-pymoddir=/usr/$(get_libdir)/python${PYVER}/site-packages \
- ${use_conf}"
- else
- use_conf="--with-python=no ${use_conf}"
- fi
-
- # Fix doc path just in case
- sed -i -e "s:@exec_prefix@/doc:/usr/share/doc/${PF}/html:g" \
- GDALmake.opt.in || die "sed gdalmake.opt failed"
-
- econf ${pkg_conf} ${use_conf} || die "econf failed"
- # parallel makes fail on the ogr stuff (C++, what can I say?)
- # also failing with gcc4 in libcsf
- emake -j1 || die "make failed"
- if useq ruby ; then
- cd "${S}"/swig
- make build || die "make ruby failed"
- cd "${S}"
- fi
- if useq doc ; then
- make docs || die "make docs failed"
- fi
-}
-
-src_install() {
- # einstall causes sandbox violations on /usr/lib/libgdal.so
- make DESTDIR="${D}" install || die "make install failed"
- dodoc Doxyfile.man Doxyfile HOWTO-RELEASE NEWS
- if useq doc ; then
- dohtml html/* || die "install html failed"
- docinto ogr
- dohtml ogr/html/* || die "install ogr html failed"
- fi
-}
-
-pkg_postinst() {
- einfo "GDAL is most useful with full graphics support enabled via various"
- einfo "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
- einfo "geos, and support for either netcdf or HDF4 is available, as well as"
- einfo "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
- einfo "and the new gdal-grass ebuild). HDF5 support is now included."
- ewarn
- einfo "Note: tiff and geotiff are now hard depends, so no USE flags."
- einfo "Also, this package will check for netcdf before hdf, so if you"
- einfo "prefer hdf, please emerge hdf with USE=szip prior to emerging"
- einfo "gdal. Detailed API docs require doxygen (man pages are free)."
- einfo ""
- einfo "Check available image and data formats after building with"
- einfo "gdalinfo and ogrinfo (using the --formats switch)."
-}
diff --git a/sci-libs/gdal/gdal-1.5.0-r1.ebuild b/sci-libs/gdal/gdal-1.5.0-r1.ebuild
deleted file mode 100644
index cadcf23307bb..000000000000
--- a/sci-libs/gdal/gdal-1.5.0-r1.ebuild
+++ /dev/null
@@ -1,204 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.0-r1.ebuild,v 1.5 2008/10/12 02:38:16 nerdboy Exp $
-
-WANT_AUTOCONF="2.5"
-inherit autotools distutils eutils perl-module toolchain-funcs
-
-IUSE="curl debug doc fits geos gif gml hdf hdf5 jpeg jpeg2k mysql netcdf \
-odbc png ogdi perl postgres python ruby sqlite threads"
-
-DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
-HOMEPAGE="http://www.gdal.org/"
-SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-# need to get these arches updated on several libs first
-#KEYWORDS="~alpha ~hppa"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=media-libs/tiff-3.7.0
- sci-libs/libgeotiff
- dev-libs/expat
- curl? ( net-misc/curl )
- jpeg? ( media-libs/jpeg )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- perl? ( dev-lang/perl )
- python? ( virtual/python
- dev-python/numpy )
- ruby? ( >=dev-lang/ruby-1.8.4.20060226 )
- fits? ( sci-libs/cfitsio )
- ogdi? ( sci-libs/ogdi )
- gml? ( >=dev-libs/xerces-c-2.8.0 )
- hdf5? ( >=sci-libs/hdf5-1.6.4 )
- postgres? ( virtual/postgresql-server )
- || (
- netcdf? ( sci-libs/netcdf )
- hdf? ( sci-libs/hdf )
- )
- jpeg2k? ( media-libs/jasper )
- mysql? ( virtual/mysql )
- odbc? ( dev-db/unixODBC )
- geos? ( >=sci-libs/geos-2.2.1 )
- sqlite? ( >=dev-db/sqlite-3 )"
-
-DEPEND="${RDEPEND}
- ruby? ( >=dev-lang/swig-1.3.28 )
- doc? ( app-doc/doxygen )"
-
-AT_M4DIR="${S}/m4"
-
-pkg_setup() {
- if [ -n "${GDAL_CONFIGURE_OPTS}" ]; then
- elog "User-specified configure options are ${GDAL_CONFIGURE_OPTS}."
- else
- elog "User-specified configure options are not set."
- elog "If needed, set GDAL_CONFIGURE_OPTS to enable grass support."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- eaclocal
- eautoconf
-
- epatch "${FILESDIR}"/${PN}-1.4.2-datadir.patch \
- "${FILESDIR}"/${P}-python-install.patch \
- "${FILESDIR}"/${P}-soname.patch \
- "${FILESDIR}"/${P}-makefile.patch
-
- if useq netcdf && useq hdf; then
- einfo "Checking if HDF4 is compiled with szip..."
- if built_with_use sci-libs/hdf szip ; then
- einfo "Found HDF4 compiled with szip. Nice."
- else
- ewarn "HDF4 (sci-libs/hdf) must be compiled with the szip USE flag!"
- einfo "Please emerge hdf with szip USE flag and then emerge GDAL."
- die "HDF4 not merged with szip use flag"
- fi
- fi
-}
-
-src_compile() {
- distutils_python_version
-
- local pkg_conf="${GDAL_CONFIGURE_OPTS}"
- local use_conf=""
-
- pkg_conf="${pkg_conf} --enable-shared=yes --with-pic \
- --with-libgrass=no --without-libtool"
-
- use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
- $(use_with postgres pg) $(use_with python) $(use_with ruby) \
- $(use_with threads) $(use_with fits cfitsio) $(use_with perl) \
- $(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
- $(use_with sqlite sqlite3) $(use_with jpeg2k jasper) $(use_with odbc) \
- $(use_with gml xerces) $(use_with hdf5) $(use_with curl) \
- $(use_enable debug)"
-
- # It can't find this
- if useq ogdi ; then
- use_conf="--with-ogdi=/usr/$(get_libdir) ${use_conf}"
- fi
-
- if useq mysql ; then
- use_conf="--with-mysql=/usr/bin/mysql_config ${use_conf}"
- fi
-
- if useq gif ; then
- use_conf="--with-gif=internal ${use_conf}"
- else
- use_conf="--with-gif=no ${use_conf}"
- fi
-
- if useq python ; then
- use_conf="--with-pymoddir=/usr/$(get_libdir)/python${PYVER}/site-packages \
- ${use_conf}"
- fi
-
- # Fix doc path just in case
- sed -i -e "s:@exec_prefix@/doc:/usr/share/doc/${PF}/html:g" \
- GDALmake.opt.in || die "sed gdalmake.opt failed"
-
- econf ${pkg_conf} ${use_conf} || die "econf failed"
-
- # parallel makes fail on the ogr stuff (C++, what can I say?)
- # also failing with gcc4 in libcsf
- emake -j1 || die "emake failed"
-
- if useq python; then
- sed -i -e "s#library_dirs = #library_dirs = /usr/$(get_libdir):#g" \
- swig/python/setup.cfg || die "sed python setup.cfg failed"
- sed -i -e "s:$(DESTDIR)$(prefix):$(DESTDIR)$(INST_PREFIX):g" \
- swig/python/GNUmakefile || die "sed python GNUmakefile failed"
- fi
-
- if useq perl ; then
- cd "${S}"/swig/perl
- perl-module_src_prep
- perl-module_src_compile
- cd "${S}"
- fi
-
- if useq doc ; then
- make docs || die "make docs failed"
- fi
-}
-
-src_install() {
-
- if useq perl ; then
- cd "${S}"/swig/perl
- perl-module_src_install
- sed -i -e "s:BINDINGS = python ruby perl:BINDINGS = python ruby:g" \
- GDALmake.opt
- cd "${S}"
- fi
-
- # einstall causes sandbox violations on /usr/lib/libgdal.so
- make DESTDIR="${D}" install \
- || die "make install failed"
-
- dodoc Doxyfile HOWTO-RELEASE NEWS
-
- if useq doc ; then
- dohtml html/* || die "install html failed"
- docinto ogr
- dohtml ogr/html/* || die "install ogr html failed"
- fi
-
- if useq python; then
- newdoc swig/python/README.txt README-python.txt
- dodir /usr/share/${PN}/samples
- insinto /usr/share/${PN}/samples
- doins swig/python/samples/*
- fi
-}
-
-pkg_postinst() {
- elog
- elog "If you need libgrass support, then you must rebuild gdal, after"
- elog "installing the latest Grass, and set the following option:"
- elog
- elog "GDAL_CONFIGURE_OPTS=--with-grass=${GRASS_HOME} emerge gdal"
- elog
- elog "GDAL is most useful with full graphics support enabled via various"
- elog "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
- elog "geos, and support for either netcdf or HDF4 is available, as well as"
- elog "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
- elog "and rebuilding gdal). HDF5 support is now included."
- elog
- elog "Note: tiff and geotiff are now hard depends, so no USE flags."
- elog "Also, this package will check for netcdf before hdf, so if you"
- elog "prefer hdf, please emerge hdf with USE=szip prior to emerging"
- elog "gdal. Detailed API docs require doxygen (man pages are free)."
- elog
- elog "Check available image and data formats after building with"
- elog "gdalinfo and ogrinfo (using the --formats switch)."
- elog
-}
diff --git a/sci-libs/gdal/gdal-1.5.1.ebuild b/sci-libs/gdal/gdal-1.5.1.ebuild
deleted file mode 100644
index 88a9e657b44f..000000000000
--- a/sci-libs/gdal/gdal-1.5.1.ebuild
+++ /dev/null
@@ -1,206 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.1.ebuild,v 1.2 2008/05/21 19:01:41 dev-zero Exp $
-
-WANT_AUTOCONF="2.5"
-inherit autotools distutils eutils perl-module toolchain-funcs
-
-IUSE="curl debug doc fits geos gif gml hdf hdf5 jpeg jpeg2k mysql netcdf \
-odbc png ogdi perl postgres python ruby sqlite threads"
-
-DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
-HOMEPAGE="http://www.gdal.org/"
-SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-# need to get these arches updated on several libs first
-#KEYWORDS="~alpha ~hppa"
-
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=media-libs/tiff-3.7.0
- sci-libs/libgeotiff
- dev-libs/expat
- curl? ( net-misc/curl )
- jpeg? ( media-libs/jpeg )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- perl? ( dev-lang/perl )
- python? ( virtual/python
- dev-python/numpy )
- ruby? ( >=dev-lang/ruby-1.8.4.20060226 )
- fits? ( sci-libs/cfitsio )
- ogdi? ( sci-libs/ogdi )
- gml? ( >=dev-libs/xerces-c-2.8.0 )
- hdf5? ( >=sci-libs/hdf5-1.6.4 )
- postgres? ( virtual/postgresql-server )
- || (
- netcdf? ( sci-libs/netcdf )
- hdf? ( sci-libs/hdf )
- )
- jpeg2k? ( media-libs/jasper )
- mysql? ( virtual/mysql )
- odbc? ( dev-db/unixODBC )
- geos? ( >=sci-libs/geos-2.2.1 )
- sqlite? ( >=dev-db/sqlite-3 )"
-
-DEPEND="${RDEPEND}
- ruby? ( >=dev-lang/swig-1.3.28 )
- doc? ( app-doc/doxygen )"
-
-AT_M4DIR="${S}/m4"
-
-pkg_setup() {
- if [ -n "${GDAL_CONFIGURE_OPTS}" ]; then
- elog "User-specified configure options are ${GDAL_CONFIGURE_OPTS}."
- else
- elog "User-specified configure options are not set."
- elog "If needed, set GDAL_CONFIGURE_OPTS to enable grass support."
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- eaclocal
- eautoconf
-
- epatch "${FILESDIR}"/${PN}-1.4.2-datadir.patch \
- "${FILESDIR}"/${PN}-1.5.0-soname.patch \
- "${FILESDIR}"/${PN}-1.5.0-makefile.patch \
- "${FILESDIR}"/${P}-python-install.patch \
- "${FILESDIR}"/${P}-max-min.patch
-
- if useq netcdf && useq hdf; then
- einfo "Checking if HDF4 is compiled with szip..."
- if built_with_use sci-libs/hdf szip ; then
- einfo "Found HDF4 compiled with szip. Nice."
- else
- ewarn "HDF4 (sci-libs/hdf) must be compiled with the szip USE flag!"
- einfo "Please emerge hdf with szip USE flag and then emerge GDAL."
- die "HDF4 not merged with szip use flag"
- fi
- fi
-}
-
-src_compile() {
-
- distutils_python_version
-
- local pkg_conf="${GDAL_CONFIGURE_OPTS}"
- local use_conf=""
-
- pkg_conf="${pkg_conf} --enable-shared=yes --with-pic \
- --with-libgrass=no --without-libtool"
-
- use_conf="$(use_with jpeg) $(use_with png) $(use_with mysql) \
- $(use_with postgres pg) $(use_with python) $(use_with ruby) \
- $(use_with threads) $(use_with fits cfitsio) $(use_with perl) \
- $(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
- $(use_with sqlite sqlite3) $(use_with jpeg2k jasper) $(use_with odbc) \
- $(use_with gml xerces) $(use_with hdf5) $(use_with curl) \
- $(use_enable debug)"
-
- # It can't find this
- if useq ogdi ; then
- use_conf="--with-ogdi=/usr/$(get_libdir) ${use_conf}"
- fi
-
- if useq mysql ; then
- use_conf="--with-mysql=/usr/bin/mysql_config ${use_conf}"
- fi
-
- if useq gif ; then
- use_conf="--with-gif=internal ${use_conf}"
- else
- use_conf="--with-gif=no ${use_conf}"
- fi
-
- if useq python ; then
- use_conf="--with-pymoddir=/usr/$(get_libdir)/python${PYVER}/site-packages \
- ${use_conf}"
- fi
-
- # Fix doc path just in case
- sed -i -e "s:@exec_prefix@/doc:/usr/share/doc/${PF}/html:g" \
- GDALmake.opt.in || die "sed gdalmake.opt failed"
-
- econf ${pkg_conf} ${use_conf} || die "econf failed"
-
- # parallel makes fail on the ogr stuff (C++, what can I say?)
- # also failing with gcc4 in libcsf
- emake -j1 || die "emake failed"
-
- if useq python; then
- sed -i -e "s#library_dirs = #library_dirs = /usr/$(get_libdir):#g" \
- swig/python/setup.cfg || die "sed python setup.cfg failed"
- sed -i -e "s:\$(DESTDIR)\$(prefix):\$(DESTDIR)\$(INST_PREFIX):g" \
- swig/python/GNUmakefile || die "sed python makefile failed"
- fi
-
- if useq perl ; then
- cd "${S}"/swig/perl
- perl-module_src_prep
- perl-module_src_compile
- cd "${S}"
- fi
-
- if useq doc ; then
- make docs || die "make docs failed"
- fi
-}
-
-src_install() {
-
- if useq perl ; then
- cd "${S}"/swig/perl
- perl-module_src_install
- sed -i -e "s:BINDINGS = python ruby perl:BINDINGS = python ruby:g" \
- GDALmake.opt
- cd "${S}"
- fi
-
- # einstall causes sandbox violations on /usr/lib/libgdal.so
- make DESTDIR="${D}" install \
- || die "make install failed"
-
- dodoc Doxyfile HOWTO-RELEASE NEWS
-
- if useq doc ; then
- dohtml html/* || die "install html failed"
- docinto ogr
- dohtml ogr/html/* || die "install ogr html failed"
- fi
-
- if useq python; then
- newdoc swig/python/README.txt README-python.txt
- dodir /usr/share/${PN}/samples
- insinto /usr/share/${PN}/samples
- doins swig/python/samples/*
- fi
-}
-
-pkg_postinst() {
- elog
- elog "If you need libgrass support, then you must rebuild gdal, after"
- elog "installing the latest Grass, and set the following option:"
- elog
- elog "GDAL_CONFIGURE_OPTS=--with-grass=${GRASS_HOME} emerge gdal"
- elog
- elog "GDAL is most useful with full graphics support enabled via various"
- elog "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
- elog "geos, and support for either netcdf or HDF4 is available, as well as"
- elog "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
- elog "and rebuilding gdal). HDF5 support is now included."
- elog
- elog "Note: tiff and geotiff are now hard depends, so no USE flags."
- elog "Also, this package will check for netcdf before hdf, so if you"
- elog "prefer hdf, please emerge hdf with USE=szip prior to emerging"
- elog "gdal. Detailed API docs require doxygen (man pages are free)."
- elog
- elog "Check available image and data formats after building with"
- elog "gdalinfo and ogrinfo (using the --formats switch)."
- elog
-}
diff --git a/sci-libs/gdal/gdal-1.5.2.ebuild b/sci-libs/gdal/gdal-1.5.2.ebuild
index c1da150bea12..9e54ada59141 100644
--- a/sci-libs/gdal/gdal-1.5.2.ebuild
+++ b/sci-libs/gdal/gdal-1.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.2.ebuild,v 1.8 2009/03/02 19:51:15 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.2.ebuild,v 1.9 2009/06/17 04:45:59 nerdboy Exp $
WANT_AUTOCONF="2.5"
inherit autotools distutils eutils perl-module toolchain-funcs
@@ -14,7 +14,7 @@ SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="amd64 ~ppc ppc64 sparc x86"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
# need to get these arches updated on several libs first
#KEYWORDS="~alpha ~hppa"