summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-12-03 21:12:46 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-12-03 21:12:46 +0000
commit794c42f75f018dbd896d4021631f3cc2a38fba74 (patch)
tree339031af3084f2cf61bff6a9a239bee0ff6f59f3 /sci-libs/gdal
parentversion bump (diff)
downloadgentoo-2-794c42f75f018dbd896d4021631f3cc2a38fba74.tar.gz
gentoo-2-794c42f75f018dbd896d4021631f3cc2a38fba74.tar.bz2
gentoo-2-794c42f75f018dbd896d4021631f3cc2a38fba74.zip
Fixes for bugs 111688 and 113480.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-libs/gdal')
-rw-r--r--sci-libs/gdal/ChangeLog7
-rw-r--r--sci-libs/gdal/files/gdal-gcc4.patch19
-rw-r--r--sci-libs/gdal/gdal-1.2.6-r4.ebuild11
-rw-r--r--sci-libs/gdal/gdal-1.3.0-r1.ebuild9
-rw-r--r--sci-libs/gdal/gdal-1.3.1.ebuild11
5 files changed, 45 insertions, 12 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 018b5402d3f0..d7f66ffe83fa 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.19 2005/11/21 19:36:21 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.20 2005/12/03 21:12:46 nerdboy Exp $
+
+ 03 Dec 2005; Steve Arnold <nerdboy@gentoo.org> +files/gdal-gcc4.patch,
+ gdal-1.2.6-r4.ebuild, gdal-1.3.0-r1.ebuild, gdal-1.3.1.ebuild:
+ Fixes for bugs 111688 and 113480; thanks to Robert Marmorstein
+ <rmmarm@wm.edu> for the patch.
21 Nov 2005; Simon Stelling <blubb@gentoo.org> gdal-1.2.6-r4.ebuild:
stable on amd64; bug 98593
diff --git a/sci-libs/gdal/files/gdal-gcc4.patch b/sci-libs/gdal/files/gdal-gcc4.patch
new file mode 100644
index 000000000000..d6718d7f310a
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-gcc4.patch
@@ -0,0 +1,19 @@
+*** gdal-1.3.1/frmts/fit/fitdataset.cpp.old Thu Nov 24 12:14:08 2005
+--- gdal-1.3.1/frmts/fit/fitdataset.cpp Thu Nov 24 12:14:19 2005
+***************
+*** 174,180 ****
+
+ public:
+
+! FITRasterBand::FITRasterBand( FITDataset *, int );
+ ~FITRasterBand();
+
+ // should override RasterIO eventually.
+--- 174,180 ----
+
+ public:
+
+! FITRasterBand( FITDataset *, int );
+ ~FITRasterBand();
+
+ // should override RasterIO eventually.
diff --git a/sci-libs/gdal/gdal-1.2.6-r4.ebuild b/sci-libs/gdal/gdal-1.2.6-r4.ebuild
index 1b64686d82d3..264a85bbf4d1 100644
--- a/sci-libs/gdal/gdal-1.2.6-r4.ebuild
+++ b/sci-libs/gdal/gdal-1.2.6-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r4.ebuild,v 1.6 2005/11/21 19:36:21 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.2.6-r4.ebuild,v 1.7 2005/12/03 21:12:46 nerdboy Exp $
-inherit eutils libtool gnuconfig distutils
+inherit eutils libtool gnuconfig distutils toolchain-funcs
IUSE="jpeg png geos gif jasper netcdf hdf python postgres mysql sqlite \
odbc ogdi fits gml doc debug"
@@ -13,7 +13,7 @@ SRC_URI="http://dl.maptools.org/dl/gdal/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="amd64 ~ppc sparc x86"
+KEYWORDS="~amd64 ~ppc sparc x86"
# need to get these arches updated on several libs first
#KEYWORDS="~alpha ~hppa ~ppc64"
@@ -38,13 +38,16 @@ DEPEND=">=sys-libs/zlib-1.1.4
jasper? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( >=dev-db/sqlite-3* )
doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-installpathfix.patch || die "epatch failed"
+ if [ $(gcc-major-version) -eq 4 ] ; then
+ epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ fi
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then
diff --git a/sci-libs/gdal/gdal-1.3.0-r1.ebuild b/sci-libs/gdal/gdal-1.3.0-r1.ebuild
index 0911fcf79493..c53e36756854 100644
--- a/sci-libs/gdal/gdal-1.3.0-r1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0-r1.ebuild,v 1.5 2005/11/02 08:48:21 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.0-r1.ebuild,v 1.6 2005/12/03 21:12:46 nerdboy Exp $
-inherit eutils libtool gnuconfig distutils
+inherit eutils libtool gnuconfig distutils toolchain-funcs
IUSE="jpeg png geos gif jasper netcdf hdf hdf5 python postgres mysql \
odbc sqlite ogdi fits gml doc debug"
@@ -39,13 +39,16 @@ DEPEND=">=sys-libs/zlib-1.1.4
jasper? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( >=dev-db/sqlite-3* )
doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-installpathfix.patch || die "epatch failed"
+ if [ $(gcc-major-version) -eq 4 ] ; then
+ epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ fi
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then
diff --git a/sci-libs/gdal/gdal-1.3.1.ebuild b/sci-libs/gdal/gdal-1.3.1.ebuild
index 92c76b396c48..2112b911656f 100644
--- a/sci-libs/gdal/gdal-1.3.1.ebuild
+++ b/sci-libs/gdal/gdal-1.3.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.3 2005/11/02 08:48:21 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.3.1.ebuild,v 1.4 2005/12/03 21:12:46 nerdboy Exp $
-inherit eutils libtool gnuconfig distutils
+inherit eutils libtool gnuconfig distutils toolchain-funcs
IUSE="jpeg png geos gif jasper netcdf hdf hdf5 python postgres \
odbc sqlite ogdi fits gml doc debug"
@@ -36,13 +36,16 @@ DEPEND=">=sys-libs/zlib-1.1.4
jasper? ( media-libs/jasper )
odbc? ( dev-db/unixODBC )
geos? ( sci-libs/geos )
- sqlite? ( dev-db/sqlite )
+ sqlite? ( >=dev-db/sqlite-3* )
doc? ( app-doc/doxygen )"
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-installpathfix.patch || die "epatch failed"
+ epatch ${FILESDIR}/${P}-installpathfix.patch || die "installpath patch failed"
+ if [ $(gcc-major-version) -eq 4 ] ; then
+ epatch ${FILESDIR}/${PN}-gcc4.patch || die "gcc4 patch failed"
+ fi
elibtoolize --patch-only
gnuconfig_update
if useq netcdf && useq hdf; then