summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-07-15 22:41:41 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-07-15 22:41:41 +0000
commitfdc209aa7fed95e46646b8dcacf6509ce891fd5e (patch)
tree8de05ed72b3197d34aa66475d27df4637d42b0dc /sci-libs/fplll
parentVersion bump (diff)
downloadgentoo-2-fdc209aa7fed95e46646b8dcacf6509ce891fd5e.tar.gz
gentoo-2-fdc209aa7fed95e46646b8dcacf6509ce891fd5e.tar.bz2
gentoo-2-fdc209aa7fed95e46646b8dcacf6509ce891fd5e.zip
initial import wrt #230427
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'sci-libs/fplll')
-rw-r--r--sci-libs/fplll/ChangeLog10
-rw-r--r--sci-libs/fplll/Manifest4
-rw-r--r--sci-libs/fplll/fplll-4.0.4.ebuild33
-rw-r--r--sci-libs/fplll/metadata.xml8
4 files changed, 55 insertions, 0 deletions
diff --git a/sci-libs/fplll/ChangeLog b/sci-libs/fplll/ChangeLog
new file mode 100644
index 000000000000..5740aba252b9
--- /dev/null
+++ b/sci-libs/fplll/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/fplll
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fplll/ChangeLog,v 1.1 2013/07/15 22:41:41 hasufell Exp $
+
+*fplll-4.0.4 (15 Jul 2013)
+
+ 15 Jul 2013; Julian Ospald <hasufell@gentoo.org> +fplll-4.0.4.ebuild,
+ +metadata.xml:
+ initial import wrt #230427
+
diff --git a/sci-libs/fplll/Manifest b/sci-libs/fplll/Manifest
new file mode 100644
index 000000000000..376e7663d73a
--- /dev/null
+++ b/sci-libs/fplll/Manifest
@@ -0,0 +1,4 @@
+DIST libfplll-4.0.4.tar.gz 413519 SHA256 cba8b0ded43f235003a58bcd4b2973105749b3f69732ae09fa44c7e98f5f71b1 SHA512 81cf61118f0dadca8fd82cc58df2fb5f0dc3ddd15a9b5de95a7777e0ece77d8f6a6d50d14ba7fdd6be6697cf375fac2e60792c94cc65f5a181c427dea84d552d WHIRLPOOL a9a9990d899db24693b038ff2d12505be8aa4017f715cf5d3970cf55d6077460a16a69b336b90c88c69877717e555ae79bcf7f014adcc152dd966c0779787a9f
+EBUILD fplll-4.0.4.ebuild 712 SHA256 fa31b988d4b95775072349c1e6d8fb25c0652dc01131ea5287572b8c2dd17e73 SHA512 a2628148ecd89a6795e1a72a134247bbad892a923369167ea642177bf7b431cb27d562bda79af3cf0ae02fd641680d9ce9e1c28199b6df0f96e4828ce56ff2b2 WHIRLPOOL 917685d93ed1aa385429258b50c0bf562d2aa0af01c2ed5fb2d28064f9efa6c451e5a3ac7114752a311224aeec55c44b6fb440accaf1394ea42d11ce98362800
+MISC ChangeLog 262 SHA256 e58029843f8c82f57de054021da1f7f277ce3d774f2eec7627151c8c3b58cb1a SHA512 22bfe37eefddf23a7fe389ba881c3fce81f4377d6923b56cf27fd024705a5b088eaa40f6215e90e3c66b27cf79ce02c41bb4273094b6219603e3165a5599307b WHIRLPOOL fd21002beb8a20034a4064e769998d0e9dcc41031eac7cddd171b076c3ce33b9f67cae9b15079734d7ccb67c0a991dd506a3d15ac1ab9de6a131a2fb73ea94c4
+MISC metadata.xml 234 SHA256 c4cff9874b0aee51bf55a8619e709beb39e4e479e0dfe494e5733fe3fccb644e SHA512 86d9726cc7afc9dae93786d092a32fc954bf376994c24beca21d95dceb3cdbeaa573c3a252acaf85c8d1a7a2b783b5b70f7d73935db8cccfd6725e218f94fdc6 WHIRLPOOL 4a587d464123e0cf60f725b499b0403c9a482e33cc38d545a24f16c9b73464ded264366e426eac9c8fbc6b1d5294da6573811357bf415995c38fdc0887fa77df
diff --git a/sci-libs/fplll/fplll-4.0.4.ebuild b/sci-libs/fplll/fplll-4.0.4.ebuild
new file mode 100644
index 000000000000..79755d635319
--- /dev/null
+++ b/sci-libs/fplll/fplll-4.0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fplll/fplll-4.0.4.ebuild,v 1.1 2013/07/15 22:41:41 hasufell Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Different implementations of the floating-point LLL reduction algorithm"
+HOMEPAGE="http://perso.ens-lyon.fr/damien.stehle/index.html#software"
+SRC_URI="http://perso.ens-lyon.fr/damien.stehle/fplll/lib${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/gmp-4.2.0:0
+ >=dev-libs/mpfr-2.3.0:0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/lib${P}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS README" default
+ dohtml README.html
+ prune_libtool_files
+}
diff --git a/sci-libs/fplll/metadata.xml b/sci-libs/fplll/metadata.xml
new file mode 100644
index 000000000000..a309a9b4706a
--- /dev/null
+++ b/sci-libs/fplll/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+</pkgmetadata>