summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-26 10:29:06 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-26 10:29:06 +0000
commit0458bcf416aef331e39a7e1aafda995f5570656b (patch)
tree270e1ab4f6133ca19908371ebd505a1d8e5c5a10 /sci-libs/flann
parenthttp://my.opera.com/desktopteam/blog/2011/06/26/swordfish-release-candidate-4 (diff)
downloadgentoo-2-0458bcf416aef331e39a7e1aafda995f5570656b.tar.gz
gentoo-2-0458bcf416aef331e39a7e1aafda995f5570656b.tar.bz2
gentoo-2-0458bcf416aef331e39a7e1aafda995f5570656b.zip
Rearranged ebuild
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/flann')
-rw-r--r--sci-libs/flann/ChangeLog6
-rw-r--r--sci-libs/flann/flann-1.6.10.ebuild17
-rw-r--r--sci-libs/flann/flann-1.6.8.ebuild12
-rw-r--r--sci-libs/flann/metadata.xml11
4 files changed, 27 insertions, 19 deletions
diff --git a/sci-libs/flann/ChangeLog b/sci-libs/flann/ChangeLog
index cfacffc90a64..28b221a6f71b 100644
--- a/sci-libs/flann/ChangeLog
+++ b/sci-libs/flann/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/flann
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/flann/ChangeLog,v 1.6 2011/06/13 22:23:24 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/flann/ChangeLog,v 1.7 2011/06/26 10:29:06 jlec Exp $
+
+ 26 Jun 2011; Justin Lecher <jlec@gentoo.org> flann-1.6.8.ebuild,
+ flann-1.6.10.ebuild, metadata.xml:
+ Rearranged ebuild
13 Jun 2011; Sébastien Fabbro <bicatali@gentoo.org> flann-1.6.10.ebuild:
Depend on unzip, closing bug #371513
diff --git a/sci-libs/flann/flann-1.6.10.ebuild b/sci-libs/flann/flann-1.6.10.ebuild
index 2e228e2cd81d..4d91ef342dbd 100644
--- a/sci-libs/flann/flann-1.6.10.ebuild
+++ b/sci-libs/flann/flann-1.6.10.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/flann/flann-1.6.10.ebuild,v 1.2 2011/06/13 22:23:24 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/flann/flann-1.6.10.ebuild,v 1.3 2011/06/26 10:29:06 jlec Exp $
EAPI=3
PYTHON_DEPEND="python? 2:2.5"
-inherit python cmake-utils eutils
+inherit cmake-utils eutils python
-DESCRIPTION="Fast approximate nearest neighbor searches library"
-HOMEPAGE="http://www.cs.ubc.ca/~mariusm/index.php/FLANN/FLANN"
+DESCRIPTION="Library for performing fast approximate nearest neighbor searches in high dimensional spaces"
+HOMEPAGE="http://www.cs.ubc.ca/~mariusm/index.php/FLANN/FLANN/"
SRC_URI="http://people.cs.ubc.ca/~mariusm/uploads/FLANN/${P}-src.zip"
LICENSE="BSD"
@@ -17,7 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc mpi octave python static-libs test"
-RDEPEND="sci-libs/hdf5[mpi?]
+RDEPEND="
+ sci-libs/hdf5[mpi?]
mpi? ( dev-libs/boost[mpi] )
octave? ( sci-mathematics/octave )
python? ( dev-python/numpy )"
@@ -25,7 +26,7 @@ DEPEND="${DEPEND}
app-arch/unzip
test? ( dev-util/gtest )"
-S=${WORKDIR}/${P}-src
+S="${WORKDIR}"/${P}-src
src_prepare() {
# bug #302621
@@ -37,7 +38,7 @@ src_prepare() {
# python standard installation directory respected
sed -i \
-e "/share/d" \
- -e "/COMMAND/s:install:install --root=${ED} --no-compile:" \
+ -e "/COMMAND/s:install:install --root="${ED}" --no-compile:" \
src/python/CMakeLists.txt || die
# produce pure octave files
# octave gentoo installation for .m files respected
@@ -71,7 +72,7 @@ src_configure() {
src_test() {
cd "${CMAKE_BUILD_DIR}"
LD_LIBRARY_PATH="${PWD}/lib" PYTHONPATH="${S}/src/python" \
- make test || die
+ emake test
}
src_install() {
diff --git a/sci-libs/flann/flann-1.6.8.ebuild b/sci-libs/flann/flann-1.6.8.ebuild
index 2507b2640123..216cb4c1b7ee 100644
--- a/sci-libs/flann/flann-1.6.8.ebuild
+++ b/sci-libs/flann/flann-1.6.8.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/flann/flann-1.6.8.ebuild,v 1.4 2011/05/09 23:11:58 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/flann/flann-1.6.8.ebuild,v 1.5 2011/06/26 10:29:06 jlec Exp $
EAPI=3
PYTHON_DEPEND="python? 2:2.5"
-inherit python cmake-utils
+inherit cmake-utils python
DESCRIPTION="Library for performing fast approximate nearest neighbor searches in high dimensional spaces"
-HOMEPAGE="http://www.cs.ubc.ca/~mariusm/index.php/FLANN/FLANN"
+HOMEPAGE="http://www.cs.ubc.ca/~mariusm/index.php/FLANN/FLANN/"
SRC_URI="http://people.cs.ubc.ca/~mariusm/uploads/FLANN/${P}-src.zip"
LICENSE="BSD"
@@ -17,15 +17,17 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="python test"
-RDEPEND="sci-libs/hdf5[mpi,threads]
+RDEPEND="
+ sci-libs/hdf5[mpi,threads]
python? ( dev-python/numpy )"
DEPEND="${DEPEND}
+ app-arch/unzip
test? ( dev-util/gtest )"
RESTRICT=test
# bug 366477
-S=${WORKDIR}/${P}-src
+S="${WORKDIR}"/${P}-src
src_prepare() {
sed -i -e "s:share/doc/flann:share/doc/${PF}:" doc/CMakeLists.txt || die
diff --git a/sci-libs/flann/metadata.xml b/sci-libs/flann/metadata.xml
index 0b45763a8767..e7802be569ce 100644
--- a/sci-libs/flann/metadata.xml
+++ b/sci-libs/flann/metadata.xml
@@ -1,7 +1,8 @@
+<?xml version="1.0"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang='en'>
+ <herd>sci</herd>
+ <longdescription lang="en">
FLANN is a library for performing fast approximate nearest neighbor
searches in high dimensional spaces. It contains a collection of
algorithms we found to work best for nearest neighbor search and a
@@ -10,7 +11,7 @@
FLANN is written in C++ and contains bindings for the following
languages: C, MATLAB and Python.
</longdescription>
-<use>
- <flag name='octave'>Add bindings for <pkg>sci-mathematics/octave</pkg></flag>
-</use>
+ <use>
+ <flag name="octave">Add bindings for <pkg>sci-mathematics/octave</pkg></flag>
+ </use>
</pkgmetadata>