summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-04-11 04:58:06 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-04-11 04:58:06 +0000
commit94ed09b9e75b09e122dc7149cb5d5a470f870ea8 (patch)
tree4992f9cb3a3243859a987e389feca3cc2d420320 /sci-libs/fftw/files
parentStable on x86; version that doesn't seem to suffer from death bug (diff)
downloadgentoo-2-94ed09b9e75b09e122dc7149cb5d5a470f870ea8.tar.gz
gentoo-2-94ed09b9e75b09e122dc7149cb5d5a470f870ea8.tar.bz2
gentoo-2-94ed09b9e75b09e122dc7149cb5d5a470f870ea8.zip
Removed 3dnow use flag since building of shared libs is currently broken on k7 (see bug #125218). Also, added patch to fix compilation failure with altivec support.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sci-libs/fftw/files')
-rw-r--r--sci-libs/fftw/files/fftw-altivec-headers.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/sci-libs/fftw/files/fftw-altivec-headers.patch b/sci-libs/fftw/files/fftw-altivec-headers.patch
new file mode 100644
index 000000000000..baade9bfec66
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-altivec-headers.patch
@@ -0,0 +1,26 @@
+--- configure.ac
++++ configure.ac
+@@ -230,6 +230,12 @@
+ fi
+ AC_SUBST(SIMD_CFLAGS)
+
++dnl Some headers require the simd cflags (like altivec.h)
++save_CFLAGS="$CFLAGS"
++save_CPPFLAGS="$CPPFLAGS"
++CFLAGS="$CFLAGS $SIMD_CFLAGS"
++CPPFLAGS="$CPPFLAGS $SIMD_CFLAGS"
++
+ dnl Checks for header files.
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([libintl.h malloc.h stddef.h stdlib.h string.h strings.h sys/time.h unistd.h limits.h c_asm.h intrinsics.h stdint.h mach/mach_time.h sys/sysctl.h altivec.h])
+@@ -237,6 +243,10 @@
+ dnl intrinsics.h: cray unicos
+ dnl sys/sysctl.h: MacOS X altivec detection
+
++dnl restore normal flags
++CFLAGS="$save_CFLAGS"
++CPPFLAGS="$save_CPPFLAGS"
++
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+ AC_C_INLINE