summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-22 10:11:14 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-22 10:11:14 +0000
commite0a9e1799a060540106860d35f2ae85320eb231d (patch)
tree96c87744fee3dd2fb81c8099960106ed86aa8a98 /sci-libs/fftw/fftw-3.2.2.ebuild
parentdev-haskell/wash removal (pending 01 Jan 2013), see #423763 for reference. (diff)
downloadgentoo-2-e0a9e1799a060540106860d35f2ae85320eb231d.tar.gz
gentoo-2-e0a9e1799a060540106860d35f2ae85320eb231d.tar.bz2
gentoo-2-e0a9e1799a060540106860d35f2ae85320eb231d.zip
sci-libs/fftw: Correct logic to detect openmp capabable compilers
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/fftw/fftw-3.2.2.ebuild')
-rw-r--r--sci-libs/fftw/fftw-3.2.2.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sci-libs/fftw/fftw-3.2.2.ebuild b/sci-libs/fftw/fftw-3.2.2.ebuild
index 5479d4bca26d..fd45cc4fd129 100644
--- a/sci-libs/fftw/fftw-3.2.2.ebuild
+++ b/sci-libs/fftw/fftw-3.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2.ebuild,v 1.18 2012/10/18 21:42:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.2.ebuild,v 1.19 2013/02/22 10:11:14 jlec Exp $
EAPI=2
@@ -26,7 +26,7 @@ pkg_setup() {
elif use threads; then
FFTW_THREADS="--enable-threads --disable-openmp"
fi
- if use openmp && ! tc-has-openmp; then
+ if use openmp && [[ $(tc-getCC) == *gcc* ]] && ! tc-has-openmp; then
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
ewarn "If you want to build fftw with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"