summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-14 17:22:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-14 17:22:50 +0000
commite32e21e9bd67d3d98cf2b2a9c819db5c0b4f2c64 (patch)
treed262eafd1d375d1fa0afebb821d75a874b0a6875 /sci-libs/dsdp
parentRemoved this one for now. Patch failed to apply (diff)
downloadgentoo-2-e32e21e9bd67d3d98cf2b2a9c819db5c0b4f2c64.tar.gz
gentoo-2-e32e21e9bd67d3d98cf2b2a9c819db5c0b4f2c64.tar.bz2
gentoo-2-e32e21e9bd67d3d98cf2b2a9c819db5c0b4f2c64.zip
Fixed leak in one of the examples
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/dsdp')
-rw-r--r--sci-libs/dsdp/ChangeLog6
-rw-r--r--sci-libs/dsdp/dsdp-5.8.ebuild3
-rw-r--r--sci-libs/dsdp/files/dsdp-5.8-readsdpa.patch11
3 files changed, 18 insertions, 2 deletions
diff --git a/sci-libs/dsdp/ChangeLog b/sci-libs/dsdp/ChangeLog
index 70e69f3a195f..00add285fd8a 100644
--- a/sci-libs/dsdp/ChangeLog
+++ b/sci-libs/dsdp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/dsdp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/ChangeLog,v 1.1 2011/03/07 05:33:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/ChangeLog,v 1.2 2011/03/14 17:22:50 bicatali Exp $
+
+ 14 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> dsdp-5.8.ebuild,
+ +files/dsdp-5.8-readsdpa.patch:
+ Fixed leak in one of the examples
*dsdp-5.8 (07 Mar 2011)
diff --git a/sci-libs/dsdp/dsdp-5.8.ebuild b/sci-libs/dsdp/dsdp-5.8.ebuild
index 5c8b8e42d2b5..fc29c136458b 100644
--- a/sci-libs/dsdp/dsdp-5.8.ebuild
+++ b/sci-libs/dsdp/dsdp-5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/dsdp-5.8.ebuild,v 1.1 2011/03/07 05:33:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/dsdp-5.8.ebuild,v 1.2 2011/03/14 17:22:50 bicatali Exp $
EAPI="4"
inherit eutils toolchain-funcs versionator
@@ -31,6 +31,7 @@ make_shared_lib() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-readsdpa.patch
# to do proper parallel compilation
find . -name Makefile -exec \
sed -i -e 's:make :$(MAKE) :g' '{}' \;
diff --git a/sci-libs/dsdp/files/dsdp-5.8-readsdpa.patch b/sci-libs/dsdp/files/dsdp-5.8-readsdpa.patch
new file mode 100644
index 000000000000..f555e50ba0ce
--- /dev/null
+++ b/sci-libs/dsdp/files/dsdp-5.8-readsdpa.patch
@@ -0,0 +1,11 @@
+--- examples/readsdpa.c.orig 2011-03-14 16:49:10.000000000 +0000
++++ examples/readsdpa.c 2011-03-14 17:05:52.000000000 +0000
+@@ -87,7 +87,7 @@
+ double ddobj,ppobj,scl,dpot;
+ char problemname[100],thisline[100], filename[300],savefile[100];
+ char directory[100]="/home/benson/sdpexamples/sdplib/";
+- char outputfile[50]="",suffix[20]=".dat-s", tablename[20]="results-dsdp-5.8";
++ char outputfile[50]="",suffix[20]=".dat-s", tablename[100]="results-dsdp-5.8";
+ char success='s',sformat;
+ FILE *fp1=0,*fp2=0,*fout;
+ DSDPData dddd;