summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-04 07:57:38 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-04 07:57:38 +0000
commit28894f4ee3131b0e6b92944b34112829d594a56c (patch)
tree462a40dc913f3c8ccab68eacefab8766531359f6 /sci-libs/coinor-bcp
parentFix the common coinor pkg-config installation problem (diff)
downloadgentoo-2-28894f4ee3131b0e6b92944b34112829d594a56c.tar.gz
gentoo-2-28894f4ee3131b0e6b92944b34112829d594a56c.tar.bz2
gentoo-2-28894f4ee3131b0e6b92944b34112829d594a56c.zip
Fix the common coinor pkg-config installation problem
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/coinor-bcp')
-rw-r--r--sci-libs/coinor-bcp/ChangeLog5
-rw-r--r--sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild12
2 files changed, 15 insertions, 2 deletions
diff --git a/sci-libs/coinor-bcp/ChangeLog b/sci-libs/coinor-bcp/ChangeLog
index 2944dffe824a..ed9f97ee3ffe 100644
--- a/sci-libs/coinor-bcp/ChangeLog
+++ b/sci-libs/coinor-bcp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/coinor-bcp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-bcp/ChangeLog,v 1.2 2014/01/15 18:20:43 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-bcp/ChangeLog,v 1.3 2014/02/04 07:57:38 jlec Exp $
+
+ 04 Feb 2014; Justin Lecher <jlec@gentoo.org> coinor-bcp-1.3.8.ebuild:
+ Fix the common coinor pkg-config installation problem
15 Jan 2014; Sébastien Fabbro <bicatali@gentoo.org> coinor-bcp-1.3.8.ebuild:
Fixed license, removed sed fix for as-needed (applied upstream), cleanup
diff --git a/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild b/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
index 940b7628236a..0313e4a8678a 100644
--- a/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
+++ b/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild,v 1.2 2014/01/15 18:20:43 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild,v 1.3 2014/02/04 07:57:38 jlec Exp $
EAPI=5
@@ -27,9 +27,19 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+src_prepare() {
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
src_configure() {
+ # needed for the --with-coin-instdir
+ dodir /usr
local myeconfargs=(
--enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
)
autotools-utils_src_configure
}