summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-19 20:35:56 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-19 20:35:56 +0000
commitcc1e4da737e47483b1e8b053352262e3e735cd5f (patch)
treeeb7d3d3f7ced480ee3968d150f1041a1955b8fef /sci-libs/clapack/clapack-3.2.1-r6.ebuild
parentnew bootstrap for x86 (diff)
downloadgentoo-2-cc1e4da737e47483b1e8b053352262e3e735cd5f.tar.gz
gentoo-2-cc1e4da737e47483b1e8b053352262e3e735cd5f.tar.bz2
gentoo-2-cc1e4da737e47483b1e8b053352262e3e735cd5f.zip
Fix hang from KDE bug 274940; find blas using PkgConfig
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/clapack/clapack-3.2.1-r6.ebuild')
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-libs/clapack/clapack-3.2.1-r6.ebuild b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
new file mode 100644
index 000000000000..64af0d5024d0
--- /dev/null
+++ b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r6.ebuild,v 1.1 2011/06/19 20:35:56 dilfridge Exp $
+
+EAPI=4
+
+inherit base cmake-utils
+
+DESCRIPTION="f2c'ed version of LAPACK"
+HOMEPAGE="http://www.netlib.org/clapack/"
+SRC_URI="http://www.netlib.org/${PN}/${P}-CMAKE.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-libs/libf2c-20090407-r1
+ virtual/blas"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-CMAKE
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix_include_file.patch"
+ "${FILESDIR}/${P}-noblasf2c.patch"
+ "${FILESDIR}/${P}-hang.patch"
+ "${FILESDIR}/${P}-findblas-r6.patch"
+)
+
+src_configure() {
+ local mycmakeargs=( $(cmake-utils_use_enable test TESTS) )
+ cmake-utils_src_configure
+}