summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-16 14:28:58 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-16 14:28:58 +0000
commit19397e86df383aee28f759eb275669194108a16b (patch)
treeb2f8b803951cb7dde50e74a318f6d13862d84b07 /sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild
parentRemoval of fortran.eclass, #348851 (diff)
downloadgentoo-2-19397e86df383aee28f759eb275669194108a16b.tar.gz
gentoo-2-19397e86df383aee28f759eb275669194108a16b.tar.bz2
gentoo-2-19397e86df383aee28f759eb275669194108a16b.zip
Removal of fortran.eclass, #348851
(Portage version: 2.2.0_alpha8/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild')
-rw-r--r--sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild b/sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild
index 26c4148fddb8..db977d740618 100644
--- a/sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild
+++ b/sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild,v 1.3 2010/11/08 17:33:46 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccp4-libs/ccp4-libs-6.1.3-r4.ebuild,v 1.4 2010/12/16 14:28:58 jlec Exp $
EAPI="3"
-inherit fortran eutils gnuconfig multilib toolchain-funcs
-
-FORTRAN="g77 gfortran ifc"
+inherit eutils gnuconfig multilib toolchain-funcs
SRC="ftp://ftp.ccp4.ac.uk/ccp4"
@@ -127,7 +125,7 @@ src_configure() {
# irix irix64 sunos sunos64 aix hpux osf1 linux freebsd
# linux_compaq_compilers linux_intel_compilers generic Darwin
# ia64_linux_intel Darwin_ibm_compilers linux_ibm_compilers
- if [[ "${FORTRANC}" = "ifc" ]]; then
+ if [[ "$(tc-getFC)" = "ifort" ]]; then
if use ia64; then
GENTOO_OSNAME="ia64_linux_intel"
else
@@ -163,7 +161,7 @@ src_configure() {
export COPTIM=${CFLAGS}
export CXXOPTIM=${CXXFLAGS}
# Default to -O2 if FFLAGS is unset
- export FC=${FORTRANC}
+ export FC=$(tc-getFC)
export FOPTIM=${FFLAGS:- -O2}
# export CCP4_SCR="${T}"
@@ -171,7 +169,7 @@ src_configure() {
# $(tc-getCC) ${userldflags} -shared -Wl,-soname,libmmdb.so -o libmmdb.so \${MMDBOBJS} $(gcc-config -L | awk -F: '{for(i=1; i<=NF; i++) printf " -L%s", $i}') -lm -lstdc++ && \
export SHARE_LIB="\
$(tc-getCC) ${userldflags} -shared -Wl,-soname,libccp4c.so -o libccp4c.so \${CORELIBOBJS} \${CGENERALOBJS} \${CUCOBJS} \${CMTZOBJS} \${CMAPOBJS} \${CSYMOBJS} -L../ccif/ -lccif $(gcc-config -L | awk -F: '{for(i=1; i<=NF; i++) printf " -L%s", $i}') -lm && \
- ${FORTRANC} ${userldflags} -shared -Wl,-soname,libccp4f.so -o libccp4f.so \${FORTRANLOBJS} \${FINTERFACEOBJS} -L../ccif/ -lccif -L. -lccp4c -lmmdb $(gcc-config -L | awk -F: '{for(i=1; i<=NF; i++) printf " -L%s", $i}') -lstdc++ -lgfortran -lm"
+ $(tc-getFC) ${userldflags} -shared -Wl,-soname,libccp4f.so -o libccp4f.so \${FORTRANLOBJS} \${FINTERFACEOBJS} -L../ccif/ -lccif -L. -lccp4c -lmmdb $(gcc-config -L | awk -F: '{for(i=1; i<=NF; i++) printf " -L%s", $i}') -lstdc++ -lgfortran -lm"
# Can't use econf, configure rejects unknown options like --prefix
./configure \