summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-04-13 21:48:34 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-04-13 21:48:34 +0000
commit297896c3730f84083839b6ab119c32e4edb8a719 (patch)
treedcacb558b6b57f43bae7e4b1527f9254270b916b /sci-libs/arprec/arprec-2.2.2.ebuild
parentMarking smplayer-themes-0.1.18 ppc64 for bug 263218 (diff)
downloadgentoo-2-297896c3730f84083839b6ab119c32e4edb8a719.tar.gz
gentoo-2-297896c3730f84083839b6ab119c32e4edb8a719.tar.bz2
gentoo-2-297896c3730f84083839b6ab119c32e4edb8a719.zip
Initial import
(Portage version: 2.2_rc29/cvs/Linux i686)
Diffstat (limited to 'sci-libs/arprec/arprec-2.2.2.ebuild')
-rw-r--r--sci-libs/arprec/arprec-2.2.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/arprec/arprec-2.2.2.ebuild b/sci-libs/arprec/arprec-2.2.2.ebuild
new file mode 100644
index 000000000000..21a0b45cb7f2
--- /dev/null
+++ b/sci-libs/arprec/arprec-2.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arprec/arprec-2.2.2.ebuild,v 1.1 2009/04/13 21:48:34 grozin Exp $
+EAPI=2
+DESCRIPTION="Arbitrary precision float arithmetics and functions"
+IUSE="fortran qd"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+DEPEND="qd? ( sci-libs/qd )"
+
+src_configure() {
+ econf $(use_enable fortran enable_fortran) \
+ $(use_enable qd enable_qd)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use fortran; then
+ emake toolkit || die "emake toolkit failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS NEWS TODO || die "dodoc failed"
+ if use fortran; then
+ cd toolkit
+ ./mathinit || die "mathinit failed"
+ exeinto /usr/libexec/${PN}
+ doexe mathtool || die "mathtool install failed"
+ insinto /usr/libexec/${PN}
+ doins *.dat || die "mathtool data install failed"
+ docinto toolkit
+ dodoc README || die "mathtool doc install failed"
+ fi
+ cd "${D}"/usr/share/doc || die "cd failed"
+ mv ${PN}/${PN}.pdf ${PF}/ || die "mv failed"
+ rm -rf ${PN}/ || die "rm failed"
+}