summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-23 19:43:00 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-23 19:43:00 +0000
commitbb5a5d51dc9565fa738b361d71da8ab8d1b9f2e7 (patch)
tree202ab973e8f0713ea5ec5d1b89f5509a99b49f7e /sci-libs/amd
parentVersion bump. (diff)
downloadgentoo-2-bb5a5d51dc9565fa738b361d71da8ab8d1b9f2e7.tar.gz
gentoo-2-bb5a5d51dc9565fa738b361d71da8ab8d1b9f2e7.tar.bz2
gentoo-2-bb5a5d51dc9565fa738b361d71da8ab8d1b9f2e7.zip
Bump
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/amd')
-rw-r--r--sci-libs/amd/ChangeLog9
-rw-r--r--sci-libs/amd/amd-2.2.2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/sci-libs/amd/ChangeLog b/sci-libs/amd/ChangeLog
index ad6481ef8062..1b5c21a1e257 100644
--- a/sci-libs/amd/ChangeLog
+++ b/sci-libs/amd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/amd
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/ChangeLog,v 1.25 2010/12/22 18:18:12 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/ChangeLog,v 1.26 2011/02/23 19:43:00 bicatali Exp $
+
+*amd-2.2.2 (23 Feb 2011)
+
+ 23 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> +amd-2.2.2.ebuild:
+ Bump
22 Dec 2010; Sébastien Fabbro <bicatali@gentoo.org> amd-2.2.0.ebuild,
files/amd-2.2.0-autotools.patch, amd-2.2.1.ebuild:
diff --git a/sci-libs/amd/amd-2.2.2.ebuild b/sci-libs/amd/amd-2.2.2.ebuild
new file mode 100644
index 000000000000..e380843457e1
--- /dev/null
+++ b/sci-libs/amd/amd-2.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/amd-2.2.2.ebuild,v 1.1 2011/02/23 19:43:00 bicatali Exp $
+
+EAPI="3"
+
+inherit autotools eutils toolchain-funcs
+
+MY_PN=AMD
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/amd"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc static-libs"
+
+RDEPEND="sci-libs/ufconfig"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.2.0-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/AMD_UserGuide.pdf || die "doc install failed"
+ fi
+}