summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-10-31 12:01:00 +0000
committerJustin Lecher <jlec@gentoo.org>2010-10-31 12:01:00 +0000
commitb110a5c183520687303971bccd26a2e4a8b2c82c (patch)
tree3ffdca4f252d7dc65934dd43f1b8c2187db2e78b /sci-libs/amd
parentVersion bump (diff)
downloadgentoo-2-b110a5c183520687303971bccd26a2e4a8b2c82c.tar.gz
gentoo-2-b110a5c183520687303971bccd26a2e4a8b2c82c.tar.bz2
gentoo-2-b110a5c183520687303971bccd26a2e4a8b2c82c.zip
Version Bump
(Portage version: 2.2.0_alpha2/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/amd')
-rw-r--r--sci-libs/amd/ChangeLog7
-rw-r--r--sci-libs/amd/amd-2.2.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sci-libs/amd/ChangeLog b/sci-libs/amd/ChangeLog
index 0df9e06d17e5..3e151adf25cb 100644
--- a/sci-libs/amd/ChangeLog
+++ b/sci-libs/amd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/amd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/ChangeLog,v 1.19 2010/07/09 10:13:00 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/ChangeLog,v 1.20 2010/10/31 12:01:00 jlec Exp $
+
+*amd-2.2.1 (31 Oct 2010)
+
+ 31 Oct 2010; Justin Lecher <jlec@gentoo.org> +amd-2.2.1.ebuild:
+ Version Bump
09 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> amd-2.2.0.ebuild:
ppc64 stable wrt #318649
diff --git a/sci-libs/amd/amd-2.2.1.ebuild b/sci-libs/amd/amd-2.2.1.ebuild
new file mode 100644
index 000000000000..ad50f90b527e
--- /dev/null
+++ b/sci-libs/amd/amd-2.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/amd-2.2.1.ebuild,v 1.1 2010/10/31 12:01:00 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils fortran
+
+FORTRAN="gfortran ifc"
+
+MY_PN=AMD
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/amd"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+RDEPEND="sci-libs/ufconfig"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2.0-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/AMD_UserGuide.pdf || die "doc install failed"
+ fi
+}