summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-12 01:47:11 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-12 01:47:11 +0000
commitc2e7bac5128bec4502440f4b935325a7a59338fb (patch)
tree7be654573d2aeb53a0aa0b00fc195b1b23860c25 /sci-libs/amd/amd-2.3.1.ebuild
parentInitial import (diff)
downloadgentoo-2-c2e7bac5128bec4502440f4b935325a7a59338fb.tar.gz
gentoo-2-c2e7bac5128bec4502440f4b935325a7a59338fb.tar.bz2
gentoo-2-c2e7bac5128bec4502440f4b935325a7a59338fb.zip
Version bump
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/amd/amd-2.3.1.ebuild')
-rw-r--r--sci-libs/amd/amd-2.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/amd/amd-2.3.1.ebuild b/sci-libs/amd/amd-2.3.1.ebuild
new file mode 100644
index 000000000000..1324d0f06a5d
--- /dev/null
+++ b/sci-libs/amd/amd-2.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/amd-2.3.1.ebuild,v 1.1 2012/11/12 01:47:11 bicatali Exp $
+
+EAPI=4
+
+inherit autotools-utils fortran-2
+
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/amd"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc fortran static-libs"
+
+RDEPEND="sci-libs/suitesparseconfig"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable fortran)
+ $(use_with doc)
+ )
+ autotools-utils_src_configure
+}