summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawek Lis <slis@gentoo.org>2014-03-03 07:15:54 +0000
committerSlawek Lis <slis@gentoo.org>2014-03-03 07:15:54 +0000
commit05431362a42fb03f420b8e5622f0edc81c34ac66 (patch)
tree5bc45bc3cb45775e10fc3b23f5937f2f286a4601 /sci-libs/Fiona/Fiona-9999.ebuild
parentVersion bump. (diff)
downloadgentoo-2-05431362a42fb03f420b8e5622f0edc81c34ac66.tar.gz
gentoo-2-05431362a42fb03f420b8e5622f0edc81c34ac66.tar.bz2
gentoo-2-05431362a42fb03f420b8e5622f0edc81c34ac66.zip
Added Fiona package
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x55265D89)
Diffstat (limited to 'sci-libs/Fiona/Fiona-9999.ebuild')
-rw-r--r--sci-libs/Fiona/Fiona-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/Fiona/Fiona-9999.ebuild b/sci-libs/Fiona/Fiona-9999.ebuild
new file mode 100644
index 000000000000..d0019ce5be41
--- /dev/null
+++ b/sci-libs/Fiona/Fiona-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/Fiona/Fiona-9999.ebuild,v 1.1 2014/03/03 07:15:54 slis Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fiona is OGR's neat, nimble, no-nonsense API"
+HOMEPAGE="https://pypi.python.org/pypi/Fiona"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="http://github.com/Toblerity/${PN}.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=sci-libs/gdal-1.8"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ test? ( dev-python/nose )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+} \ No newline at end of file