summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-02-09 22:14:45 +0000
committerMike Frysinger <vapier@gentoo.org>2012-02-09 22:14:45 +0000
commitfa2d8b7354e23b63f9dd2516c137c7a36f989e93 (patch)
tree14e1f2a2d5f565e79f0ab13a88986de623d8ad8c /sci-geosciences
parentDrop buggy code as discussed on qt@gentoo.org on 2012/02/02 (diff)
downloadgentoo-2-fa2d8b7354e23b63f9dd2516c137c7a36f989e93.tar.gz
gentoo-2-fa2d8b7354e23b63f9dd2516c137c7a36f989e93.tar.bz2
gentoo-2-fa2d8b7354e23b63f9dd2516c137c7a36f989e93.zip
Do not require xmlto for releases since the tarball includes the man pages already, and add a live git ebuild.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog9
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.4-always-install-man-pages.patch36
-rw-r--r--sci-geosciences/gpsd/gpsd-3.4.ebuild23
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild162
4 files changed, 223 insertions, 7 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 85762b2c644b..9e97caa7d0c4 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.82 2012/01/13 17:32:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.83 2012/02/09 22:14:45 vapier Exp $
+
+*gpsd-9999 (09 Feb 2012)
+
+ 09 Feb 2012; Mike Frysinger <vapier@gentoo.org> gpsd-3.4.ebuild,
+ +files/gpsd-3.4-always-install-man-pages.patch, +gpsd-9999.ebuild:
+ Do not require xmlto for releases since the tarball includes the man pages
+ already, and add a live git ebuild.
*gpsd-3.4 (13 Jan 2012)
diff --git a/sci-geosciences/gpsd/files/gpsd-3.4-always-install-man-pages.patch b/sci-geosciences/gpsd/files/gpsd-3.4-always-install-man-pages.patch
new file mode 100644
index 000000000000..c9c1c7d109ad
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.4-always-install-man-pages.patch
@@ -0,0 +1,36 @@
+From 918d6d8e5bac3981126cb01e673430cb7c96ec02 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 9 Feb 2012 16:51:24 -0500
+Subject: [PATCH] always install the man pages
+
+Since we maintain local copies, don't require xmlto/xsltproc in
+order to install them. This makes packaging simpler.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ SConstruct | 9 ++++-----
+ 1 files changed, 4 insertions(+), 5 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index ab85b7d..fb08779 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1186,11 +1186,10 @@ if qt_env:
+
+
+ maninstall = []
+-if manbuilder:
+- for manpage in base_manpages.keys() + python_manpages.keys():
+- section = manpage.split(".")[1]
+- dest = os.path.join(installdir('mandir'), "man"+section, manpage)
+- maninstall.append(env.InstallAs(source=manpage, target=dest))
++for manpage in base_manpages.keys() + python_manpages.keys():
++ section = manpage.split(".")[1]
++ dest = os.path.join(installdir('mandir'), "man"+section, manpage)
++ maninstall.append(env.InstallAs(source=manpage, target=dest))
+ install = env.Alias('install', binaryinstall + maninstall + python_install + pc_install + headerinstall)
+
+ def Uninstall(nodes):
+--
+1.7.8.4
+
diff --git a/sci-geosciences/gpsd/gpsd-3.4.ebuild b/sci-geosciences/gpsd/gpsd-3.4.ebuild
index 2ca85199b7ea..6ebf24fc1b38 100644
--- a/sci-geosciences/gpsd/gpsd-3.4.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.4.ebuild,v 1.1 2012/01/13 17:32:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.4.ebuild,v 1.2 2012/02/09 22:14:45 vapier Exp $
EAPI="4"
@@ -11,13 +11,19 @@ SCONS_MIN_VERSION="1.2.1"
inherit eutils user multilib distutils scons-utils toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
+ inherit git-2
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
HOMEPAGE="http://catb.org/gpsd/"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
GPSD_PROTOCOLS=(
ashtech aivdm clientdebug earthmate evermore fv18 garmin
@@ -39,12 +45,16 @@ RDEPEND="X? ( dev-python/pygtk:2 )
)
ntp? ( net-misc/ntp )
qt4? ( x11-libs/qt-gui )"
-# xml packages are for man page generation
DEPEND="${RDEPEND}
- app-text/xmlto
- =app-text/docbook-xml-dtd-4.1*
test? ( sys-devel/bc )"
+# xml packages are for man page generation
+if [[ ${PV} == "9999" ]] ; then
+ DEPEND+="
+ app-text/xmlto
+ =app-text/docbook-xml-dtd-4.1*"
+fi
+
pkg_setup() {
use python && python_pkg_setup
}
@@ -55,6 +65,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.4-gpsmon-lm.patch
epatch "${FILESDIR}"/${PN}-3.4-strptime.patch
epatch "${FILESDIR}"/${PN}-3.4-chrpath.patch
+ epatch "${FILESDIR}"/${PN}-3.4-always-install-man-pages.patch
# Avoid useless -L paths to the install dir
sed -i \
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
new file mode 100644
index 000000000000..49a95f9c21b7
--- /dev/null
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-9999.ebuild,v 1.1 2012/02/09 22:14:45 vapier Exp $
+
+EAPI="4"
+
+PYTHON_DEPEND="python? 2:2.6"
+RESTRICT_PYTHON_ABIS="3.*"
+SUPPORT_PYTHON_ABIS="1"
+SCONS_MIN_VERSION="1.2.1"
+
+inherit eutils user multilib distutils scons-utils toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.nongnu.org/gpsd.git"
+ inherit git-2
+else
+ SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="GPS daemon and library to support USB/serial GPS devices and various GPS/mapping clients"
+HOMEPAGE="http://catb.org/gpsd/"
+
+LICENSE="BSD"
+SLOT="0"
+
+GPSD_PROTOCOLS=(
+ ashtech aivdm clientdebug earthmate evermore fv18 garmin
+ garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver
+ oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip
+ tripmate tnt ubx
+)
+IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/gpsd_protocols_}
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth cxx debug dbus ipv6 ncurses ntp python qt4 +shm +sockets test udev usb X"
+REQUIRED_USE="X? ( python )"
+
+RDEPEND="X? ( dev-python/pygtk:2 )
+ ncurses? ( sys-libs/ncurses )
+ bluetooth? ( net-wireless/bluez )
+ usb? ( virtual/libusb:1 )
+ dbus? (
+ sys-apps/dbus
+ dev-libs/dbus-glib
+ )
+ ntp? ( net-misc/ntp )
+ qt4? ( x11-libs/qt-gui )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/bc )"
+
+# xml packages are for man page generation
+if [[ ${PV} == "9999" ]] ; then
+ DEPEND+="
+ app-text/xmlto
+ =app-text/docbook-xml-dtd-4.1*"
+fi
+
+pkg_setup() {
+ use python && python_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.3-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-3.4-strptime.patch
+ epatch "${FILESDIR}"/${PN}-3.4-chrpath.patch
+ epatch "${FILESDIR}"/${PN}-3.4-always-install-man-pages.patch
+
+ # Avoid useless -L paths to the install dir
+ sed -i \
+ -e '/^env.Prepend(LIBPATH=.installdir(.libdir.).)$/d' \
+ -e 's:\<STAGING_PREFIX\>:SYSROOT:g' \
+ SConstruct || die
+
+ # Extract python info out of SConstruct so we can use saner distribute
+ if use python ; then
+ pyvar() { sed -n "/^ *$1 *=/s:.*= *::p" SConstruct ; }
+ local pybins=$(pyvar python_progs)
+ local pysrcs=$(sed -n '/^ *python_extensions = {/,/}/{s:^ *::;s:os[.]sep:"/":g;p}' SConstruct)
+ local packet=$(python -c "${pysrcs}; print(python_extensions['gps/packet'])")
+ local client=$(python -c "${pysrcs}; print(python_extensions['gps/clienthelpers'])")
+ sed \
+ -e "s|@VERSION@|$(pyvar gpsd_version)|" \
+ -e "s|@URL@|$(pyvar website)|" \
+ -e "s|@EMAIL@|$(pyvar devmail)|" \
+ -e "s|@SCRIPTS@|${pybins}|" \
+ -e "s|@GPS_PACKET_SOURCES@|${packet}|" \
+ -e "s|@GPS_CLIENT_SOURCES@|${client}|" \
+ -e "s|@SCRIPTS@|$(pyvar python_progs)|" \
+ "${FILESDIR}"/${PN}-3.3-setup.py > setup.py || die
+ distutils_src_prepare
+ fi
+}
+
+src_configure() {
+ myesconsargs=(
+ prefix=/usr
+ libdir="/$(get_libdir)"
+ gpsd_user=gpsd
+ gpsd_group=uucp
+ strip=False
+ python=False
+ $(use_scons bluetooth bluez)
+ $(use_scons cxx libgpsmm)
+ $(use_scons debug)
+ $(use_scons dbus dbus_export)
+ $(use_scons ipv6)
+ $(use_scons ncurses)
+ $(use_scons ntp ntpshm)
+ $(use_scons ntp pps)
+ $(use_scons shm shm_export)
+ $(use_scons sockets socket_export)
+ $(use_scons qt4 libQgpsmm)
+ $(use_scons usb)
+ )
+
+ # enable specified protocols
+ local protocol
+ for protocol in ${GPSD_PROTOCOLS[@]} ; do
+ myesconsargs+=( $(use_scons gpsd_protocols_${protocol} ${protocol}) )
+ done
+}
+
+src_compile() {
+ export CHRPATH=
+ tc-export CC CXX PKG_CONFIG
+ export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
+ escons
+
+ use python && distutils_src_compile
+}
+
+src_install() {
+ DESTDIR="${D}" escons install $(usex udev udev-install "")
+
+ newconfd "${FILESDIR}"/gpsd.conf-2 gpsd
+ newinitd "${FILESDIR}"/gpsd.init-2 gpsd
+
+ if use python ; then
+ distutils_src_install
+ # Delete all X related packages if user doesn't want them
+ if ! use X ; then
+ local p
+ for p in $(grep -Il 'import .*pygtk' *) ; do
+ find "${D}"/usr/bin -name "${p}*" -delete
+ done
+ fi
+ fi
+}
+
+pkg_preinst() {
+ # Run the gpsd daemon as gpsd and group uucp; create it here
+ # as it doesn't seem to be needed during compile/install ...
+ enewuser gpsd -1 -1 -1 "uucp"
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}