summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-05-07 06:56:13 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-05-07 06:56:13 +0000
commitde9625f7a21835912acb82425bedfd1f1db5989c (patch)
treed64bb6855e6ae94c30d78bb878cc94c0eedfd679 /sci-geosciences
parentremove unused net-p2p/transmission:daemon use flag (diff)
downloadgentoo-2-de9625f7a21835912acb82425bedfd1f1db5989c.tar.gz
gentoo-2-de9625f7a21835912acb82425bedfd1f1db5989c.tar.bz2
gentoo-2-de9625f7a21835912acb82425bedfd1f1db5989c.zip
updated to handle either ffmpeg API, but not a permanent fix
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/grass/ChangeLog6
-rw-r--r--sci-geosciences/grass/grass-6.2.3.ebuild26
2 files changed, 17 insertions, 15 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 1c83f74370d2..69b2cf7e389c 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/grass
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.53 2008/05/04 01:14:07 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.54 2008/05/07 06:56:13 nerdboy Exp $
+
+ 07 May 2008; Steve Arnold <nerdboy@gentoo.org> grass-6.2.3.ebuild:
+ Updated to handle either ffmpeg API, but not a permanent fix; this should
+ be reverted to the new interface once ffmpeg is unmasked and stable.
04 May 2008; Steve Arnold <nerdboy@gentoo.org> grass-6.2.1.ebuild:
forced stable version to use the older ffmpeg
diff --git a/sci-geosciences/grass/grass-6.2.3.ebuild b/sci-geosciences/grass/grass-6.2.3.ebuild
index 31026c4bf4cb..1c2e58397c14 100644
--- a/sci-geosciences/grass/grass-6.2.3.ebuild
+++ b/sci-geosciences/grass/grass-6.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.3.ebuild,v 1.3 2008/05/04 01:07:37 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.3.ebuild,v 1.4 2008/05/07 06:56:13 nerdboy Exp $
inherit eutils autotools fdo-mime versionator
@@ -33,7 +33,7 @@ RDEPEND=">=sys-devel/make-3.80
sys-apps/man-db )
sci-libs/gdal
>=sci-libs/proj-4.4.7
- ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
+ ffmpeg? ( media-video/ffmpeg )
fftw? ( sci-libs/fftw )
gmath? ( virtual/blas
virtual/lapack )
@@ -105,15 +105,6 @@ pkg_setup() {
ewarn "GRASS OpenGL support needs X (will also pull in Tcl/Tk)."
die "Please set the X useflag."
fi
-
- if use ffmpeg; then
- ewarn "This version requires the newest ffmpeg, which is a major"
- ewarn "ABI change (and may break things). You should definitely"
- ewarn "rebuild everything that uses ffmpeg if you haven't already"
- ewarn "done so, and be prepared for possible breakage..."
- ewarn "Hit Ctrl-C now if you're not ready to do this."
- epause 10
- fi
}
src_unpack() {
@@ -159,10 +150,17 @@ src_compile() {
myconf="${myconf} --without-opengl --without-glw"
fi
+ # Should handle either older or latest without intervention;
+ # this won't work forever, but it should be okay for a while...
if use ffmpeg; then
- myconf="${myconf} --with-ffmpeg \
- --with-ffmpeg-includes=/usr/include/libavcodec \
- --with-ffmpeg-libs=/usr/$(get_libdir)"
+ myconf="${myconf} --with-ffmpeg \
+ --with-ffmpeg-libs=/usr/$(get_libdir)"
+ if has_version media-video/ffmpeg-0.4.9_p20080326 ; then
+ myconf="${myconf} \
+ --with-ffmpeg-includes=/usr/include/libavcodec"
+ else
+ myconf="${myconf} --with-ffmpeg-includes=/usr/include/ffmpeg"
+ fi
else
myconf="${myconf} --without-ffmpeg"
fi