summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-07-12 12:31:33 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-07-12 12:31:33 +0000
commitda06a5de51df79246d54ca608c7845c826173bf8 (patch)
tree4f5369ac1b9b3c48f442e3c43a7b68588563443a /sci-geosciences
parentVersion bump; PUBLISH fixes now upstream. The channel variable backward compa... (diff)
downloadgentoo-2-da06a5de51df79246d54ca608c7845c826173bf8.tar.gz
gentoo-2-da06a5de51df79246d54ca608c7845c826173bf8.tar.bz2
gentoo-2-da06a5de51df79246d54ca608c7845c826173bf8.zip
backport patch from trunk, fixing macro definition (compile issue), see http://trac.osgeo.org/mapserver/ticket/3877
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/mapserver/ChangeLog7
-rw-r--r--sci-geosciences/mapserver/files/6.0.0-fix-mapunion-macro.patch36
-rw-r--r--sci-geosciences/mapserver/mapserver-6.0.0.ebuild5
3 files changed, 45 insertions, 3 deletions
diff --git a/sci-geosciences/mapserver/ChangeLog b/sci-geosciences/mapserver/ChangeLog
index a81f1767addb..957ebd60248d 100644
--- a/sci-geosciences/mapserver/ChangeLog
+++ b/sci-geosciences/mapserver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/mapserver
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.41 2011/06/28 15:22:38 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.42 2011/07/12 12:31:33 lxnay Exp $
+
+ 12 Jul 2011; Fabio Erculiani <lxnay@gentoo.org>
+ +files/6.0.0-fix-mapunion-macro.patch, mapserver-6.0.0.ebuild:
+ backport patch from trunk, fixing macro definition (compile issue), see
+ http://trac.osgeo.org/mapserver/ticket/3877
28 Jun 2011; Ole Markus With <olemarkus@gentoo.org> -mapserver-5.6.6.ebuild:
Non-maintainer commit: Removing ebuild depending on older PHP versions. Bug
diff --git a/sci-geosciences/mapserver/files/6.0.0-fix-mapunion-macro.patch b/sci-geosciences/mapserver/files/6.0.0-fix-mapunion-macro.patch
new file mode 100644
index 000000000000..952d3b6f6401
--- /dev/null
+++ b/sci-geosciences/mapserver/files/6.0.0-fix-mapunion-macro.patch
@@ -0,0 +1,36 @@
+Index: /trunk/mapserver/HISTORY.TXT
+===================================================================
+--- /trunk/mapserver/HISTORY.TXT (revision 11712)
++++ /trunk/mapserver/HISTORY.TXT (revision 11713)
+@@ -15,4 +15,6 @@
+ Current Version (SVN trunk, 6.1-dev, future 6.2):
+ -------------------------------------------------
++
++- Fixed the build problem in mapunion.c (#3877)
+
+ - Implement to get all shapes with the clustered layer (#3873)
+Index: /trunk/mapserver/mapunion.c
+===================================================================
+--- /trunk/mapserver/mapunion.c (revision 11710)
++++ /trunk/mapserver/mapunion.c (revision 11713)
+@@ -316,5 +316,5 @@
+ /* get items requested by the union layer plus the required items */
+ msLayerSetProcessingKey(srclayer, "ITEMS", itemlist);
+- if (msLayerWhichItems(srclayer, TRUE, NULL) != MS_SUCCESS)
++ if (msLayerWhichItems(srclayer, MS_TRUE, NULL) != MS_SUCCESS)
+ {
+ msFree(itemlist);
+@@ -325,5 +325,5 @@
+ {
+ /* get only the required items */
+- if (msLayerWhichItems(srclayer, FALSE, NULL) != MS_SUCCESS)
++ if (msLayerWhichItems(srclayer, MS_FALSE, NULL) != MS_SUCCESS)
+ return MS_FAILURE;
+ }
+@@ -354,5 +354,5 @@
+
+ /* get only the required items */
+- if (msLayerWhichItems(srclayer, FALSE, NULL) != MS_SUCCESS)
++ if (msLayerWhichItems(srclayer, MS_FALSE, NULL) != MS_SUCCESS)
+ return MS_FAILURE;
+ }
diff --git a/sci-geosciences/mapserver/mapserver-6.0.0.ebuild b/sci-geosciences/mapserver/mapserver-6.0.0.ebuild
index bc5c818f6c1d..fe4f4ba2669e 100644
--- a/sci-geosciences/mapserver/mapserver-6.0.0.ebuild
+++ b/sci-geosciences/mapserver/mapserver-6.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-6.0.0.ebuild,v 1.2 2011/06/11 15:08:55 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-6.0.0.ebuild,v 1.3 2011/07/12 12:31:33 lxnay Exp $
EAPI=3
@@ -117,7 +117,8 @@ src_unpack() {
src_prepare() {
epatch "${FILESDIR}/6.0.0_rc1-ldflags.patch" \
"${FILESDIR}/6.0.0_rc1-bool.patch" \
- "${FILESDIR}/6.0.0_rc1-php_ldflags.patch"
+ "${FILESDIR}/6.0.0_rc1-php_ldflags.patch" \
+ "${FILESDIR}/6.0.0-fix-mapunion-macro.patch"
eautoreconf
}