summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2015-01-11 22:35:05 +0000
committerMarc Schiffbauer <mschiff@gentoo.org>2015-01-11 22:35:05 +0000
commitafbec84038472c028786e67a0d4ed3683c808fb3 (patch)
tree3024cbfde7dc68243beccaa67f730ab062d2b735 /sci-geosciences
parentVersion bump (diff)
downloadgentoo-2-afbec84038472c028786e67a0d4ed3683c808fb3.tar.gz
gentoo-2-afbec84038472c028786e67a0d4ed3683c808fb3.tar.bz2
gentoo-2-afbec84038472c028786e67a0d4ed3683c808fb3.zip
bump version
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x296C6CCA35A64134)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/opencpn/ChangeLog9
-rw-r--r--sci-geosciences/opencpn/opencpn-4.0.0.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/sci-geosciences/opencpn/ChangeLog b/sci-geosciences/opencpn/ChangeLog
index 08dc5bc896d7..492e76a77669 100644
--- a/sci-geosciences/opencpn/ChangeLog
+++ b/sci-geosciences/opencpn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/opencpn
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/opencpn/ChangeLog,v 1.11 2013/08/28 13:06:49 mschiff Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/opencpn/ChangeLog,v 1.12 2015/01/11 22:35:05 mschiff Exp $
+
+*opencpn-4.0.0 (11 Jan 2015)
+
+ 11 Jan 2015; Marc Schiffbauer <mschiff@gentoo.org> +opencpn-4.0.0.ebuild:
+ bump version
28 Aug 2013; Marc Schiffbauer <mschiff@gentoo.org> opencpn-3.0.2.ebuild,
opencpn-3.2.2.ebuild:
diff --git a/sci-geosciences/opencpn/opencpn-4.0.0.ebuild b/sci-geosciences/opencpn/opencpn-4.0.0.ebuild
new file mode 100644
index 000000000000..b20fecee841c
--- /dev/null
+++ b/sci-geosciences/opencpn/opencpn-4.0.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/opencpn/opencpn-4.0.0.ebuild,v 1.1 2015/01/11 22:35:05 mschiff Exp $
+
+EAPI=5
+
+# TODO: add plugins
+
+## wmm_pi, World Magnetic Model (https://github.com/nohal/wmm_pi, GPL-2+)
+#WMM_PLUGIN_PV="1.0"
+#WMM_PLUGIN_PN="wmm_pi"
+#WMM_PLUGIN_P="${WMM_PLUGIN_PN}-${WMM_PLUGIN_PV}"
+#WMM_PLUGIN_URI="https://github.com/nohal/${WMM_PLUGIN_PN}/archive/${WMM_PLUGIN_PN}-v${WMM_PLUGIN_PV}.tar.gz"
+#WMM_PLUGIN_WD="${WORKDIR}/plugins/${WMM_PLUGIN_PN}"
+
+WX_GTK_VER="2.8"
+inherit cmake-utils wxwidgets
+
+DESCRIPTION="a free, open source software for marine navigation"
+HOMEPAGE="http://opencpn.org/"
+SRC_URI="https://github.com/OpenCPN/OpenCPN/archive/v${PV}.tar.gz -> ${P}.tar.gz
+doc? ( https://launchpad.net/~opencpn/+archive/ubuntu/${PN}/+files/${PN}-doc_${PV}.orig.tar.xz )
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gps opengl"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-libs/tinyxml
+ media-libs/freetype:2
+ media-libs/portaudio
+ sys-libs/zlib
+ opengl? ( virtual/opengl )
+ x11-libs/gtk+:2
+ x11-libs/wxGTK:2.8[X]
+ gps? ( >=sci-geosciences/gpsd-2.96-r1 )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S="${WORKDIR}/OpenCPN-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use gps GPSD)
+ -DUSE_S57=ON
+ -DUSE_GARMINHOST=ON
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use doc; then
+ dohtml -r "${S}"/../${PN}/doc/*
+ fi
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ if use doc; then
+ einfo "Documentation is available at file:///usr/share/doc/${P}/html/help_en_US.html"
+ fi
+}