summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-21 22:09:57 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-21 22:09:57 +0000
commitae254a0514011c989bd50efa8851dde7aebbf06a (patch)
tree841c19ebd8c29fcbfa7ec2e9489d78e1014dd9b4 /sci-geosciences
parentInstall pkg-config files. (diff)
downloadgentoo-2-ae254a0514011c989bd50efa8851dde7aebbf06a.tar.gz
gentoo-2-ae254a0514011c989bd50efa8851dde7aebbf06a.tar.bz2
gentoo-2-ae254a0514011c989bd50efa8851dde7aebbf06a.zip
Respect PKG_CONFIG env var when building.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsd/ChangeLog6
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.3-pkg-config.patch49
-rw-r--r--sci-geosciences/gpsd/gpsd-3.3.ebuild5
3 files changed, 57 insertions, 3 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index b09049f0cd1a..73aa9fd94c26 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.74 2011/11/20 06:59:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.75 2011/11/21 22:09:57 vapier Exp $
+
+ 21 Nov 2011; Mike Frysinger <vapier@gentoo.org> gpsd-3.3.ebuild,
+ +files/gpsd-3.3-pkg-config.patch:
+ Respect PKG_CONFIG env var when building.
*gpsd-3.3 (20 Nov 2011)
diff --git a/sci-geosciences/gpsd/files/gpsd-3.3-pkg-config.patch b/sci-geosciences/gpsd/files/gpsd-3.3-pkg-config.patch
new file mode 100644
index 000000000000..0bb4b3c8e0aa
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.3-pkg-config.patch
@@ -0,0 +1,49 @@
+From b6ef265b49d973acc2295f46f0518e0644ba7dbb Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 21 Nov 2011 16:05:27 -0500
+Subject: [PATCH] respect PKG_CONFIG in the build env
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ SConstruct | 9 +++++----
+ 1 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/SConstruct b/SConstruct
+index cb578fe..5bb0fed 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -214,8 +214,9 @@ env['PYTHON'] = sys.executable
+ # explicitly quote them or (better yet) use the "=" form of GNU option
+ # settings.
+ env['STRIP'] = "strip"
++env['PKG_CONFIG'] = "pkg-config"
+ env['CHRPATH'] = 'chrpath'
+-for i in ["AR", "ARFLAGS", "CCFLAGS", "CFLAGS", "CC", "CXX", "CXXFLAGS", "STRIP", "CHRPATH", "LD", "TAR"]:
++for i in ["AR", "ARFLAGS", "CCFLAGS", "CFLAGS", "CC", "CXX", "CXXFLAGS", "STRIP", "PKG_CONFIG", "CHRPATH", "LD", "TAR"]:
+ if os.environ.has_key(i):
+ j = i
+ if i == "LD":
+@@ -407,9 +408,9 @@ cxx = config.CheckCXX()
+ # define a helper function for pkg-config - we need to pass
+ # --static for static linking, too.
+ if env["shared"]:
+- pkg_config = lambda pkg: ['!pkg-config --cflags --libs %s' %(pkg, )]
++ pkg_config = lambda pkg: ['!%s --cflags --libs %s' %(env['PKG_CONFIG'], pkg, )]
+ else:
+- pkg_config = lambda pkg: ['!pkg-config --cflags --libs --static %s' %(pkg, )]
++ pkg_config = lambda pkg: ['!%s --cflags --libs --static %s' %(env['PKG_CONFIG'], pkg, )]
+
+ # GCC isn't always named gcc, alas.
+ if env['CC'] == 'gcc' or (sys.platform.startswith('freebsd') and env['CC'] == 'cc'):
+@@ -339,7 +340,7 @@ if "help" in ARGLIST:
+
+ def CheckPKG(context, name):
+ context.Message( 'Checking for %s... ' % name )
+- ret = context.TryAction('pkg-config --exists \'%s\'' % name)[0]
++ ret = context.TryAction('%s --exists \'%s\'' % (env['PKG_CONFIG'], name))[0]
+ context.Result( ret )
+ return ret
+
+--
+1.7.6.1
+
diff --git a/sci-geosciences/gpsd/gpsd-3.3.ebuild b/sci-geosciences/gpsd/gpsd-3.3.ebuild
index 3d2ffa32c9c9..863c2316ca53 100644
--- a/sci-geosciences/gpsd/gpsd-3.3.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.3.ebuild,v 1.1 2011/11/20 06:59:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.3.ebuild,v 1.2 2011/11/21 22:09:57 vapier Exp $
EAPI="4"
@@ -52,6 +52,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${P}-release-rev.patch
epatch "${FILESDIR}"/${P}-udev-install.patch
+ epatch "${FILESDIR}"/${P}-pkg-config.patch
# Avoid useless -L paths to the install dir
sed -i \
@@ -108,7 +109,7 @@ src_configure() {
src_compile() {
export CHRPATH=true
- tc-export CC CXX
+ tc-export CC CXX PKG_CONFIG
export SHLINKFLAGS=${LDFLAGS} LINKFLAGS=${LDFLAGS}
escons