summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2013-04-02 20:27:16 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2013-04-02 20:27:16 +0000
commita13fac6221bcc0b1fe29069cb8ebb9fbf78c3da2 (patch)
tree018734541acff86eaf6cd590fc484349d9578124 /sci-geosciences
parentVersion bump #464222 by Joe M. (diff)
downloadgentoo-2-a13fac6221bcc0b1fe29069cb8ebb9fbf78c3da2.tar.gz
gentoo-2-a13fac6221bcc0b1fe29069cb8ebb9fbf78c3da2.tar.bz2
gentoo-2-a13fac6221bcc0b1fe29069cb8ebb9fbf78c3da2.zip
Fix introspection issue, add python bindings support, bug #373809. Thanks to Nikoli, EvaSDK and hasufell.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/osm-gps-map/ChangeLog8
-rw-r--r--sci-geosciences/osm-gps-map/files/osm-gps-map-0.7.3-fix-introspection.patch10
-rw-r--r--sci-geosciences/osm-gps-map/files/osm-gps-map-0.7.3-fix-python-setup.py.patch15
-rw-r--r--sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild73
4 files changed, 86 insertions, 20 deletions
diff --git a/sci-geosciences/osm-gps-map/ChangeLog b/sci-geosciences/osm-gps-map/ChangeLog
index 803f0c1f1c3d..591390757234 100644
--- a/sci-geosciences/osm-gps-map/ChangeLog
+++ b/sci-geosciences/osm-gps-map/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/osm-gps-map
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/ChangeLog,v 1.1 2013/03/28 18:57:59 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/ChangeLog,v 1.2 2013/04/02 20:27:16 maksbotan Exp $
+
+ 02 Apr 2013; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/osm-gps-map-0.7.3-fix-introspection.patch,
+ +files/osm-gps-map-0.7.3-fix-python-setup.py.patch, osm-gps-map-0.7.3.ebuild:
+ Fix introspection issue, add python bindings support, bug #373809. Thanks to
+ Nikoli, EvaSDK and hasufell.
*osm-gps-map-0.7.3 (28 Mar 2013)
diff --git a/sci-geosciences/osm-gps-map/files/osm-gps-map-0.7.3-fix-introspection.patch b/sci-geosciences/osm-gps-map/files/osm-gps-map-0.7.3-fix-introspection.patch
new file mode 100644
index 000000000000..350876ce40bb
--- /dev/null
+++ b/sci-geosciences/osm-gps-map/files/osm-gps-map-0.7.3-fix-introspection.patch
@@ -0,0 +1,10 @@
+--- src/Makefile.am 2011-03-19 10:08:23.000000000 +0300
++++ src/Makefile.am 2013-04-02 23:13:01.408952029 +0400
+@@ -86,6 +86,7 @@
+ OsmGpsMap_1_0_gir_CFLAGS = $(OSMGPSMAP_CFLAGS)
+ OsmGpsMap_1_0_gir_LIBS = libosmgpsmap.la
+ OsmGpsMap_1_0_gir_FILES = $(introspection_sources)
++OsmGpsMap_1_0_gir_SCANNERFLAGS = --identifier-prefix=OsmGps
+ INTROSPECTION_GIRS += OsmGpsMap-1.0.gir
+
+ girdir = $(datadir)/gir-1.0
diff --git a/sci-geosciences/osm-gps-map/files/osm-gps-map-0.7.3-fix-python-setup.py.patch b/sci-geosciences/osm-gps-map/files/osm-gps-map-0.7.3-fix-python-setup.py.patch
new file mode 100644
index 000000000000..f6287bfc1135
--- /dev/null
+++ b/sci-geosciences/osm-gps-map/files/osm-gps-map-0.7.3-fix-python-setup.py.patch
@@ -0,0 +1,15 @@
+--- setup.py 2011-03-19 10:08:23.000000000 +0300
++++ setup.py 2013-04-02 23:35:01.469947224 +0400
+@@ -21,9 +21,9 @@
+
+ _osmgpsmap = Extension(name = 'osmgpsmap',
+ sources= ['osmgpsmapmodule.c','osmgpsmap.c'],
+- include_dirs = get_include('osmgpsmap pygobject-2.0'),
+- library_dirs = get_lib_dirs('osmgpsmap pygobject-2.0'),
+- libraries = get_libs('osmgpsmap pygobject-2.0'),
++ include_dirs = get_include('gtk+-2.0 pygobject-2.0'),
++ library_dirs = get_lib_dirs('gtk+-2.0 pygobject-2.0'),
++ libraries = get_libs('gtk+-2.0 pygobject-2.0') + ["osmgpsmap"],
+ define_macros = [('VERSION', '"""%s"""' % VERSION)],
+ )
+
diff --git a/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild b/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
index 6cb769cfd9f6..7964f21eade6 100644
--- a/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
+++ b/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild
@@ -1,42 +1,77 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild,v 1.1 2013/03/28 18:57:59 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osm-gps-map/osm-gps-map-0.7.3.ebuild,v 1.2 2013/04/02 20:27:16 maksbotan Exp $
-EAPI="5"
+EAPI=5
-inherit autotools gnome2
+PYTHON_COMPAT=( python2_{6,7} )
+DISTUTILS_OPTIONAL=1
-DESCRIPTION="A gtk+ viewer for OpenStreetMap files."
+inherit autotools gnome2 distutils-r1
+
+DESCRIPTION="A gtk+ viewer for OpenStreetMap files"
HOMEPAGE="http://nzjrs.github.com/${PN}/"
-SRC_URI="http://www.johnstowers.co.nz/files/${PN}/${P}.tar.gz"
+SRC_URI="http://www.johnstowers.co.nz/files/${PN}/${P}.tar.gz
+python? ( http://www.johnstowers.co.nz/files/${PN}/python-osmgpsmap-${PV}.tar.gz )"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="introspection python"
-DEPEND="
+RDEPEND="
>=dev-libs/glib-2.16.0
- gnome-base/gnome-common
>=net-libs/libsoup-2.4.0
>=x11-libs/cairo-1.6.0
- >=x11-libs/gtk+-2.14.0
+ >=x11-libs/gtk+-2.14.0:2
+ x11-libs/gdk-pixbuf
introspection? ( dev-libs/gobject-introspection )
+ python? ( ${PYTHON_DEPS}
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ )
"
-RDEPEND="${DEPEND}"
-
-G2CONF="
- $(use_enable introspection)
- --docdir=/usr/share/doc/${PN}
- --disable-dependency-tracking
- --enable-fast-install
- --disable-static
-"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ gnome-base/gnome-common"
+
+PYTHON_S="${WORKDIR}/python-osmgpsmap-${PV}"
+
+pkg_setup() {
+ #configure script does not accept quoted EPREFIX...
+ G2CONF="
+ $(use_enable introspection)
+ --docdir=/usr/share/doc/${PF}
+ --enable-fast-install
+ --disable-static
+ "
+}
src_prepare() {
- epatch "${FILESDIR}/${P}-fix-docs-location.patch"
-# epatch "${FILESDIR}/${P}-disable-compiler-warnings.patch"
+ epatch "${FILESDIR}/${P}-fix-docs-location.patch" \
+ "${FILESDIR}/${P}-fix-introspection.patch"
eautoreconf
gnome2_src_prepare
+
+ cd "${PYTHON_S}" || die
+ epatch "${FILESDIR}/${P}-fix-python-setup.py.patch"
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use python; then
+ cd "${PYTHON_S}" || die
+ CFLAGS="${CFLAGS} -I\"${S}\"/src" LDFLAGS="${LDFLAGS} -L\"${S}\"/src/.libs" distutils-r1_src_compile
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python; then
+ cd "${PYTHON_S}" || die
+ distutils-r1_src_install
+ fi
}