summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-02 21:51:23 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-02 21:51:23 +0000
commit90d8f92fd13088d3200f652358fc2928110ff5fc (patch)
treefedec720900f4762d5fb474c5abacf559f59d4a6 /sci-geosciences
parentBump to new RC. (diff)
downloadgentoo-2-90d8f92fd13088d3200f652358fc2928110ff5fc.tar.gz
gentoo-2-90d8f92fd13088d3200f652358fc2928110ff5fc.tar.bz2
gentoo-2-90d8f92fd13088d3200f652358fc2928110ff5fc.zip
Make php extension really work.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/mapserver/ChangeLog6
-rw-r--r--sci-geosciences/mapserver/files/6.0.0_rc1-php_ldflags.patch15
-rw-r--r--sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild26
3 files changed, 41 insertions, 6 deletions
diff --git a/sci-geosciences/mapserver/ChangeLog b/sci-geosciences/mapserver/ChangeLog
index 1ad3569e8208..4b8a4cbd31ae 100644
--- a/sci-geosciences/mapserver/ChangeLog
+++ b/sci-geosciences/mapserver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/mapserver
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.37 2011/05/02 20:09:56 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/ChangeLog,v 1.38 2011/05/02 21:51:22 scarabeus Exp $
+
+ 02 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/6.0.0_rc1-php_ldflags.patch, mapserver-6.0.0_rc1.ebuild:
+ Make php extension really work.
02 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
mapserver-6.0.0_rc1.ebuild:
diff --git a/sci-geosciences/mapserver/files/6.0.0_rc1-php_ldflags.patch b/sci-geosciences/mapserver/files/6.0.0_rc1-php_ldflags.patch
new file mode 100644
index 000000000000..706bae4ce7b1
--- /dev/null
+++ b/sci-geosciences/mapserver/files/6.0.0_rc1-php_ldflags.patch
@@ -0,0 +1,15 @@
+--- mapserver-6.0.0-rc1.old/mapscript/php/Makefile.in 2011-05-02 12:10:03.000000000 +0200
++++ mapserver-6.0.0-rc1/mapscript/php/Makefile.in 2011-05-02 23:43:15.000000000 +0200
+@@ -86,10 +86,10 @@
+
+
+ php_mapscript.so: $(PHPMS_OBJS) ../../libmapserver.a
+- $(LD) -o $@ $(PHPMS_OBJS) $(MS_LIBS)
++ $(LD) -o $@ $(LDFLAGS) $(PHPMS_OBJS) $(MS_LIBS)
+
+ php_proj.so: $(PHPPROJ_OBJS)
+- $(LD) -o $@ $(PHPPROJ_OBJS) $(MS_LIBS)
++ $(LD) -o $@ $(LDFLAGS) $(PHPPROJ_OBJS) $(MS_LIBS)
+
+ %.o: %.c php_mapscript_util.h php_mapscript.h
+ $(CC) $(CFLAGS112) -c -o $@ $<
diff --git a/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild b/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild
index 27916ca8a827..e618286523ef 100644
--- a/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild
+++ b/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild,v 1.10 2011/05/02 20:09:56 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/mapserver/mapserver-6.0.0_rc1.ebuild,v 1.11 2011/05/02 21:51:22 scarabeus Exp $
EAPI=3
@@ -87,6 +87,16 @@ _enter_build_dir() {
each_ruby_configure() { ${RUBY} extconf.rb || die ; }
+ext-source-r2_src_install() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ newins "${PHP_EXT_NAME}.so" "${PHP_EXT_NAME}.so" || die "Unable to install extension"
+ done
+ php-ext-source-r2_createinifiles
+}
+
pkg_setup() {
webapp_pkg_setup
use perl && perl-module_pkg_setup
@@ -97,11 +107,17 @@ pkg_setup() {
src_unpack() {
# unpack A and then copy the php thingies into workdir/php-slot
php-ext-source-r2_src_unpack
+ # HACK: and then remove it and replace by symlink
+ for slot in $(php_get_slots); do
+ rm -rf "${WORKDIR}/${slot}" || die
+ ln -s "${PHP_EXT_S}" "${WORKDIR}/${slot}" || die
+ done
}
src_prepare() {
epatch "${FILESDIR}/6.0.0_rc1-ldflags.patch" \
- "${FILESDIR}/6.0.0_rc1-bool.patch"
+ "${FILESDIR}/6.0.0_rc1-bool.patch" \
+ "${FILESDIR}/6.0.0_rc1-php_ldflags.patch"
eautoreconf
}
@@ -158,11 +174,11 @@ src_configure() {
}
src_compile() {
- emake -j1 || die
+ emake || die
use python && _enter_build_dir "${S}/mapscript/python" "distutils_src_compile"
use perl && _enter_build_dir "${S}/mapscript/perl" "perl-module_src_prep"
use perl && _enter_build_dir "${S}/mapscript/perl" "perl-module_src_compile"
- use php && php-ext-source-r2_src_compile
+ #use php && php-ext-source-r2_src_compile # already compiled by the emake all
#use ruby && _enter_build_dir "${S}/mapscript/ruby" "ruby-ng_src_compile"
}
@@ -184,7 +200,7 @@ src_install() {
use python && _enter_build_dir "${S}/mapscript/python" "distutils_src_install"
use perl && _enter_build_dir "${S}/mapscript/perl" "perl-module_src_install"
use perl && _enter_build_dir "${S}/mapscript/perl" "fixlocalpod"
- use php && php-ext-source-r2_src_install
+ use php && ext-source-r2_src_install
#use ruby && _enter_build_dir "${S}/mapscript/ruby" "ruby-ng_src_install"
webapp_src_preinst