summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-21 20:06:52 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-21 20:06:52 +0000
commit5fe8d1a5d7986bae00efd66fdfe37e6608566ea5 (patch)
tree9b9941038af33fa603801962a82d6c0bf8f889a9 /sci-geosciences
parentx86 stable, bug #289703 (diff)
downloadgentoo-2-5fe8d1a5d7986bae00efd66fdfe37e6608566ea5.tar.gz
gentoo-2-5fe8d1a5d7986bae00efd66fdfe37e6608566ea5.tar.bz2
gentoo-2-5fe8d1a5d7986bae00efd66fdfe37e6608566ea5.zip
Initial import from science overlay, requirement for qgis, see bug #113355
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gdal-grass/ChangeLog10
-rw-r--r--sci-geosciences/gdal-grass/files/gdal-grass-makefile.patch11
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild43
-rw-r--r--sci-geosciences/gdal-grass/metadata.xml6
4 files changed, 70 insertions, 0 deletions
diff --git a/sci-geosciences/gdal-grass/ChangeLog b/sci-geosciences/gdal-grass/ChangeLog
new file mode 100644
index 000000000000..59d6feeec9bc
--- /dev/null
+++ b/sci-geosciences/gdal-grass/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-geosciences/gdal-grass
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/ChangeLog,v 1.1 2009/11/21 20:06:52 bicatali Exp $
+
+*gdal-grass-1.4.3 (21 Nov 2009)
+
+ 21 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +gdal-grass-1.4.3.ebuild, +files/gdal-grass-makefile.patch, +metadata.xml:
+ Initial import from science overlay, requirement for qgis, see bug #113355
+
diff --git a/sci-geosciences/gdal-grass/files/gdal-grass-makefile.patch b/sci-geosciences/gdal-grass/files/gdal-grass-makefile.patch
new file mode 100644
index 000000000000..dcf5bc40065b
--- /dev/null
+++ b/sci-geosciences/gdal-grass/files/gdal-grass-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2009-07-12 00:09:33.000000000 +0200
++++ Makefile.in 2009-07-12 00:11:09.000000000 +0200
+@@ -26,7 +26,7 @@
+ install -d $(AUTOLOAD_DIR)
+ cp $(GLIBNAME) $(AUTOLOAD_DIR)
+ cp $(OLIBNAME) $(AUTOLOAD_DIR)
+- test -d ${GRASSTABLES_DIR} || mkdir ${GRASSTABLES_DIR}
++ test -d ${GRASSTABLES_DIR} || mkdir -p ${GRASSTABLES_DIR}
+ test -d ${GRASSTABLES_DIR}/etc || mkdir ${GRASSTABLES_DIR}/etc
+ cp @GRASS_GISBASE@/etc/ellipse.table ${GRASSTABLES_DIR}/etc
+ cp @GRASS_GISBASE@/etc/datum.table @GRASS_GISBASE@/etc/datumtransform.table ${GRASSTABLES_DIR}/etc
diff --git a/sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild b/sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild
new file mode 100644
index 000000000000..45f5cdfac302
--- /dev/null
+++ b/sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gdal-grass/gdal-grass-1.4.3.ebuild,v 1.1 2009/11/21 20:06:52 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="GDAL plugin to access GRASS data"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+RDEPEND="sci-libs/gdal
+ sci-geosciences/grass"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+}
+
+src_configure() {
+ GRASS_ENVD="/etc/env.d/99grass /etc/env.d/99grass-6 /etc/env.d/99grass-cvs";
+ for file in ${GRASS_ENVD}; do
+ if test -r ${file}; then
+ GRASSPATH=$(sed -n 's/LDPATH="\(.*\)\/lib"$/\1/p' ${file});
+ fi
+ done
+ econf --with-grass=${GRASSPATH} --with-gdal
+}
+
+src_install() {
+ #pass the right variables to 'make install' to prevent a sandbox access violation
+ emake DESTDIR="${D}" \
+ GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
+ AUTOLOAD_DIR="${D}/usr/lib/gdalplugins" \
+ install || die "emake install failure"
+}
diff --git a/sci-geosciences/gdal-grass/metadata.xml b/sci-geosciences/gdal-grass/metadata.xml
new file mode 100644
index 000000000000..0fcb66048e40
--- /dev/null
+++ b/sci-geosciences/gdal-grass/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+</pkgmetadata>
+