summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-03-10 18:42:06 +0000
committerHans de Graaff <graaff@gentoo.org>2015-03-10 18:42:06 +0000
commit1663867ee1b64e4d19e64f323a170ffda015d648 (patch)
tree2e732a90b451bdb1db8c292229d3f00540b60ff3 /sci-geosciences/viking
parentMask broken rb_libtorrent ebuild due to #539368 and #542434 (diff)
downloadgentoo-2-1663867ee1b64e4d19e64f323a170ffda015d648.tar.gz
gentoo-2-1663867ee1b64e4d19e64f323a170ffda015d648.tar.bz2
gentoo-2-1663867ee1b64e4d19e64f323a170ffda015d648.zip
Add upstream patch to fix compilation with newer gpsd versions, fixing bug 541646.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'sci-geosciences/viking')
-rw-r--r--sci-geosciences/viking/ChangeLog7
-rw-r--r--sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch53
-rw-r--r--sci-geosciences/viking/viking-1.5.1.ebuild10
3 files changed, 67 insertions, 3 deletions
diff --git a/sci-geosciences/viking/ChangeLog b/sci-geosciences/viking/ChangeLog
index 6345a28fd409..f25acccaa101 100644
--- a/sci-geosciences/viking/ChangeLog
+++ b/sci-geosciences/viking/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/viking
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/ChangeLog,v 1.28 2015/03/09 19:59:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/ChangeLog,v 1.29 2015/03/10 18:42:06 graaff Exp $
+
+ 10 Mar 2015; Hans de Graaff <graaff@gentoo.org> viking-1.5.1.ebuild,
+ +files/viking-1.5.1-gpsd-3.13.patch:
+ Add upstream patch to fix compilation with newer gpsd versions, fixing bug
+ 541646.
09 Mar 2015; Hans de Graaff <graaff@gentoo.org> viking-1.5.1.ebuild:
Limit gpsd dependency to compatible versions for bug 541646.
diff --git a/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch b/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch
new file mode 100644
index 000000000000..d559746ff81c
--- /dev/null
+++ b/sci-geosciences/viking/files/viking-1.5.1-gpsd-3.13.patch
@@ -0,0 +1,53 @@
+commit 25043ca24a55468dc9eeaa7335a24d132c51b07d
+Author: Rob Norris <rw_norris@hotmail.com>
+Date: Mon Mar 9 23:25:15 2015 +0000
+
+ SF Bugs#117: Confirm capability with GPSD_API_MAJOR_VERSION=6 (gpsd 3.12 / libgps.so.22)
+
+diff --git a/src/vikgpslayer.c b/src/vikgpslayer.c
+index daf6d42..ca4be29 100644
+--- a/src/vikgpslayer.c
++++ b/src/vikgpslayer.c
+@@ -1673,7 +1673,7 @@ static gboolean gpsd_data_available(GIOChannel *source, GIOCondition condition,
+ if (condition == G_IO_IN) {
+ #if GPSD_API_MAJOR_VERSION == 3 || GPSD_API_MAJOR_VERSION == 4
+ if (!gps_poll(&vgl->vgpsd->gpsd)) {
+-#elif GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ if (gps_read(&vgl->vgpsd->gpsd) > -1) {
+ // Reuse old function to perform operations on the new GPS data
+ gpsd_raw_hook(vgl->vgpsd, NULL);
+@@ -1718,7 +1718,7 @@ static gboolean rt_gpsd_try_connect(gpointer *data)
+ vgl->vgpsd = g_malloc(sizeof(VglGpsd));
+
+ if (gps_open_r(vgl->gpsd_host, vgl->gpsd_port, /*(struct gps_data_t *)*/vgl->vgpsd) != 0) {
+-#elif GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ vgl->vgpsd = g_malloc(sizeof(VglGpsd));
+ if (gps_open(vgl->gpsd_host, vgl->gpsd_port, &vgl->vgpsd->gpsd) != 0) {
+ #else
+@@ -1757,7 +1757,7 @@ static gboolean rt_gpsd_try_connect(gpointer *data)
+ #if GPSD_API_MAJOR_VERSION == 3
+ gps_query(&vgl->vgpsd->gpsd, "w+x");
+ #endif
+-#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ gps_stream(&vgl->vgpsd->gpsd, WATCH_ENABLE, NULL);
+ #endif
+
+@@ -1813,13 +1813,13 @@ static void rt_gpsd_disconnect(VikGpsLayer *vgl)
+ vgl->realtime_io_channel = NULL;
+ }
+ if (vgl->vgpsd) {
+-#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#if GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ gps_stream(&vgl->vgpsd->gpsd, WATCH_DISABLE, NULL);
+ #endif
+ gps_close(&vgl->vgpsd->gpsd);
+ #if GPSD_API_MAJOR_VERSION == 3
+ free(vgl->vgpsd);
+-#elif GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5
++#elif GPSD_API_MAJOR_VERSION == 4 || GPSD_API_MAJOR_VERSION == 5 || GPSD_API_MAJOR_VERSION == 6
+ g_free(vgl->vgpsd);
+ #endif
+ vgl->vgpsd = NULL;
diff --git a/sci-geosciences/viking/viking-1.5.1.ebuild b/sci-geosciences/viking/viking-1.5.1.ebuild
index 26e17c1e9642..dea09aa1cf12 100644
--- a/sci-geosciences/viking/viking-1.5.1.ebuild
+++ b/sci-geosciences/viking/viking-1.5.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/viking-1.5.1.ebuild,v 1.2 2015/03/09 19:59:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/viking/viking-1.5.1.ebuild,v 1.3 2015/03/10 18:42:06 graaff Exp $
EAPI=5
+inherit eutils
+
DESCRIPTION="GPS data editor and analyzer"
HOMEPAGE="http://viking.sourceforge.net/"
IUSE="doc +exif gps +magic nls"
@@ -23,7 +25,7 @@ COMMONDEPEND="
sys-libs/zlib
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:2
- gps? ( >=sci-geosciences/gpsd-2.96 <sci-geosciences/gpsd-3.12 )
+ gps? ( >=sci-geosciences/gpsd-2.96 )
exif? ( media-libs/libexif )
magic? ( sys-apps/file )
"
@@ -40,6 +42,10 @@ DEPEND="${COMMONDEPEND}
sys-devel/gettext
"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gpsd-3.13.patch
+}
+
src_configure() {
econf \
--disable-deprecations \