summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-04-22 13:41:52 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-04-22 13:41:52 +0000
commitfa94f2998416c7a493155fbf835f5673ba156b04 (patch)
tree04861d054e7507ecd5076bda0a0108e5ef351b57 /sci-geosciences/seawater
parentRemove unused USE="consolekit" and USE="gnome-keyring" from metadata.xml (diff)
downloadgentoo-2-fa94f2998416c7a493155fbf835f5673ba156b04.tar.gz
gentoo-2-fa94f2998416c7a493155fbf835f5673ba156b04.tar.bz2
gentoo-2-fa94f2998416c7a493155fbf835f5673ba156b04.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'sci-geosciences/seawater')
-rw-r--r--sci-geosciences/seawater/ChangeLog9
-rw-r--r--sci-geosciences/seawater/seawater-3.3.2.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/sci-geosciences/seawater/ChangeLog b/sci-geosciences/seawater/ChangeLog
index 1a1a9e15c6ec..ba438af7d6e3 100644
--- a/sci-geosciences/seawater/ChangeLog
+++ b/sci-geosciences/seawater/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/seawater
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/seawater/ChangeLog,v 1.8 2013/09/05 19:04:16 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/seawater/ChangeLog,v 1.9 2014/04/22 13:41:52 hasufell Exp $
+
+*seawater-3.3.2 (22 Apr 2014)
+
+ 22 Apr 2014; Julian Ospald <hasufell@gentoo.org> +seawater-3.3.2.ebuild:
+ version bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> seawater-2.0.1.ebuild,
seawater-3.3.1.ebuild, seawater-3.3.ebuild:
diff --git a/sci-geosciences/seawater/seawater-3.3.2.ebuild b/sci-geosciences/seawater/seawater-3.3.2.ebuild
new file mode 100644
index 000000000000..f9dca31d646f
--- /dev/null
+++ b/sci-geosciences/seawater/seawater-3.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/seawater/seawater-3.3.2.ebuild,v 1.1 2014/04/22 13:41:52 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 )
+inherit distutils-r1
+
+DESCRIPTION="Python version of the SEAWATER 3.2 MATLAB toolkit for calculating the properties of sea water"
+HOMEPAGE="http://pypi.python.org/pypi/seawater/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # seems there are files missing
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/oct2py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}