summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-24 17:43:07 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-24 17:43:07 +0000
commitd859cafa063c241334c6a78daeee25fb0b7acc93 (patch)
tree255a8198891caa32c51cfbb3ca8859bd097ec16b /sci-geosciences/qgis
parentVersion bump. Clean up. (diff)
downloadgentoo-2-d859cafa063c241334c6a78daeee25fb0b7acc93.tar.gz
gentoo-2-d859cafa063c241334c6a78daeee25fb0b7acc93.tar.bz2
gentoo-2-d859cafa063c241334c6a78daeee25fb0b7acc93.zip
Version bump, from the science overlay by Christian Schmitt
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/qgis')
-rw-r--r--sci-geosciences/qgis/ChangeLog9
-rw-r--r--sci-geosciences/qgis/qgis-1.4.0.ebuild86
2 files changed, 93 insertions, 2 deletions
diff --git a/sci-geosciences/qgis/ChangeLog b/sci-geosciences/qgis/ChangeLog
index b0966cc27f67..76ac4d7fb1d9 100644
--- a/sci-geosciences/qgis/ChangeLog
+++ b/sci-geosciences/qgis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/qgis
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.3 2009/12/15 10:59:40 scarabeus Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/ChangeLog,v 1.4 2010/01/24 17:43:07 bicatali Exp $
+
+*qgis-1.4.0 (24 Jan 2010)
+
+ 24 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> +qgis-1.4.0.ebuild:
+ Version bump, from the science overlay by Christian Schmitt
15 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org> qgis-1.3.0.ebuild:
Update deps to reflect reality bit more. Move to new cmake-utils syntax.
diff --git a/sci-geosciences/qgis/qgis-1.4.0.ebuild b/sci-geosciences/qgis/qgis-1.4.0.ebuild
new file mode 100644
index 000000000000..94dcb21de4ad
--- /dev/null
+++ b/sci-geosciences/qgis/qgis-1.4.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/qgis/qgis-1.4.0.ebuild,v 1.1 2010/01/24 17:43:07 bicatali Exp $
+
+EAPI="2"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="User friendly Geographic Information System"
+HOMEPAGE="http://www.qgis.org/"
+
+SRC_URI="http://download.osgeo.org/${PN}/src/${PN}_${PV}.tar.gz
+ examples? ( http://download.osgeo.org/qgis/data/qgis_sample_data.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples gps grass gsl postgres python sqlite"
+
+RDEPEND=">=sci-libs/gdal-1.6.1
+ x11-libs/qt-core:4[qt3support]
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ x11-libs/qt-sql:4
+ sci-libs/geos
+ sci-libs/proj
+ gps? ( dev-libs/expat sci-geosciences/gpsbabel )
+ grass? ( >=sci-geosciences/grass-6 sci-geosciences/gdal-grass )
+ gsl? ( sci-libs/gsl )
+ postgres? ( >=virtual/postgresql-base-8 )
+ python? ( dev-lang/python[sqlite] dev-python/PyQt4[sql,svg] )
+ sqlite? ( dev-db/sqlite:3 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+src_configure() {
+ local mycmakeargs
+ mycmakeargs+=(
+ "-DBUILD_SHARED_LIBS:BOOL=ON"
+ "-DBINDINGS_GLOBAL_INSTALL:BOOL=ON"
+ "-DQGIS_LIB_SUBDIR=$(get_libdir)"
+ "-DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis"
+ $(cmake-utils_use_with postgres POSTGRESQL)
+ $(cmake-utils_use_with grass)
+ $(cmake-utils_use_with gps EXPAT)
+ $(cmake-utils_use_with gsl)
+ $(cmake-utils_use_with python BINDINGS)
+ $(cmake-utils_use_with sqlite SPATIALITE)
+ )
+
+ if use grass; then
+ GRASS_ENVD="/etc/env.d/99grass /etc/env.d/99grass-6 /etc/env.d/99grass-cvs";
+ for file in ${GRASS_ENVD}; do
+ if test -r ${file}; then
+ GRASSPATH=$(sed -n 's/LDPATH="\(.*\)\/lib"$/\1/p' ${file});
+ fi
+ done
+ mycmakeargs+=(
+ "-DGRASS_PREFIX=${GRASSPATH}"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS BUGS ChangeLog README SPONSORS CONTRIBUTORS
+
+ newicon images/icons/qgis-icon.png qgis.png
+ make_desktop_entry qgis "Quantum GIS " qgis.png
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${WORKDIR}"/qgis_sample_data/* || die "Unable to install examples"
+ fi
+}
+
+pkg_postinst() {
+ if use postgres; then
+ elog "If you don't intend to use an external PostGIS server"
+ elog "you should install:"
+ elog " dev-db/postgis"
+ fi
+}