summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-03-14 13:00:38 +0000
committerHanno Böck <hanno@gentoo.org>2009-03-14 13:00:38 +0000
commitfc901993c58a31a0df341037115218bb80b1a280 (patch)
tree73e37b9481f2f4b16ede15583f3b18cea9e6e19b /sci-geosciences/osmosis
parentDrop remaining USE=bootstrap usage #256439. (diff)
downloadgentoo-2-fc901993c58a31a0df341037115218bb80b1a280.tar.gz
gentoo-2-fc901993c58a31a0df341037115218bb80b1a280.tar.bz2
gentoo-2-fc901993c58a31a0df341037115218bb80b1a280.zip
osmosis bump
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/osmosis')
-rw-r--r--sci-geosciences/osmosis/ChangeLog9
-rw-r--r--sci-geosciences/osmosis/osmosis-0.30.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/sci-geosciences/osmosis/ChangeLog b/sci-geosciences/osmosis/ChangeLog
index 4b89d58a33aa..9f401c9666ca 100644
--- a/sci-geosciences/osmosis/ChangeLog
+++ b/sci-geosciences/osmosis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/osmosis
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osmosis/ChangeLog,v 1.2 2008/11/16 12:41:58 hanno Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osmosis/ChangeLog,v 1.3 2009/03/14 13:00:38 hanno Exp $
+
+*osmosis-0.30 (14 Mar 2009)
+
+ 14 Mar 2009; Hanno Boeck <hanno@gentoo.org> +osmosis-0.30.ebuild:
+ Version bump.
16 Nov 2008; Hanno Boeck <hanno@gentoo.org> osmosis-0.29.ebuild:
Add ~amd64.
diff --git a/sci-geosciences/osmosis/osmosis-0.30.ebuild b/sci-geosciences/osmosis/osmosis-0.30.ebuild
new file mode 100644
index 000000000000..8efda60fd59a
--- /dev/null
+++ b/sci-geosciences/osmosis/osmosis-0.30.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/osmosis/osmosis-0.30.ebuild,v 1.1 2009/03/14 13:00:38 hanno Exp $
+
+WANT_ANT_TASKS="ant-nodeps"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Commandline tool to process openstreetmap data"
+HOMEPAGE="http://wiki.openstreetmap.org/index.php/Osmosis"
+SRC_URI="http://gweb.bretth.com/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ eant build_binary || die
+}
+
+src_install() {
+ java-pkg_newjar "${PN}.jar" || die "java-pkg_newjar failed"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar" || die "java-pkg_dolauncher failed"
+
+ dodoc readme.txt changes.txt doc/*.txt || die "dodoc failed"
+}