summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-11-15 04:05:27 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-11-15 04:05:27 +0000
commitbff1854908dd95506ad96bb6e78ccf196b98c20c (patch)
treeec68802f2b77edfe79d7df22da3099bfb541fccc /sci-geosciences/grass
parentAdd USE=static-libs support. (diff)
downloadgentoo-2-bff1854908dd95506ad96bb6e78ccf196b98c20c.tar.gz
gentoo-2-bff1854908dd95506ad96bb6e78ccf196b98c20c.tar.bz2
gentoo-2-bff1854908dd95506ad96bb6e78ccf196b98c20c.zip
Added small fixes for bugs 375999 and 381763.
(Portage version: 2.1.10.32/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/ChangeLog7
-rw-r--r--sci-geosciences/grass/files/grass-6.4.1-nopycompile.patch12
-rw-r--r--sci-geosciences/grass/files/grass-6.4.1-timer_flags.patch13
-rw-r--r--sci-geosciences/grass/grass-6.4.1.ebuild6
4 files changed, 34 insertions, 4 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index 9749ab7eb834..f2caa5f6e85e 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/grass
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.108 2011/09/27 11:21:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.109 2011/11/15 04:05:27 nerdboy Exp $
+
+ 15 Nov 2011; Steve Arnold <nerdboy@gentoo.org> grass-6.4.1.ebuild,
+ +files/grass-6.4.1-nopycompile.patch, +files/grass-6.4.1-timer_flags.patch:
+ Added small fixes for bugs 375999 and 381763. Thanks to Chris Mayo for
+ the second patch. Not addressing other upstream issues at this time.
27 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> grass-6.4.1.ebuild,
+files/grass-6.4.1-libpng15.patch:
diff --git a/sci-geosciences/grass/files/grass-6.4.1-nopycompile.patch b/sci-geosciences/grass/files/grass-6.4.1-nopycompile.patch
new file mode 100644
index 000000000000..75f173aded0c
--- /dev/null
+++ b/sci-geosciences/grass/files/grass-6.4.1-nopycompile.patch
@@ -0,0 +1,12 @@
+diff -ur grass-6.4.1.orig/gui/wxpython/Makefile grass-6.4.1/gui/wxpython/Makefile
+--- grass-6.4.1.orig/gui/wxpython/Makefile
++++ grass-6.4.1/gui/wxpython/Makefile
+@@ -11,7 +11,7 @@
+ ETCDIR = $(ETC)/wxpython
+
+ SRCFILES := $(wildcard compat/* gui_modules/* icons/*.* icons/silk/* images/* xml/*) gis_set.py wxgui.py README
+-DSTFILES := $(patsubst %,$(ETCDIR)/%,$(SRCFILES)) $(patsubst %.py,$(ETCDIR)/%.pyc,$(filter %.py,$(SRCFILES)))
++DSTFILES := $(patsubst %,$(ETCDIR)/%,$(SRCFILES))
+
+ default: install_scripts
+ $(MAKE) parsubdirs
diff --git a/sci-geosciences/grass/files/grass-6.4.1-timer_flags.patch b/sci-geosciences/grass/files/grass-6.4.1-timer_flags.patch
new file mode 100644
index 000000000000..7c25094728da
--- /dev/null
+++ b/sci-geosciences/grass/files/grass-6.4.1-timer_flags.patch
@@ -0,0 +1,13 @@
+--- tools/timer/Makefile.orig 2011-11-14 18:58:13.000000000 -0800
++++ tools/timer/Makefile 2011-11-14 19:00:41.000000000 -0800
+@@ -8,8 +8,8 @@
+ default: $(ETC)/$(PGM)
+
+ $(ETC)/$(PGM): main.c
+- $(CC) -c $<
+- $(CC) -o $(ETC)/$(PGM) $<
++ $(CC) $(CFLAGS) -c $<
++ $(CC) $(LDFLAGS) -o $(ETC)/$(PGM) $<
+
+ clean:
+ \rm -f $(ETC)/$(PGM) main.o
diff --git a/sci-geosciences/grass/grass-6.4.1.ebuild b/sci-geosciences/grass/grass-6.4.1.ebuild
index 984f83ccd308..1ecf735c2274 100644
--- a/sci-geosciences/grass/grass-6.4.1.ebuild
+++ b/sci-geosciences/grass/grass-6.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.1.ebuild,v 1.8 2011/09/27 11:21:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.4.1.ebuild,v 1.9 2011/11/15 04:05:27 nerdboy Exp $
EAPI=3
@@ -87,6 +87,8 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-pkgconf.patch
"${FILESDIR}"/${P}-libpng15.patch
+ "${FILESDIR}"/${P}-nopycompile.patch
+ "${FILESDIR}"/${P}-timer_flags.patch
)
pkg_setup() {
@@ -124,8 +126,6 @@ pkg_setup() {
src_prepare() {
use opengl || epatch "${FILESDIR}"/${PN}-6.4.0-html-nonviz.patch
- # Hackish workaround to respect LDFLAGS. Bug #375999
- sed -i -e "s:-c:${CFLAGS} ${LDFLAGS} &:" "${S}"/tools/timer/Makefile
base_src_prepare
}