summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-12-19 05:57:29 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-12-19 05:57:29 +0000
commit31ede25eb8b018cbe1c5de523ff3ee2be84da1e0 (patch)
treeb4fdabd5752a974b3a2b9cfd4d5872a37230a919 /sci-geosciences/grass
parentAdded ~mips to KEYWORDS, per #245771. (diff)
downloadgentoo-2-31ede25eb8b018cbe1c5de523ff3ee2be84da1e0.tar.gz
gentoo-2-31ede25eb8b018cbe1c5de523ff3ee2be84da1e0.tar.bz2
gentoo-2-31ede25eb8b018cbe1c5de523ff3ee2be84da1e0.zip
Backported ffmpeg fixup and use flag cleanup (see bug #250850).
(Portage version: 2.2_rc16/cvs/Linux 2.6.27.7 x86_64)
Diffstat (limited to 'sci-geosciences/grass')
-rw-r--r--sci-geosciences/grass/ChangeLog8
-rw-r--r--sci-geosciences/grass/files/grass-6.2.1-gcc43.patch11
-rw-r--r--sci-geosciences/grass/grass-6.2.1.ebuild123
3 files changed, 71 insertions, 71 deletions
diff --git a/sci-geosciences/grass/ChangeLog b/sci-geosciences/grass/ChangeLog
index aceffae9e190..abefcbd44ffd 100644
--- a/sci-geosciences/grass/ChangeLog
+++ b/sci-geosciences/grass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/grass
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.65 2008/11/08 22:19:39 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/ChangeLog,v 1.66 2008/12/19 05:57:29 nerdboy Exp $
+
+ 19 Dec 2008; Steve Arnold <nerdboy@gentoo.org>
+ +files/grass-6.2.1-gcc43.patch, grass-6.2.1.ebuild:
+ Backported ffmpeg fixup and use flag cleanup (see bug #250850). Also
+ added ggc 4.3 include patch. Still need postgres 8.3 pushed to stable
+ before Grass 6.3 can go stable.
08 Nov 2008; Steve Arnold <nerdboy@gentoo.org> metadata.xml,
grass-6.3.0.ebuild:
diff --git a/sci-geosciences/grass/files/grass-6.2.1-gcc43.patch b/sci-geosciences/grass/files/grass-6.2.1-gcc43.patch
new file mode 100644
index 000000000000..556ac73168fe
--- /dev/null
+++ b/sci-geosciences/grass/files/grass-6.2.1-gcc43.patch
@@ -0,0 +1,11 @@
+diff -aur grass-6.2.3.orig/raster/r.terraflow/IOStream/include/ami_stream.h grass-6.2.3/raster/r.terraflow/IOStream/include/ami_stream.h
+--- grass-6.2.3.orig/raster/r.terraflow/IOStream/include/ami_stream.h 2004-11-09 14:29:58.000000000 +0100
++++ grass-6.2.3/raster/r.terraflow/IOStream/include/ami_stream.h 2008-03-21 01:03:36.000000000 +0100
+@@ -51,6 +51,7 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <cstring>
+
+ #include <iostream>
+ using namespace std;
diff --git a/sci-geosciences/grass/grass-6.2.1.ebuild b/sci-geosciences/grass/grass-6.2.1.ebuild
index 34901720b987..0099085239f5 100644
--- a/sci-geosciences/grass/grass-6.2.1.ebuild
+++ b/sci-geosciences/grass/grass-6.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.1.ebuild,v 1.14 2008/08/14 07:07:57 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/grass/grass-6.2.1.ebuild,v 1.15 2008/12/19 05:57:29 nerdboy Exp $
inherit eutils libtool
@@ -13,8 +13,8 @@ SLOT="6"
KEYWORDS="amd64 ppc sparc x86"
# To-do: get ppc64 gdal deps fixed up
-IUSE="ffmpeg fftw glw gmath jpeg largefile motif mysql nls odbc opengl png
-postgres python readline sqlite tcl tk tiff truetype X"
+IUSE="ffmpeg fftw gmath jpeg largefile motif mysql nls odbc opengl png \
+postgres python readline sqlite tiff truetype X"
RESTRICT="strip"
@@ -26,9 +26,7 @@ RDEPEND=">=sys-libs/zlib-1.1.4
sys-apps/man-db )
sci-libs/gdal
>=sci-libs/proj-4.4.7
- ffmpeg? ( <media-video/ffmpeg-0.4.9_p20070616-r20
- !=media-video/ffmpeg-0.4.9_p20070616-r1
- !=media-video/ffmpeg-0.4.9_p20070616-r2 )
+ ffmpeg? ( media-video/ffmpeg )
fftw? ( sci-libs/fftw )
gmath? ( virtual/blas
virtual/lapack )
@@ -36,15 +34,12 @@ RDEPEND=">=sys-libs/zlib-1.1.4
motif? ( x11-libs/openmotif )
mysql? ( dev-db/mysql )
odbc? ( >=dev-db/unixODBC-2.0.6 )
- opengl? ( ( virtual/opengl )
- glw? ( media-libs/mesa ) )
+ opengl? ( virtual/opengl )
png? ( >=media-libs/libpng-1.2.2 )
- postgres? ( >=virtual/postgresql-server-7.3 )
+ postgres? ( >=virtual/postgresql-base-7.3 )
python? ( dev-lang/python )
readline? ( sys-libs/readline )
sqlite? ( dev-db/sqlite )
- tcl? ( >=dev-lang/tcl-8.4 )
- tk? ( >=dev-lang/tk-8.4 )
tiff? ( >=media-libs/tiff-3.5.7 )
truetype? ( >=media-libs/freetype-2.0 )
X? (
@@ -57,19 +52,19 @@ RDEPEND=">=sys-libs/zlib-1.1.4
x11-libs/libICE
x11-libs/libXpm
x11-libs/libXaw
+ >=dev-lang/tcl-8.4
+ >=dev-lang/tk-8.4
)"
DEPEND="${RDEPEND}
- >=sys-devel/make-3.80
>=sys-devel/flex-2.5.4a
>=sys-devel/bison-1.35
- >=sys-devel/gcc-3.2.2
X? (
x11-proto/xproto
x11-proto/xextproto
)"
-src_unpack() {
+pkg_setup() {
local myblas
if use gmath; then
for d in $(eselect lapack show); do myblas=${d}; done
@@ -88,61 +83,45 @@ src_unpack() {
fi
fi
- if use glw && ! use opengl; then
- ewarn "You set USE='glw -opengl'. GLw support needs OpenGL."
- ewarn "OpenGL support also requires Tcl and Tk support."
- die "Set opengl, tcl, and tk useflags."
- fi
-
- if use glw && ! built_with_use media-libs/mesa motif; then
- ewarn "GRASS OpenGL support needs mesa with motif headers."
- ewarn "Please rebuild mesa with motif support."
- die "Re-emerge mesa with motif."
- fi
-
- if use opengl && ! use {tcl,tk}; then
- ewarn "GRASS OpenGL support needs both Tcl and Tk."
- die "Please set tcl and tk useflags."
- fi
-
- if use tcl && ! use tk; then
- ewarn "You set USE='tcl -tk'. GRASS needs both tcl and tk."
- die "Set tk useflag."
- fi
-
- if use tk && ! use tcl; then
- ewarn "You set USE='-tcl tk'. GRASS needs both tcl and tk."
- die "Set tcl useflag."
+ if use opengl && ! use X; then
+ ewarn "GRASS OpenGL support needs X (will also pull in Tcl/Tk)."
+ die "Please set the X useflag."
fi
+}
- if use tcl && built_with_use dev-lang/tcl threads; then
- ewarn "GRASS nviz will not work with Tcl compiled with threads!"
- ewarn "Please disable either opengl or tcl threads."
- die "Emerge TCL without threads."
- fi
- if use tk && built_with_use dev-lang/tk threads; then
- ewarn "GRASS nviz will not work with Tk compiled with threads!"
- ewarn "Please disable either opengl or tk threads."
- die "Emerge tk without threads."
- fi
+src_unpack() {
unpack ${A}
cd "${S}"
+
use ffmpeg && epatch "${FILESDIR}"/${P}-ffmpeg-fix.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
epatch rpm/fedora/grass-readline.patch
+
elibtoolize
+
+ # patch missing math functions (yes, this is still needed)
+ sed -i -e "s:\$(EXTRA_LIBS):\$(EXTRA_LIBS) \$(MATHLIB):g" include/Make/Shlib.make
+ echo "MATHLIB=-lm" >> include/Make/Rules.make
}
src_compile() {
local myconf
myconf="--prefix=/usr --with-cxx --enable-shared \
--with-gdal=$(type -P gdal-config) --with-curses --with-proj \
- --with-proj-includes=/usr/include --with-proj-libs=/usr/lib \
- --with-proj-share=/usr/share/proj"
-
- if use tcl || use tk; then
- myconf="${myconf} --with-tcltk \
- --with-tcltk-includes=/usr/include \
- --with-tcltk-libs=/usr/$(get_libdir)/tcl8.4 --with-x"
+ --with-includes=/usr/include --with-libs=/usr/$(get_libdir) \
+ --with-proj-includes=/usr/include \
+ --with-proj-libs=/usr/$(get_libdir) \
+ --with-proj-share=/usr/share/proj \
+ --without-glw --without-wxwidgets"
+ if use X; then
+ if has_version ">=dev-lang/tcl-8.5"; then
+ TCL_LIBDIR="/usr/$(get_libdir)/tcl8.5"
+ else
+ TCL_LIBDIR="/usr/$(get_libdir)/tcl8.4"
+ fi
+ myconf="${myconf} --with-tcltk --with-x \
+ --with-tcltk-includes=/usr/include \
+ --with-tcltk-libs=${TCL_LIBDIR}"
else
myconf="${myconf} --without-tcltk --without-x"
fi
@@ -150,28 +129,36 @@ src_compile() {
if use opengl; then
epatch "${FILESDIR}"/${P}-html-nviz-fix.patch
myconf="${myconf} --with-opengl --with-opengl-libs=/usr/$(get_libdir)/opengl/xorg-x11/lib"
- if use glw; then
- myconf="${myconf} --with-glw"
- fi
else
epatch "${FILESDIR}"/${P}-html-nonviz.patch
myconf="${myconf} --without-opengl --without-glw"
fi
+ # Should handle either older or latest without intervention;
+ # this won't work forever, but it should be okay for a while...
if use ffmpeg; then
- myconf="${myconf} --with-ffmpeg --with-ffmpeg-includes=/usr/include/ffmpeg --with-ffmpeg-libs=/usr/lib"
+ myconf="${myconf} --with-ffmpeg \
+ --with-ffmpeg-libs=/usr/$(get_libdir)"
+ if has_version ">=media-video/ffmpeg-0.4.9_p20080326" ; then
+ # must pass multiple include dirs now; if anyone has a better
+ # way to do this, please speak up and file a bug :)
+ myconf="${myconf} --with-ffmpeg-includes=/usr/include/libav*"
+ else
+ myconf="${myconf} --with-ffmpeg-includes=/usr/include/ffmpeg"
+ fi
else
- myconf="${myconf} --without-ffmpeg"
+ myconf="${myconf} --without-ffmpeg"
fi
if use truetype; then
- myconf="${myconf} --with-freetype --with-freetype-includes=/usr/include/freetype2"
+ myconf="${myconf} --with-freetype --with-freetype-includes=/usr/include/freetype2"
fi
if use mysql; then
- myconf="${myconf} --with-mysql --with-mysql-includes=/usr/include/mysql --with-mysql-libs=/usr/$(get_libdir)/mysql"
+ myconf="${myconf} --with-mysql --with-mysql-includes=/usr/include/mysql \
+ --with-mysql-libs=/usr/$(get_libdir)/mysql"
else
- myconf="${myconf} --without-mysql"
+ myconf="${myconf} --without-mysql"
fi
if use sqlite; then
@@ -181,7 +168,7 @@ src_compile() {
myconf="${myconf} --without-sqlite"
fi
- export LD_LIBRARY_PATH="/${WORKDIR}/image/usr/${P}/$(get_libdir):${LD_LIBRARY_PATH}"
+ #export LD_LIBRARY_PATH="/${WORKDIR}/image/usr/${P}/$(get_libdir):${LD_LIBRARY_PATH}"
econf ${myconf} --with-libs=/usr/$(get_libdir) \
$(use_enable amd64 64bit) \
$(use_with fftw) \
@@ -194,11 +181,7 @@ src_compile() {
$(use_with postgres) \
$(use_with python) \
$(use_with readline) \
- $(use_with tiff) \
- $(use_with tcl tcltk) || die "configure failed!"
- # patch missing math functions
- sed -i 's:EXTRA_LIBS=:EXTRA_LIBS=-lm :g' "${S}"/lib/gmath/Makefile
- sed -i 's:EXTRA_LIBS = :EXTRA_LIBS = -lm :g' "${S}"/lib/gis/Makefile
+ $(use_with tiff) || die "configure failed!"
emake -j1 || die "emake failed!"
}