summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-10-24 00:43:07 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-10-24 00:43:07 +0000
commitcfcb72642a3de86f84f6e47b08f7e08d42335e0d (patch)
tree0483cba31117be460e3ac0a238675bd1f18e4b2c /sci-geosciences/gpsd
parentInitial import, bug 152600, ebuild supplied by rbu (diff)
downloadgentoo-2-cfcb72642a3de86f84f6e47b08f7e08d42335e0d.tar.gz
gentoo-2-cfcb72642a3de86f84f6e47b08f7e08d42335e0d.tar.bz2
gentoo-2-cfcb72642a3de86f84f6e47b08f7e08d42335e0d.zip
updated with USE flag for TNT hardware support plus init script change for NTP
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/ChangeLog7
-rwxr-xr-xsci-geosciences/gpsd/files/gpsd.init3
-rw-r--r--sci-geosciences/gpsd/gpsd-2.33-r1.ebuild8
3 files changed, 12 insertions, 6 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 44a990372f64..1a05a0491874 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.20 2006/08/31 11:03:19 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.21 2006/10/24 00:43:07 nerdboy Exp $
+
+ 24 Oct 2006; Steve Arnold <nerdboy@gentoo.org> files/gpsd.init,
+ gpsd-2.33-r1.ebuild:
+ Updated with USE flag for TNT hardware support (it's the only one that's
+ default disabled) and init script change (bugs 144059 and 150141).
31 Aug 2006; Matthias Schwarzott <zzam@gentoo.org> ChangeLog:
Fixed double-utf8 encoding, see bug #125288.
diff --git a/sci-geosciences/gpsd/files/gpsd.init b/sci-geosciences/gpsd/files/gpsd.init
index 994145ac2e0b..26ae9152be92 100755
--- a/sci-geosciences/gpsd/files/gpsd.init
+++ b/sci-geosciences/gpsd/files/gpsd.init
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/files/gpsd.init,v 1.2 2006/05/08 05:30:35 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/files/gpsd.init,v 1.3 2006/10/24 00:43:07 nerdboy Exp $
# You can use this init script to manage a serial port GPS or other
# non-hotplug device (or any device for that matter). By design,
@@ -9,6 +9,7 @@
depend() {
after serial hotplug
+ before ntpd
}
checkconfig() {
diff --git a/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild b/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
index 89de2c29b0fe..03f9709a0def 100644
--- a/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild,v 1.1 2006/08/14 06:40:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.33-r1.ebuild,v 1.2 2006/10/24 00:43:07 nerdboy Exp $
inherit eutils libtool distutils
@@ -12,7 +12,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~arm ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="dbus ntp static usb X"
+IUSE="dbus ntp static tntc usb X"
RDEPEND="X? ( || (
( x11-libs/libXmu
@@ -70,8 +70,8 @@ src_compile() {
my_conf="${my_conf} --disable-ntpshm"
fi
- econf ${my_conf} $(use_with X x) $(use_enable dbus) \
- || die "econf failed"
+ econf ${my_conf} $(use_enable dbus) $(use_enable tntc tnt) \
+ $(use_with X x) || die "econf failed"
emake LDFLAGS="${LDFLAGS} -lm" || die "emake failed"
}