summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-16 11:07:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-16 11:07:47 +0000
commitb96007a40279d6725bc4c263f1db130d0ff1f523 (patch)
treef120afb20c1839104780ff1ad98c8570ffb4dddc /sci-geosciences/gpsd
parentFix underlinking (bug #367449) (diff)
downloadgentoo-2-b96007a40279d6725bc4c263f1db130d0ff1f523.tar.gz
gentoo-2-b96007a40279d6725bc4c263f1db130d0ff1f523.tar.bz2
gentoo-2-b96007a40279d6725bc4c263f1db130d0ff1f523.zip
Fix pkg-config usage.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gpsd')
-rw-r--r--sci-geosciences/gpsd/ChangeLog6
-rw-r--r--sci-geosciences/gpsd/files/2.96-pkgconfig.patch37
-rw-r--r--sci-geosciences/gpsd/gpsd-2.96.ebuild3
3 files changed, 44 insertions, 2 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index 9ba82e069511..d4c4f8caeb17 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.66 2011/05/16 10:43:42 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.67 2011/05/16 11:07:47 flameeyes Exp $
+
+ 16 May 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/2.96-pkgconfig.patch, gpsd-2.96.ebuild:
+ Fix pkg-config usage.
*gpsd-2.96 (16 May 2011)
diff --git a/sci-geosciences/gpsd/files/2.96-pkgconfig.patch b/sci-geosciences/gpsd/files/2.96-pkgconfig.patch
new file mode 100644
index 000000000000..b829c4730111
--- /dev/null
+++ b/sci-geosciences/gpsd/files/2.96-pkgconfig.patch
@@ -0,0 +1,37 @@
+Index: gpsd-2.96/configure.ac
+===================================================================
+--- gpsd-2.96.orig/configure.ac
++++ gpsd-2.96/configure.ac
+@@ -687,12 +687,7 @@ AC_MSG_CHECKING([for BlueZ support])
+ if test x"$ac_bluetooth" = x"yes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE(HAVE_BLUEZ,1,[Define if we have Bluez])
+- # Older versions of autotools barf and die on this.
+- #PKG_CHECK_MODULES(BLUEZ, bluez )
+- BLUEZ_CFLAGS=`pkg-config --cflags bluez`
+- BLUEZ_LIBS=`pkg-config --libs bluez`
+- AC_SUBST(BLUEZ_CFLAGS)
+- AC_SUBST(BLUEZ_LIBS)
++ PKG_CHECK_MODULES(BLUEZ, bluez )
+ else
+ AC_MSG_RESULT([no])
+ fi
+@@ -709,16 +704,8 @@ AC_MSG_CHECKING([for DBUS support])
+ if test x"$ac_dbus" = "xyes"; then
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([DBUS_ENABLE], 1, [DBUS support])
+- # Older versions of autotools barf and die on this.
+- #PKG_CHECK_MODULES(DBUS, dbus-1 >= 0.23.4 )
+- DBUS_CFLAGS=`pkg-config --cflags dbus-glib-1`
+- DBUS_LIBS=`pkg-config --libs dbus-1`
+- AC_SUBST(DBUS_CFLAGS)
+- AC_SUBST(DBUS_LIBS)
+- #PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1 >= 0.22 )
+- DBUS_GLIB_LIBS=`pkg-config --libs dbus-glib-1`
+- AC_SUBST(DBUS_GLIB_CFLAGS)
+- AC_SUBST(DBUS_GLIB_LIBS)
++ PKG_CHECK_MODULES(DBUS, dbus-1 >= 0.23.4 )
++ PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1 >= 0.22 )
+ else
+ AC_MSG_RESULT([no])
+ fi
diff --git a/sci-geosciences/gpsd/gpsd-2.96.ebuild b/sci-geosciences/gpsd/gpsd-2.96.ebuild
index b924ee6a0d98..9a768edf685c 100644
--- a/sci-geosciences/gpsd/gpsd-2.96.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.96.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.96.ebuild,v 1.1 2011/05/16 10:43:42 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.96.ebuild,v 1.2 2011/05/16 11:07:47 flameeyes Exp $
EAPI=3
@@ -46,6 +46,7 @@ PATCHES=(
"${FILESDIR}/2.95-disable-strip.patch"
"${FILESDIR}/${PV}-fix-ldflags.patch"
"${FILESDIR}/${PV}-fix-tests.patch"
+ "${FILESDIR}/${PV}-pkgconfig.patch"
)
pkg_setup() {