summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-02-23 20:03:59 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-02-23 20:03:59 +0000
commit526cb746c344f0db28fc5debe877057fdcf62f91 (patch)
treef3fd9163d614e3e6acbb3c4a30e4758a5226cffe /sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
parentApply the patch for bug #208631 also in 3.5.9. (diff)
downloadgentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.tar.gz
gentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.tar.bz2
gentoo-2-526cb746c344f0db28fc5debe877057fdcf62f91.zip
updated to latest version and new udev rules (closes bug #210079)
(Portage version: 2.1.4.1)
Diffstat (limited to 'sci-geosciences/gpsd/gpsd-2.34-r1.ebuild')
-rw-r--r--sci-geosciences/gpsd/gpsd-2.34-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild b/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
index 694b4c13c444..b7da424b212c 100644
--- a/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
+++ b/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild,v 1.2 2007/07/22 07:10:12 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-2.34-r1.ebuild,v 1.3 2008/02/23 20:03:58 nerdboy Exp $
inherit eutils autotools distutils
@@ -47,7 +47,7 @@ WANT_AUTOCONF=2.5
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
eautoreconf
}
@@ -81,8 +81,8 @@ src_compile() {
}
src_install() {
- cd ${S}
- make DESTDIR=${D} install
+
+ make DESTDIR="${D}" install
if use usb ; then
insinto /etc/hotplug/usb
@@ -91,8 +91,8 @@ src_install() {
doexe gpsd.hotplug
keepdir /var/run/usb # needed for REMOVER
else
- newconfd ${FILESDIR}/gpsd.conf gpsd
- newinitd ${FILESDIR}/gpsd.init gpsd
+ newconfd "${FILESDIR}"/gpsd.conf gpsd
+ newinitd "${FILESDIR}"/gpsd.init gpsd
fi
if use X ; then
@@ -109,7 +109,7 @@ src_install() {
doexe gps.py gpsfake.py gpspacket.so
fi
- dodoc AUTHORS COPYING INSTALL README TODO
+ dodoc AUTHORS INSTALL README TODO
# add missing include file (see bug #162361)
insinto /usr/include