summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-29 17:25:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-29 17:25:17 +0000
commitc5288da179d2aadf7df067bf0cf48230db089a6f (patch)
tree5d9edf0b5f608a748ff417090b4df0b65e702e57 /sci-geosciences/gmt
parentKeyword ~x86 (diff)
downloadgentoo-2-c5288da179d2aadf7df067bf0cf48230db089a6f.tar.gz
gentoo-2-c5288da179d2aadf7df067bf0cf48230db089a6f.tar.bz2
gentoo-2-c5288da179d2aadf7df067bf0cf48230db089a6f.zip
Version bump to latest release.
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'sci-geosciences/gmt')
-rw-r--r--sci-geosciences/gmt/ChangeLog8
-rw-r--r--sci-geosciences/gmt/gmt-4.5.8.ebuild86
-rw-r--r--sci-geosciences/gmt/metadata.xml1
3 files changed, 94 insertions, 1 deletions
diff --git a/sci-geosciences/gmt/ChangeLog b/sci-geosciences/gmt/ChangeLog
index 12feb19564b6..7570c1177050 100644
--- a/sci-geosciences/gmt/ChangeLog
+++ b/sci-geosciences/gmt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-geosciences/gmt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/ChangeLog,v 1.26 2012/05/29 11:51:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/ChangeLog,v 1.27 2012/05/29 17:25:17 scarabeus Exp $
+
+*gmt-4.5.8 (29 May 2012)
+
+ 29 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> +gmt-4.5.8.ebuild,
+ metadata.xml:
+ Version bump to latest release.
29 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> -gmt-4.0.ebuild,
gmt-4.5.6.ebuild:
diff --git a/sci-geosciences/gmt/gmt-4.5.8.ebuild b/sci-geosciences/gmt/gmt-4.5.8.ebuild
new file mode 100644
index 000000000000..1216cb27f0db
--- /dev/null
+++ b/sci-geosciences/gmt/gmt-4.5.8.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gmt/gmt-4.5.8.ebuild,v 1.1 2012/05/29 17:25:16 scarabeus Exp $
+
+EAPI=4
+
+inherit multilib autotools eutils
+
+GSHHS="gshhs-2.2.0"
+
+DESCRIPTION="Powerful map generator"
+HOMEPAGE="http://gmt.soest.hawaii.edu/"
+SRC_URI="mirror://gmt/${P}.tar.bz2
+ mirror://gmt/${GSHHS}.tar.bz2
+ gmttria? ( mirror://gmt/${P}-non-gpl.tar.bz2 )
+"
+LICENSE="GPL-2 gmttria? ( Artistic )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +gdal gmttria +metric mex +netcdf octave ps"
+
+RDEPEND="
+ !sci-biology/probcons
+ gdal? ( sci-libs/gdal )
+ netcdf? ( >=sci-libs/netcdf-4.1 )
+ octave? ( sci-mathematics/octave )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/GMT${PV}"
+
+# mex can use matlab too which i can't test
+REQUIRED_USE="
+ mex? ( octave )
+"
+
+# hand written make files that are not parallel safe
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ mv -f "${WORKDIR}/share/"* "${S}/share/" || die
+
+ epatch \
+ "${FILESDIR}/${PN}-4.5.0-no-strip.patch" \
+ "${FILESDIR}/${PN}-4.5.6-respect-ldflags.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/${P} \
+ --includedir=/usr/include/${P} \
+ --datadir=/usr/share/${P} \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-update \
+ --disable-matlab \
+ --disable-xgrid \
+ --enable-shared \
+ --disable-debug \
+ $(use_enable gdal) \
+ $(use_enable netcdf) \
+ $(use_enable octave) \
+ $(use_enable debug devdebug) \
+ $(use_enable !metric US) \
+ $(use_enable ps eps) \
+ $(use_enable mex) \
+ $(use_enable gmttria triangle)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ install-all
+
+ # remove static libs
+ find "${ED}/usr/$(get_libdir)" -name '*.a' -exec rm -f {} +
+
+ dodoc README
+
+ cat << _EOF_ > "${T}/99gmt"
+GMTHOME="${EPREFIX}/usr/share/${P}"
+GMT_SHAREDIR="${EPREFIX}/usr/share/${P}"
+_EOF_
+ doenvd "${T}/99gmt"
+}
diff --git a/sci-geosciences/gmt/metadata.xml b/sci-geosciences/gmt/metadata.xml
index 8c519f3c7f84..d870102f7c95 100644
--- a/sci-geosciences/gmt/metadata.xml
+++ b/sci-geosciences/gmt/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>sci-geosciences</herd>
<use>
+ <flag name='gdal'>Enable <pkg>sci-libs/gdal</pkg> library support</flag>
<flag name='gmtfull'>Full resolution bathymetry database</flag>
<flag name='gmthigh'>Add high resolution bathymetry database</flag>
<flag name='gmttria'>Non GNU triangulation method, more efficient</flag>