summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-05-06 15:56:43 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-05-06 15:56:43 +0000
commitd4f5b0e5bdca709725ca6653eac5e53ef62730e7 (patch)
treeb846cb3fda4a246ab46f8efb395b1906f5f643f3 /sci-electronics
parentAdded local USE flag gnuplot for sci-electronics/gwave. (diff)
downloadgentoo-2-d4f5b0e5bdca709725ca6653eac5e53ef62730e7.tar.gz
gentoo-2-d4f5b0e5bdca709725ca6653eac5e53ef62730e7.tar.bz2
gentoo-2-d4f5b0e5bdca709725ca6653eac5e53ef62730e7.zip
Version bump.
(Portage version: 2.1.2.5)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gwave/ChangeLog7
-rw-r--r--sci-electronics/gwave/files/digest-gwave-200606063
-rw-r--r--sci-electronics/gwave/gwave-20060606.ebuild32
3 files changed, 41 insertions, 1 deletions
diff --git a/sci-electronics/gwave/ChangeLog b/sci-electronics/gwave/ChangeLog
index 853f972410c5..1f6e3a3d01e8 100644
--- a/sci-electronics/gwave/ChangeLog
+++ b/sci-electronics/gwave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/gwave
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gwave/ChangeLog,v 1.11 2007/03/03 13:08:41 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gwave/ChangeLog,v 1.12 2007/05/06 15:56:43 calchan Exp $
+
+*gwave-20060606 (06 May 2007)
+
+ 06 May 2007; Denis Dupeyron <calchan@gentoo.org> +gwave-20060606.ebuild:
+ Version bump.
03 Mar 2007; Denis Dupeyron <calchan@gentoo.org> gwave-20031224.ebuild,
gwave-20051222.ebuild:
diff --git a/sci-electronics/gwave/files/digest-gwave-20060606 b/sci-electronics/gwave/files/digest-gwave-20060606
new file mode 100644
index 000000000000..330528a18315
--- /dev/null
+++ b/sci-electronics/gwave/files/digest-gwave-20060606
@@ -0,0 +1,3 @@
+MD5 43816379d75c17a8302df14350365b00 gwave-20060606.tar.gz 490107
+RMD160 67c6e9bb5a001352f627662bd6eb225a78d028e8 gwave-20060606.tar.gz 490107
+SHA256 4e69e31f261cf020b91fe66588ec85b58333adc70a38c7d96ff565b40faca92e gwave-20060606.tar.gz 490107
diff --git a/sci-electronics/gwave/gwave-20060606.ebuild b/sci-electronics/gwave/gwave-20060606.ebuild
new file mode 100644
index 000000000000..82fc7b1164a0
--- /dev/null
+++ b/sci-electronics/gwave/gwave-20060606.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gwave/gwave-20060606.ebuild,v 1.1 2007/05/06 15:56:43 calchan Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Analog waveform viewer for SPICE-like simulations"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.geda.seul.org/tools/gwave/"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnuplot plotutils"
+SLOT="0"
+
+DEPEND="=dev-scheme/guile-1.6*
+ =x11-libs/guile-gtk-1.2*"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )
+ plotutils? ( media-libs/plotutils )"
+
+src_compile() {
+ filter-ldflags -Wl,--as-needed --as-needed
+ econf --disable-dependency-tracking || die "Configuration failed"
+ make || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ rm -f doc/Makefile* *.1 || die "Removing doc/Makefile failed"
+ dodoc AUTHORS NEWS README TODO doc/* || die "Installation of documentation failed"
+}