summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2009-11-16 21:40:53 +0000
committerDenis Dupeyron <calchan@gentoo.org>2009-11-16 21:40:53 +0000
commitcfe1a68ee3473bd407ff04af6a19da2312722cfa (patch)
tree167f3682ab7b63f1474a7db7b6d2744f09e7e6e6 /sci-electronics
parentremove stray backslash, oops (diff)
downloadgentoo-2-cfe1a68ee3473bd407ff04af6a19da2312722cfa.tar.gz
gentoo-2-cfe1a68ee3473bd407ff04af6a19da2312722cfa.tar.bz2
gentoo-2-cfe1a68ee3473bd407ff04af6a19da2312722cfa.zip
Added live subversion ebuild.
(Portage version: 2.1.7.1/cvs/Linux i686)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad/ChangeLog7
-rw-r--r--sci-electronics/kicad/kicad-99999999.ebuild128
-rw-r--r--sci-electronics/kicad/metadata.xml11
3 files changed, 143 insertions, 3 deletions
diff --git a/sci-electronics/kicad/ChangeLog b/sci-electronics/kicad/ChangeLog
index 8f81182ae353..8a2e4a7c5595 100644
--- a/sci-electronics/kicad/ChangeLog
+++ b/sci-electronics/kicad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/kicad
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.43 2009/11/08 18:52:51 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/ChangeLog,v 1.44 2009/11/16 21:40:53 calchan Exp $
+
+*kicad-99999999 (16 Nov 2009)
+
+ 16 Nov 2009; Denis Dupeyron <calchan@gentoo.org> +kicad-99999999.ebuild:
+ Added live subversion ebuild.
08 Nov 2009; nixnut <nixnut@gentoo.org> kicad-20090320.1666-r2.ebuild:
ppc stable #285472
diff --git a/sci-electronics/kicad/kicad-99999999.ebuild b/sci-electronics/kicad/kicad-99999999.ebuild
new file mode 100644
index 000000000000..1f15e5d6942c
--- /dev/null
+++ b/sci-electronics/kicad/kicad-99999999.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/kicad/kicad-99999999.ebuild,v 1.1 2009/11/16 21:40:53 calchan Exp $
+
+EAPI="2"
+WX_GTK_VER="2.8"
+
+inherit cmake-utils wxwidgets fdo-mime gnome2-utils subversion
+
+DESCRIPTION="Electronic Schematic and PCB design tools."
+HOMEPAGE="http://kicad.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="dev-doc doc debug examples minimal python"
+
+CDEPEND="x11-libs/wxGTK:2.8[X,opengl]"
+DEPEND=">=dev-util/cmake-2.6.0
+ >=dev-libs/boost-1.39
+ dev-doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}
+ sys-libs/zlib
+ python? ( dev-lang/python )"
+
+src_unpack() {
+ local svn_uri_base="https://kicad.svn.sourceforge.net/svnroot/kicad/trunk"
+ subversion_fetch "${svn_uri_base}/kicad"
+ use minimal || subversion_fetch "${svn_uri_base}/kicad-library" kicad-library
+ use doc && subversion_fetch "${svn_uri_base}/kicad-doc" kicad-doc
+}
+
+src_prepare() {
+ subversion_src_prepare
+
+ # Use native boost
+ sed -i -e '/Boost/s/^#check_find_package/check_find_package/' \
+ -e '/Boost/s/^#find_package/find_package/' CMakeLists.txt || die "sed failed"
+
+ # Add important doc files
+ sed -i -e 's/INSTALL.txt/AUTHORS.txt CHANGELOG.txt README.txt TODO.txt/' CMakeLists.txt || die "sed failed"
+
+ # Fix desktop files
+ rm resources/linux/mime/applications/eeschema.desktop
+ sed -i -e 's/Development;//' resources/linux/mime/applications/kicad.desktop || die "sed failed"
+
+ # Handle optional minimal install
+ if use minimal ; then
+ sed -i -e '/add_subdirectory(template)/d' CMakeLists.txt || die "sed failed"
+ else
+ sed -i -e '/add_subdirectory(template)/a \
+add_subdirectory(kicad-library)' CMakeLists.txt || die "sed failed"
+ fi
+
+ # Add documentation and fix necessary code if requested
+ if use doc ; then
+ sed -i -e '/add_subdirectory(demos)/a \
+add_subdirectory(kicad-doc)' CMakeLists.txt || die "sed failed"
+ sed -i -e "s/subdirs.Add( wxT( \"kicad\" ) );/subdirs.Add( wxT( \"${PF}\" ) );/" \
+ -e '/subdirs.Add( _T( "help" ) );/d' common/edaappl.cpp || die "sed failed"
+ fi
+
+ # Install examples in the right place if requested
+ if use examples ; then
+ sed -i -e 's:${KICAD_DATA}/demos:${KICAD_DOCS}/examples:' CMakeLists.txt || die "sed failed"
+ else
+ sed -i -e '/add_subdirectory(demos)/d' CMakeLists.txt || die "sed failed"
+ fi
+}
+
+src_configure() {
+ need-wxwidgets unicode
+
+ mycmakeargs="${mycmakeargs}
+ -DKICAD_MINIZIP=OFF
+ -DKICAD_CYRILLIC=ON
+ -DwxUSE_UNICODE=ON
+ -DKICAD_GOST=OFF
+ -DKICAD_AUIMANAGER=OFF
+ -DKICAD_AUITOOLBAR=OFF
+ -DKICAD_DOCS=/usr/share/doc/${PF}
+ -DKICAD_HELP=/usr/share/doc/${PF}
+ $(cmake-utils_use python KICAD_PYTHON)"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use dev-doc && doxygen Doxyfile
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use dev-doc ; then
+ insinto /usr/share/doc/${PF}
+ doins uncrustify.cfg
+ cd Documentation
+ doins -r GUI_Translation_HOWTO.pdf guidelines/UIpolicies.txt doxygen/doxygen
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+
+ if use minimal ; then
+ ewarn "If the schematic and/or board editors complain about missing libraries when you"
+ ewarn "open old projects, you will have to take one or more of the following actions :"
+ ewarn "- Install the missing libraries manually."
+ ewarn "- Remove the libraries from the 'Libs and Dir' preferences."
+ ewarn "- Fix the libraries' locations in the 'Libs and Dir' preferences."
+ ewarn "- Emerge kicad without the 'minimal' USE flag."
+ elog
+ fi
+ elog "You may want to emerge media-gfx/wings if you want to create 3D models of components."
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
diff --git a/sci-electronics/kicad/metadata.xml b/sci-electronics/kicad/metadata.xml
index 33342106251a..328e3db19d20 100644
--- a/sci-electronics/kicad/metadata.xml
+++ b/sci-electronics/kicad/metadata.xml
@@ -1,9 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+
<herd>sci-electronics</herd>
+
<longdescription>
- Kicad is an open source (GPL) software for the creation of electronic
- schematic diagrams and printed circuit board artwork.
+ Kicad is an open source (GPL) software for the creation of electronic
+ schematic diagrams and printed circuit board artwork.
</longdescription>
+
+ <use>
+ <flag name="dev-doc">Install developer documentation (requires
+ <pkg>app-doc/doxygen</pkg>)</flag>
+ </use>
</pkgmetadata>