summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2015-06-15 17:27:19 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2015-06-15 17:27:19 +0000
commitcf4b2c3812546ee36010f746fc2ce14cba91b7de (patch)
tree84b87be2c876a41090d342ac5149bbfc075bd2bd /sci-electronics
parentUpdating remote-id in metadata.xml (diff)
downloadgentoo-2-cf4b2c3812546ee36010f746fc2ce14cba91b7de.tar.gz
gentoo-2-cf4b2c3812546ee36010f746fc2ce14cba91b7de.tar.bz2
gentoo-2-cf4b2c3812546ee36010f746fc2ce14cba91b7de.zip
Bug fix release
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x24083D3E28343508)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/xnec2c/ChangeLog7
-rw-r--r--sci-electronics/xnec2c/xnec2c-3.3.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sci-electronics/xnec2c/ChangeLog b/sci-electronics/xnec2c/ChangeLog
index 10071c3252f3..03ad3ad29eb7 100644
--- a/sci-electronics/xnec2c/ChangeLog
+++ b/sci-electronics/xnec2c/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-electronics/xnec2c
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.23 2015/02/22 08:22:34 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/ChangeLog,v 1.24 2015/06/15 17:27:19 tomjbe Exp $
+
+*xnec2c-3.3 (15 Jun 2015)
+
+ 15 Jun 2015; Thomas Beierlein <tomjbe@gentoo.org> +xnec2c-3.3.ebuild:
+ Bug fix release
*xnec2c-3.2 (22 Feb 2015)
diff --git a/sci-electronics/xnec2c/xnec2c-3.3.ebuild b/sci-electronics/xnec2c/xnec2c-3.3.ebuild
new file mode 100644
index 000000000000..79b462b683ea
--- /dev/null
+++ b/sci-electronics/xnec2c/xnec2c-3.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/xnec2c/xnec2c-3.3.ebuild,v 1.1 2015/06/15 17:27:19 tomjbe Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A GTK+ graphical interactive version of nec2c"
+HOMEPAGE="http://www.qsl.net/5b4az/pages/nec2.html"
+SRC_URI="http://www.qsl.net/5b4az/pkg/nec2/xnec2c/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ glib-gettextize --force --copy || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS README doc/*.txt
+ use doc && dohtml -r doc/*.html doc/images
+ insinto /usr/share/doc/${PF}/examples
+ use examples && doins examples/*
+}